Leica Disto API: Packages

Leica Disto API
  • Main Page
  • Packages
  • Classes
  • Packages
  • Package Functions
Packages
Here are the packages with brief descriptions (if available):
[detail level 1234]
\ N Leica
  \ N Disto
    o N Api
    | o N AsyncSubsystem
    | o N CommandInterface
    | o N Communication
    | o N Configuration
    | o N EventInterface
    | o N GeoMath
    | o N HardwareInterface
    | o N Logging
    | \ N SystemInterface
    \ N Networking
      \ N Windows
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica

  • Classes
  • Packages
  • Package Functions
Namespaces
Package Leica

Namespaces

package Disto
Generated on Tue Feb 24 2015 14:07:38 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto

  • Packages
  • Package Functions
  • Leica
  • Disto
Namespaces
Package Leica.Disto

Namespaces

package | Api
package | Networking
Generated on Tue Feb 24 2015 14:07:38 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
Namespaces
Package Leica.Disto.Api

Namespaces

package | AsyncSubsystem
package | CommandInterface
package | Communication
package | Configuration
package | EventInterface
package | GeoMath
package | HardwareInterface
package | Logging
package | SystemInterface
Generated on Tue Feb 24 2015 14:07:38 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.AsyncSubsystem

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • AsyncSubsystem
Classes | Enumerations | Functions
Package Leica.Disto.Api.AsyncSubsystem

Classes

class | InterruptReasonMask
wakeup mask for calls to WaitOnActionDone More...
class | ExceptionCleanupInitialize
system needs to initialize excetpion More...
class | ExceptionInvalidState
invalid state exception More...
class | ExceptionCleanupStop
system has stopped exception More...
class | ExceptionError
generic error exception More...
class | ExceptionCleanup
generic cleanup exception (cleanup = reaction exception after error messages have been displayed) More...
class | ExceptionCore
generic core exception More...
class | ExceptionTimeout
generic timeout exception More...
class | ExceptionInvalidParameter
generic timeout exception More...
class | ExceptionInvalidUsage
generic timeout exception More...
class | Subsystem
asynchronous subsystem base class More...
class | SyncObject
Object used for thread synchronization. It is mainly used as return value of asynchronous methods for communicating with the sensor. More...
class | SyncObject< T >
Object used for thread synchronization. It is mainly used as return value in asynchronous method declaration. More...

Enumerations

enum | EInterruptReason { EInterruptReason.ActionsDone, EInterruptReason.CommandAboveNormal, EInterruptReason.CommandHigh, EInterruptReason.Timeout }
interrupt reasons returned by WaitOnActionDone More...
enum | EAsyncCallQueue { EAsyncCallQueue.QueueHigh, EAsyncCallQueue.QueueAboveNormal, EAsyncCallQueue.QueueNormal, EAsyncCallQueue.QueueLastItem }
asynchronous interface command priorities More...
enum EAsyncThreadWakeUpReason {
EAsyncThreadWakeUpReason.WakeUpTerminateThread, EAsyncThreadWakeUpReason.WakeUpCommandNormal, EAsyncThreadWakeUpReason.WakeUpCommandAboveNormal, EAsyncThreadWakeUpReason.WakeUpCommandHigh,
EAsyncThreadWakeUpReason.WakeUpImplEvent, EAsyncThreadWakeUpReason.WakeUpTimeout, EAsyncThreadWakeUpReason.WakeUpLastItem
}
wake up reasons returned by WaitForEvent More...

Functions

delegate void ErrorCallbackDelegate (string p_Name, Exception p_Exception)
Delegate for the callback to be called if a work item does not terminate within the timeout More...

Enumeration Type Documentation

enum Leica.Disto.Api.AsyncSubsystem.EAsyncCallQueue

asynchronous interface command priorities

Enumerator
QueueHigh | Identifier for the "high priority" command queue
QueueAboveNormal | Identifier for the "above normal" command queue
QueueNormal | Identifier for the "normal" command queue
QueueLastItem | Identifier for the last item - used in iterations
enum Leica.Disto.Api.AsyncSubsystem.EAsyncThreadWakeUpReason

wake up reasons returned by WaitForEvent

Enumerator
WakeUpTerminateThread | terminate event was signalled
WakeUpCommandNormal | command with "normal" priority has been received
WakeUpCommandAboveNormal | command with "above normal" priority has been received
WakeUpCommandHigh | command with "high" priority has been received
WakeUpImplEvent | user event was signalled
WakeUpTimeout | timeout event was signalled
WakeUpLastItem | used for iterations, etc.
enum Leica.Disto.Api.AsyncSubsystem.EInterruptReason

interrupt reasons returned by WaitOnActionDone

Enumerator
ActionsDone | action completed normally (with or without error)
CommandAboveNormal | interrupted by a command with priority "above normal"
CommandHigh | interrupted by a command with priority "high"
Timeout | action did not complete but timed out

Function Documentation

delegate void Leica.Disto.Api.AsyncSubsystem.ErrorCallbackDelegate | ( | string | p_Name,
 |  | Exception | p_Exception
 | ) |  |

Delegate for the callback to be called if a work item does not terminate within the timeout

Parameters
p_Name
p_Exception
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.CommandInterface

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • CommandInterface
Classes | Enumerations
Package Leica.Disto.Api.CommandInterface

Classes

class | ExceptionCommandInterface
exception that is thrown from the command interface, when something bad is encountered in the input More...
class | Response
Represents the result that is returned by the Sensor, translated into binary data. The object contains a result object or an error code, but not boththey are mutually exclusive. More...
class | SnapshotImage
Implements a snapshot image that is returned from the sensor. More...

Enumerations

enum ETokenKind : int {
ETokenKind.cmd, ETokenKind.ok, ETokenKind.error, ETokenKind.trm,
ETokenKind.real, ETokenKind.str, ETokenKind.integer, ETokenKind.sep
}
The Lexer analyses teh ASCII stream and determines token. It can only figure out those which are composed of basic characters. More...

Enumeration Type Documentation

enum Leica.Disto.Api.CommandInterface.ETokenKind : int

The Lexer analyses teh ASCII stream and determines token. It can only figure out those which are composed of basic characters.

It is the Parser that can combine tokens into higher level datagrams since only he has a higher level context.

Enumerator
cmd | a command string
ok | the success value
error | the error indicator
trm | the termianator
real | floating point number value
str | a string value
integer | in fixed point number value
sep | a separator (whitespace)
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.Communication

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • Communication
Package Leica.Disto.Api.Communication
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.Configuration

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • Configuration
Classes
Package Leica.Disto.Api.Configuration

Classes

class SystemSettings
This class contains sensor settings like its (fixed) IP address over USB and WLAN. More...
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.EventInterface

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • EventInterface
Classes | Enumerations
Package Leica.Disto.Api.EventInterface

Classes

class | ExceptionEventInterface
exception that is thrown from the command interface, when something bad is encountered in the input More...
class | SensorEvent
Base class for concrete sensor events More...
class | SensorEventMotorStopped
concrete event representing the event when a motor(s) has been stopped More...
class | SensorEventBatteryStateChanged
concrete event representing the event when the battery's state has changed More...
class | SensorEventRemoteControlKeyPressed
concrete event representing the event when the remote control's key has been pressed More...
class | SensorEventInclinationPlaneChanged
concrete event representing the event when the state of the inclination plane has changed More...
class | SensorEventCalibration
concrete event representing the event when a calibration sequence finished More...
class | SensorEventSystemMessage
Concrete event representing the occurence of a system error or warning More...
class | SensorEventMeasurePolar
Concrete event representing the occurence of a Measure Polar with Image Event More...

Enumerations

enum ESystemMessage : int { ESystemMessage.Error, ESystemMessage.Warning }
The type of message from the sensor (SkyCom 3.4) More...

Enumeration Type Documentation

enum Leica.Disto.Api.EventInterface.ESystemMessage : int

The type of message from the sensor (SkyCom 3.4)

Enumerator
Error | Identifies a System Error (SkyCom 3.4.1)
Warning | Identifies a System Warning (SkyCom 3.4.2)
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.GeoMath

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • GeoMath
Classes | Enumerations
Package Leica.Disto.Api.GeoMath

Classes

class | Angle
functions that can be applied to angles in [rad] More...
class | IdentifiedObject
Base class for objects which need a unique id for persisting them More...
class | LiveImagePixelConverter
Converter class for transforming sensor directions to pixel coordinates and back. More...
struct | Point
Struct representing a point, with double coordinates More...
class | SensorDirection
class | SensorIncline
Represents the inclination plane values from the sensor. More...
class | SensorPoint
Point defined with polar coordinates More...
struct | Size
Struct representing a size defined by width and heigt More...
class | Vector
Class for 3d vectors More...

Enumerations

enum InclinationPlaneState : int {
InclinationPlaneState.UpToDate = 0, InclinationPlaneState.Identical = 1, InclinationPlaneState.Obsolete = 2, InclinationPlaneState.Changed = 3,
InclinationPlaneState.Undefined = 4, InclinationPlaneState.Disabled = 5, InclinationPlaneState.Unstable = 6
}
the states of the inclination plane More...

Enumeration Type Documentation

enum Leica.Disto.Api.GeoMath.InclinationPlaneState : int

the states of the inclination plane

Enumerator
UpToDate | plane measurement is up to date {0}
Identical | last and current plane measurements are identical {1}
Obsolete | plane measurement is obsolete and cannot be determined {2}
Changed | last and current plane measurements have changed {3}
Undefined | plane measurement has not been done yet and is undefined {4}
Disabled | plane measurement is deactivated {5}
Unstable | plane measurement is unstable {6}
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.HardwareInterface

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • HardwareInterface
Classes | Enumerations | Functions
Package Leica.Disto.Api.HardwareInterface

Classes

class | Resolution5Mpix
5M pix image resolution More...
class | ResolutionDVGA
DVGA image resolution More...
class | ResolutionVGA
VGA image resolution More...
class | ResolutionQVGA
QVGA image resolution More...
class | ResolutionSVGA
SVGA image resolution, supported on LD5+ devices More...
class | ResolutionUXGA
UXGA image resolution, supported on LD5+ devices More...
class | SensorError
Error numbers (SkyCom 3.6) More...
interface | ILiveImage
Represents the image that is returned from the sensor when live-image is turned on. More...
interface | ISensorData
Description: Provides the interface to the Sensor's mirrored data values Responsibilities: mirrors the Sensor's data values and provides an interface to it Collaborators: an implementation of ISensor More...
interface | IAxisData
Description: Provides the interface to an Axis's mirrored data values More...
class | SensorTemperatures
consolidates the different temperatures measured on the sensor More...
class | SensorBatteryState
the sensor battery's state, i.e. current voltage level and an indicator of the battery's charging level. More...
interface | ISensorEvent
interface | ISensorEvents
Defines the sensor's event interface, i.e. which events the sensor generates. More...
interface | ISnapImage
Represents a snapshot image that is returned from the sensor by a image-snap command. More...
class | RemoteControlKey
the keys on the remote control More...

Enumerations

enum | EDeviceType { EDeviceType.UnknownDevice, EDeviceType.Disto3D, EDeviceType.DistoLd5Plus }
Device/interface type More...
enum LevelMode : byte {
LevelMode.Disabled = (byte)'D', LevelMode.Enabled = (byte)'E', LevelMode.Immediate = (byte)'I', LevelMode.Suspend = (byte)'L',
LevelMode.Resume = (byte)'U', LevelMode.Calibrate = (byte)'C'
}
Defines how the inclination error compensator operates. More...
enum | TiltSensorMode : int { TiltSensorMode.Sensitive = 0, TiltSensorMode.Rugged = 1, TiltSensorMode.Disabled = 2 }
Defines the tilt sensors sensitivity mode. If the sensor notices that the tilt plane has changed, it will start leveling. More...
enum | LaserMode : byte { LaserMode.Blink = (byte)'B', LaserMode.Point = (byte)'P', LaserMode.Off = (byte)'O', LaserMode.Continuous = (byte)'C' }
Different laser modes. More...
enum ImageResolution : byte {
ImageResolution.Mega = (byte)'M', ImageResolution.High = (byte)'H', ImageResolution.Normal = (byte)'N', ImageResolution.Low = (byte)'L',
ImageResolution.ViewFinder = (byte)'V'
}
defines the possible resolutions for snapshot images More...
enum ECommand : int {
ECommand.Invalid, ECommand.Ping, ECommand.Pin, ECommand.Puk,
ECommand.PowerOff, ECommand.LaserMode, ECommand.LevelMode, ECommand.MeasureIncline,
ECommand.MeasureAngle, ECommand.MeasurePolar, ECommand.PositionVelocity, ECommand.PositionDirection,
ECommand.PositionGo, ECommand.PositionStop, ECommand.PositionAbsolute, ECommand.PositionRelative,
ECommand.GetFace, ECommand.GetMotorStatus, ECommand.ImageMode, ECommand.ImageZoom,
ECommand.ImageBrightness, ECommand.ImageSnap, ECommand.GetValue, ECommand.SetValue,
ECommand.SaveUserCalibration, ECommand.ResetUserCalibration, ECommand.GetTemperature, ECommand.GetBattery
}
defines the commands that must be accepted by an implementation of ISensor More...
enum | ImageZoom : byte { ImageZoom.Wide = (byte)'W', ImageZoom.Normal = (byte)'N', ImageZoom.Tele = (byte)'T', ImageZoom.Super = (byte)'S' }
Defines the viewfinders camera zoom level More...
enum | ImageMode : byte { ImageMode.LiveImageDisabled = (byte)'S', ImageMode.LiveImageEnabled = (byte)'R' }
Defines the possible image modes of the viewfinder's camera More...
enum | PositioningAxis : byte { PositioningAxis.Horizontal = (byte)'H', PositioningAxis.Vertical = (byte)'V', PositioningAxis.Both = (byte)'B' }
Defines the sensors possible axes. More...
enum | PositioningDirection : byte { PositioningDirection.Positive = (byte)'P', PositioningDirection.Negative = (byte)'N' }
defines the possible directions for "position go" commands More...
enum | PositioningAngle : int { PositioningAngle.Corrected, PositioningAngle.NotCorrected }
defines the type of the angle More...
enum ImageBrightness : byte {
ImageBrightness.High = (byte)'H', ImageBrightness.Middle = (byte)'M', ImageBrightness.Normal = (byte)'N', ImageBrightness.Low = (byte)'L',
ImageBrightness.Dark = (byte)'D'
}
defines the brightness of the live-image More...
enum | VerticalAxisFace : int { VerticalAxisFace.One = 1, VerticalAxisFace.Two = 2 }
Identifies the logical position of the vertical axis (Kippachse) More...
enum SensorSubsystem : int {
SensorSubsystem.All = 0, SensorSubsystem.Edm = 1, SensorSubsystem.Hax = 2, SensorSubsystem.Vax = 3,
SensorSubsystem.Cco = 4, SensorSubsystem.Lev = 5, SensorSubsystem.Mon = 6, SensorSubsystem.Cam = 7,
SensorSubsystem.Cmd = 8
}
identifies the subsystem(s) on the sensor More...
enum | ENetworkAccess : int { ENetworkAccess.Wlan, ENetworkAccess.Usb }
The different kinds of accessing the network which sensor and control-unit are connected to. More...
enum | ERemoteControlKeyAction : int { ERemoteControlKeyAction.Down, ERemoteControlKeyAction.Up }
Actions for the single keys of the remote control More...
enum EEvent : int {
EEvent.MotorStopped, EEvent.RemoteControlKeyPressed, EEvent.BatteryStateChanged, EEvent.InclinationPlaneChanged,
EEvent.Calibration, EEvent.SystemMessage, EEvent.MeasurePolar, EEvent.MeasurePolarWithImage
}
the types of events the sensor can fire More...
enum ESystemWarning : int {
ESystemWarning.TemperatureOutOfRange = (1 << 0), ESystemWarning.OffLevel = (1 << 1), ESystemWarning.LevelSensorInitializing = (1 << 2), ESystemWarning.DeviceLocked = (1 << 3),
ESystemWarning.PinRequired = (1 << 4), ESystemWarning.PukRequired = (1 << 5), ESystemWarning.EventChannelBroken = (1 << 6), ESystemWarning.LevelSensorCalibrating = (1 << 7)
}
System Warnings (SkyCom 3.4.2) More...
enum ESystemError : int {
ESystemError.UART = (1 << 0), ESystemError.LevelSensor = (1 << 1), ESystemError.EDM = (1 << 2), ESystemError.CAM = (1 << 3),
ESystemError.Last = (1 << 15)
}
System Errors (SkyCom 3.4.1) More...
enum SensorState : int {
SensorState.Undefined, SensorState.Disconnected, SensorState.Connecting, SensorState.Initializing,
SensorState.Ready, SensorState.Busy, SensorState.Moving, SensorState.OffLevel,
SensorState.PinRequired, SensorState.PukRequired, SensorState.Locked
}
Externally visible states of the sensor. More...
enum | AxisState : int { AxisState.Stopped = 0, AxisState.Moving = 1, AxisState.Stopping = 2 }
describes the states an Axis can have More...

Functions

delegate void | LiveImageChangedHandler (ILiveImage imageSender, SensorDirection direction)
Delegate for a live image changed handler More...
delegate void | SensorDataChangedHandler (object sender, SensorState newState)
prototype fo events when the Sensor's internal data has changed More...
delegate bool | EventReceivedHandler (SensorInterface p_Sensor, ISensorEvent p_Event)
signature for an event fired by the sensor More...

Enumeration Type Documentation

enum Leica.Disto.Api.HardwareInterface.AxisState : int

describes the states an Axis can have

Enumerator
Stopped | state when the axis is not moving
Moving | state when the axis has been triggered with StartPositioning, PositionAbsolute, PositionRelative or Accelerate
Stopping | state after a a [ps] has been sent to the axis
enum Leica.Disto.Api.HardwareInterface.ECommand : int

defines the commands that must be accepted by an implementation of ISensor

Enumerator
Invalid | invalid/unknown command
Ping | check if sensor is alive
Pin | PIN verification, etc.
Puk | PUK verification, etc.
PowerOff | power off sensor
LaserMode | set the mode of the laser
LevelMode | set the inclination error compensation mode
MeasureIncline | measure the inclination plane
MeasureAngle | measure the angles Hz, V, NiHz, NiV
MeasurePolar | measure the corrected polar coordinates
PositionVelocity | set the velocity for positioning
PositionDirection | set the direction for positioning
PositionGo | start moving an axis
PositionStop | stop an axis that is moving
PositionAbsolute | absolute position an axis
PositionRelative | relative position an axis
GetFace | get the logical position of the vertical axis
GetMotorStatus | queries the status of a motor(s)
ImageMode | set the image mode (Live image enabled/disabled)
ImageZoom | set the zoom level of the viewfinder's camera
ImageBrightness | set the image brightnes of the viewfinder's camera
ImageSnap | get snapshot image from the viewfinder's camera
GetValue | query the value of a setting
SetValue | change the value of a setting
SaveUserCalibration | save the user calibration values of a subsystem to NVRAM
ResetUserCalibration | reset the user calibration values to default
GetTemperature | get the sensor's temperatures
GetBattery | get the sensor's battery state
enum Leica.Disto.Api.HardwareInterface.EDeviceType

Device/interface type

Enumerator
UnknownDevice | Unknown device for this API
Disto3D | 3D Disto
DistoLd5Plus | S910
enum Leica.Disto.Api.HardwareInterface.EEvent : int

the types of events the sensor can fire

Enumerator
MotorStopped | a motor stopped
RemoteControlKeyPressed | a key on the remote control was pressed
BatteryStateChanged | the battery's state changed
InclinationPlaneChanged | the inclination's plane changed
Calibration | a calibration sequence, e.g. initialted by [lm C] terminated
SystemMessage | either an error or warning reported by the sensor
MeasurePolar | Measure Polar values received
MeasurePolarWithImage | Measure Polar values including image received
enum Leica.Disto.Api.HardwareInterface.ENetworkAccess : int

The different kinds of accessing the network which sensor and control-unit are connected to.

Enumerator
Wlan | access via WLAN
Usb | access via USB/RNDIS
enum Leica.Disto.Api.HardwareInterface.ERemoteControlKeyAction : int

Actions for the single keys of the remote control

Enumerator
Down | key was pressed
Up | key was released
enum Leica.Disto.Api.HardwareInterface.ESystemError : int

System Errors (SkyCom 3.4.1)

The number associated with the names corresponds to the Bit

Enumerator
UART | UART defect
LevelSensor | Level sensor defect
EDM | EDM module defect
CAM | Camera subsystem defect
Last | dummy error for tests
enum Leica.Disto.Api.HardwareInterface.ESystemWarning : int

System Warnings (SkyCom 3.4.2)

The number associated with the names corresponds to the Bit

Enumerator
TemperatureOutOfRange | Sensor temperature is beyond allowed range
OffLevel | Sensor is off level (level sensor out of range)
LevelSensorInitializing | level sensor is initializing
DeviceLocked | The sensor is locked after 2 false PUK
PinRequired | PIN required
PukRequired | PUK required
EventChannelBroken | event channel could not be established
LevelSensorCalibrating | level sensor is calibrating
enum Leica.Disto.Api.HardwareInterface.ImageBrightness : byte

defines the brightness of the live-image

Enumerator
High | high brightness
Middle | intermediate brightness
Normal | normal brightness
Low | low brightness
Dark | dark brightness
enum Leica.Disto.Api.HardwareInterface.ImageMode : byte

Defines the possible image modes of the viewfinder's camera

Enumerator
LiveImageDisabled | live image is disabled
LiveImageEnabled | live image is enabled
enum Leica.Disto.Api.HardwareInterface.ImageResolution : byte

defines the possible resolutions for snapshot images

Enumerator
Mega | 5M pixel resolution - Resolution5Mpix (2752x2004)
High | high resolution - ResolutionDVGA (1280x960)
Normal | normal resolution - ResolutionVGA (640x480)
Low | low resolution - ResolutionQVGA (320x240)
ViewFinder | viewfinder resolution (zoomed) - ResolutionVGA (640x480)
enum Leica.Disto.Api.HardwareInterface.ImageZoom : byte

Defines the viewfinders camera zoom level

Enumerator
Wide | Quarter resolution 1:4
Normal | Half resolution 1:2
Tele | This zoom level corresponds to original 1:1 resolution, i.e. it is a crop of the sensors 5 Megapixel image.
Super | Interpolated image, 2× zoom.
enum Leica.Disto.Api.HardwareInterface.LaserMode : byte

Different laser modes.

Enumerator
Blink | Laser pointer blinks
Point | Enable the laser pointer. It will automatically be disabled after the next measurement.
Off | Disable the laser pointer
Continuous | Enable the laser pointer. It remains enabled also after a measurement.
enum Leica.Disto.Api.HardwareInterface.LevelMode : byte

Defines how the inclination error compensator operates.

By leveling, the sensor determines the horizon or, in other words, the slope of the surface it is standing on. This information is then used for calculating the angles Hz and V relative to the horizon.

Enumerator
Disabled | Disable periodic measurement of the inclination plane
Enabled | Enable periodic measurement of the inclination plane
Immediate | Immediately measure the inclination plane (start leveling)
Suspend | Suspend leveling. This may be useful e.g. during a scan that should not be interrupted.
Resume | Resume leveling.
Calibrate | Internal use only. Calibrate the error compensator. This takes some time.
enum Leica.Disto.Api.HardwareInterface.PositioningAngle : int

defines the type of the angle

Enumerator
Corrected | the angle contains all corrections
NotCorrected | the angle contains all corrections, except no inclination correction
enum Leica.Disto.Api.HardwareInterface.PositioningAxis : byte

Defines the sensors possible axes.

Enumerator
Horizontal | Hz axis: horizontal movement
Vertical | V axis: vertical movement
Both | Both axes
enum Leica.Disto.Api.HardwareInterface.PositioningDirection : byte

defines the possible directions for "position go" commands

Enumerator
Positive

Positive direction

  • Horizontal movement: clockwise rotation
  • Vertical movement: screws on the sensor element face downwards at full extent.
Negative

Negative direction

  • Horizontal movement: counter-clockwise rotation
  • Vertical movement: screws on the sensor element face upwards at full extent.
enum Leica.Disto.Api.HardwareInterface.SensorState : int

Externally visible states of the sensor.

Enumerator
Undefined | Unknown state. Also returned if the state did not change
Disconnected | the sensor is disconnected
Connecting | the sensor is being connected
Initializing | the sensor is being initialised after connecting
Ready | the sensor is ready to accept commands
Busy | the sensor is executing a command
Moving | the sensor is moving with one or both axis
OffLevel | the sensor is off level so that the inclination plane cannot be determined
PinRequired | the sensor needs a PIN to continue initialization
PukRequired | the sensor needs a PUK to continue initialization
Locked | the sensor has been locked due to too many bad security credentials
enum Leica.Disto.Api.HardwareInterface.SensorSubsystem : int

identifies the subsystem(s) on the sensor

Enumerator
All | identifies all subsystems
Edm | identifies the "EDM" subsystem
Hax | identifies the "Horizontal Axis" subsystem
Vax | identifies the "Vertical Axis" subsystem
Cco | identifies the "Calculate Coordinates" subsystem
Lev | identifies the "Level" subsystem
Mon | identifies the "Monitor" subsystem
Cam | identifies the "Camera" subsystem
Cmd | identifies the "Command" subsystem
enum Leica.Disto.Api.HardwareInterface.TiltSensorMode : int

Defines the tilt sensors sensitivity mode. If the sensor notices that the tilt plane has changed, it will start leveling.

Enumerator
Sensitive | Sensitive; little changes already trigger leveling.
Rugged | Less sensitive mode
Disabled | Tilt sensor is disabled. This may be useful in case of unsteady underground which would constantly trigger leveling.
enum Leica.Disto.Api.HardwareInterface.VerticalAxisFace : int

Identifies the logical position of the vertical axis (Kippachse)

Enumerator
One | Identifies face one {0...pi} of the tilt axis. This is usually when the serial number stickers on the sensor element face upwards.
Two | Identifies face two {pi...2pi} of the tilt axis. This is when the screws on the sensor element face upwards.

Function Documentation

delegate bool Leica.Disto.Api.HardwareInterface.EventReceivedHandler | ( | SensorInterface | p_Sensor,
 |  | ISensorEvent | p_Event
 | ) |  |

signature for an event fired by the sensor

Parameters
p_Sensor
p_Event
Returns
delegate void Leica.Disto.Api.HardwareInterface.LiveImageChangedHandler | ( | ILiveImage | imageSender,
 |  | SensorDirection | direction
 | ) |  |

Delegate for a live image changed handler

Parameters
imageSender | the live-image that has changed
direction | the direction that has changed
delegate void Leica.Disto.Api.HardwareInterface.SensorDataChangedHandler | ( | object | sender,
 |  | SensorState | newState
 | ) |  |

prototype fo events when the Sensor's internal data has changed

Parameters
sender
newState The next state. It may be set to SensorState.Undefined in case the sensor state did not change.
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.Logging

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • Logging
Classes
Package Leica.Disto.Api.Logging

Classes

class | DummyLogger
interface | ILog
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Api.SystemInterface

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Api
  • SystemInterface
Classes
Package Leica.Disto.Api.SystemInterface

Classes

class | ExceptionSensorInterface
exception that is thrown from the sensor interface More...
class | ExceptionEmptyImageBuffer
Exception thrown when accessing a live image containing no data More...
class | ExceptionUnsupportedDeviceType
Exception thrown when the connected device is not supported by this API More...
class | ExceptionUnsupportedCommand
Exception thrown when the command is not supported by the connected device More...
class | SensorData
collection of the Sensor's current, internal data More...
class | AxisData
Represents the iternal data of eitherthe Hz or V axis More...
class | SensorInterface
API for the Leica 3D Disto sensor. More...
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Networking

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Networking
Namespaces | Classes
Package Leica.Disto.Networking

Namespaces

package Windows

Classes

class | PlatformWindowsNet
Class for network configuration on Windows platforms (XP, Vista, Win7, Win8) More...
class | IpDeviceDescriptor
Description of a connected Device More...
class | WlanInterfaceException
Custom Exception to catch Wlan Problems with special Utilities (Lenovo etc.) More...
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Leica.Disto.Networking.Windows

  • Packages
  • Package Functions
  • Leica
  • Disto
  • Networking
  • Windows
Classes
Package Leica.Disto.Networking.Windows

Classes

class | DistoOnWlanSearcher
class | UDPer
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • ActionsDone : Leica::Disto::Api::AsyncSubsystem
  • AddConst : Leica::Disto::Api::HardwareInterface
  • All : Leica::Disto::Api::HardwareInterface
  • AOffset : Leica::Disto::Api::HardwareInterface
  • AutoHalt : Leica::Disto::Api::HardwareInterface
  • AxisState : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • BatS : Leica::Disto::Api::HardwareInterface
  • BatteryStateChanged : Leica::Disto::Api::HardwareInterface
  • BatV : Leica::Disto::Api::HardwareInterface
  • Blink : Leica::Disto::Api::HardwareInterface
  • Both : Leica::Disto::Api::HardwareInterface
  • Busy : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • Calibrate : Leica::Disto::Api::HardwareInterface
  • Calibration : Leica::Disto::Api::HardwareInterface
  • CAM : Leica::Disto::Api::HardwareInterface
  • Cam : Leica::Disto::Api::HardwareInterface
  • CamExp : Leica::Disto::Api::HardwareInterface
  • CamGain : Leica::Disto::Api::HardwareInterface
  • CamLasX : Leica::Disto::Api::HardwareInterface
  • CamLasXTk : Leica::Disto::Api::HardwareInterface
  • CamLasY : Leica::Disto::Api::HardwareInterface
  • CamLasYTk : Leica::Disto::Api::HardwareInterface
  • CamRefTemp : Leica::Disto::Api::HardwareInterface
  • CamRelB : Leica::Disto::Api::HardwareInterface
  • CamRelG1 : Leica::Disto::Api::HardwareInterface
  • CamRelG2 : Leica::Disto::Api::HardwareInterface
  • CamRelR : Leica::Disto::Api::HardwareInterface
  • Cco : Leica::Disto::Api::HardwareInterface
  • Changed : Leica::Disto::Api::GeoMath
  • Check : Leica::Disto::Api::HardwareInterface
  • cmd : Leica::Disto::Api::CommandInterface
  • Cmd : Leica::Disto::Api::HardwareInterface
  • Coll20 : Leica::Disto::Api::HardwareInterface
  • CollTk : Leica::Disto::Api::HardwareInterface
  • CommandAboveNormal : Leica::Disto::Api::AsyncSubsystem
  • CommandHigh : Leica::Disto::Api::AsyncSubsystem
  • ConnectCommandChannel : Leica::Disto::Api::SystemInterface
  • ConnectEventChannel : Leica::Disto::Api::SystemInterface
  • Connecting : Leica::Disto::Api::HardwareInterface
  • Continuous : Leica::Disto::Api::HardwareInterface
  • Corrected : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • Dark : Leica::Disto::Api::HardwareInterface
  • Device : Leica::Disto::Api::HardwareInterface
  • DeviceLocked : Leica::Disto::Api::HardwareInterface
  • Disabled : Leica::Disto::Api::GeoMath , Leica::Disto::Api::HardwareInterface
  • DisconnectCommandChannel : Leica::Disto::Api::SystemInterface
  • Disconnected : Leica::Disto::Api::HardwareInterface
  • DisconnectEventChannel : Leica::Disto::Api::SystemInterface
  • Dist : Leica::Disto::Api::HardwareInterface
  • Disto3D : Leica::Disto::Api::HardwareInterface
  • DistoLd5Plus : Leica::Disto::Api::HardwareInterface
  • DOffset : Leica::Disto::Api::HardwareInterface
  • Down : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EAsyncCallQueue : Leica::Disto::Api::AsyncSubsystem
  • EAsyncThreadWakeUpReason : Leica::Disto::Api::AsyncSubsystem
  • ECommand : Leica::Disto::Api::HardwareInterface
  • EDeviceType : Leica::Disto::Api::HardwareInterface
  • Edm : Leica::Disto::Api::HardwareInterface
  • EDM : Leica::Disto::Api::HardwareInterface
  • EdmTemp : Leica::Disto::Api::HardwareInterface
  • EdmVersion : Leica::Disto::Api::HardwareInterface
  • EEvent : Leica::Disto::Api::HardwareInterface
  • EInterruptReason : Leica::Disto::Api::AsyncSubsystem
  • Enabled : Leica::Disto::Api::HardwareInterface
  • ENetworkAccess : Leica::Disto::Api::HardwareInterface
  • Equipment : Leica::Disto::Api::HardwareInterface
  • ERemoteControlKeyAction : Leica::Disto::Api::HardwareInterface
  • error : Leica::Disto::Api::CommandInterface
  • Error : Leica::Disto::Api::EventInterface
  • ErrorCallbackDelegate() : Leica::Disto::Api::AsyncSubsystem
  • ESystemError : Leica::Disto::Api::HardwareInterface
  • ESystemMessage : Leica::Disto::Api::EventInterface
  • ESystemWarning : Leica::Disto::Api::HardwareInterface
  • ETokenKind : Leica::Disto::Api::CommandInterface
  • EventChannelBroken : Leica::Disto::Api::HardwareInterface
  • EventReceivedHandler() : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • Face : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • Get : Leica::Disto::Api::HardwareInterface
  • GetBattery : Leica::Disto::Api::HardwareInterface
  • GetBatteryState : Leica::Disto::Api::SystemInterface
  • GetFace : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • GetMotorStatus : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • GetTemperature : Leica::Disto::Api::HardwareInterface
  • GetTemperatures : Leica::Disto::Api::SystemInterface
  • GetValue : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- h -

  • Hax : Leica::Disto::Api::HardwareInterface
  • High : Leica::Disto::Api::HardwareInterface
  • Horizontal : Leica::Disto::Api::HardwareInterface
  • HTime : Leica::Disto::Api::HardwareInterface
  • Hz : Leica::Disto::Api::HardwareInterface
  • HzMotRc : Leica::Disto::Api::HardwareInterface
  • HzMotStat : Leica::Disto::Api::HardwareInterface
  • HzOffset : Leica::Disto::Api::HardwareInterface
  • HzRaw : Leica::Disto::Api::HardwareInterface
  • HzTemp : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • ICRaw : Leica::Disto::Api::HardwareInterface
  • ICross : Leica::Disto::Api::HardwareInterface
  • Identical : Leica::Disto::Api::GeoMath
  • IHz : Leica::Disto::Api::HardwareInterface
  • ILen : Leica::Disto::Api::HardwareInterface
  • ILRaw : Leica::Disto::Api::HardwareInterface
  • ImageBrightness : Leica::Disto::Api::HardwareInterface
  • ImageMode : Leica::Disto::Api::HardwareInterface
  • ImageResolution : Leica::Disto::Api::HardwareInterface
  • ImageSnap : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • ImageZoom : Leica::Disto::Api::HardwareInterface
  • ImgHigh : Leica::Disto::Api::HardwareInterface
  • ImgLow : Leica::Disto::Api::HardwareInterface
  • ImgMega : Leica::Disto::Api::HardwareInterface
  • ImgNorm : Leica::Disto::Api::HardwareInterface
  • ImgSvga : Leica::Disto::Api::HardwareInterface
  • ImgUxga : Leica::Disto::Api::HardwareInterface
  • Immediate : Leica::Disto::Api::HardwareInterface
  • InclinationPlaneChanged : Leica::Disto::Api::HardwareInterface
  • InclinationPlaneState : Leica::Disto::Api::GeoMath
  • Initializing : Leica::Disto::Api::HardwareInterface
  • integer : Leica::Disto::Api::CommandInterface
  • Invalid : Leica::Disto::Api::HardwareInterface
  • IpAddr : Leica::Disto::Api::HardwareInterface
  • IState : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- k -

  • KernelVers : Leica::Disto::Api::HardwareInterface
  • KernelVersion : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • LaserMode : Leica::Disto::Api::HardwareInterface
  • Last : Leica::Disto::Api::HardwareInterface
  • LedSe : Leica::Disto::Api::HardwareInterface
  • LedW : Leica::Disto::Api::HardwareInterface
  • Lev : Leica::Disto::Api::HardwareInterface
  • LevelMode : Leica::Disto::Api::HardwareInterface
  • LevelSensor : Leica::Disto::Api::HardwareInterface
  • LevelSensorCalibrating : Leica::Disto::Api::HardwareInterface
  • LevelSensorInitializing : Leica::Disto::Api::HardwareInterface
  • LevExp : Leica::Disto::Api::HardwareInterface
  • LevLibX : Leica::Disto::Api::HardwareInterface
  • LevLibY : Leica::Disto::Api::HardwareInterface
  • LevRoi : Leica::Disto::Api::HardwareInterface
  • LiveImageChangedHandler() : Leica::Disto::Api::HardwareInterface
  • LiveImageDisabled : Leica::Disto::Api::HardwareInterface
  • LiveImageEnabled : Leica::Disto::Api::HardwareInterface
  • Locked : Leica::Disto::Api::HardwareInterface
  • Low : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • MeasureAngle : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • MeasureIncline : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • MeasurePolar : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • MeasurePolarWithImage : Leica::Disto::Api::HardwareInterface
  • Mega : Leica::Disto::Api::HardwareInterface
  • Middle : Leica::Disto::Api::HardwareInterface
  • Mon : Leica::Disto::Api::HardwareInterface
  • MotorStopped : Leica::Disto::Api::HardwareInterface
  • MotWhile : Leica::Disto::Api::HardwareInterface
  • Moving : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- n -

  • Negative : Leica::Disto::Api::HardwareInterface
  • NiHz : Leica::Disto::Api::HardwareInterface
  • NiV : Leica::Disto::Api::HardwareInterface
  • Normal : Leica::Disto::Api::HardwareInterface
  • NotCorrected : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • Obsolete : Leica::Disto::Api::GeoMath
  • Off : Leica::Disto::Api::HardwareInterface
  • OffLevel : Leica::Disto::Api::HardwareInterface
  • ok : Leica::Disto::Api::CommandInterface
  • One : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- p -

  • PcbNr : Leica::Disto::Api::HardwareInterface
  • PDate : Leica::Disto::Api::HardwareInterface
  • Pin : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • Ping : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PingEventChannel : Leica::Disto::Api::SystemInterface
  • PinRequired : Leica::Disto::Api::HardwareInterface
  • PinState : Leica::Disto::Api::HardwareInterface
  • Point : Leica::Disto::Api::HardwareInterface
  • PositionAbsolute : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionDirection : Leica::Disto::Api::HardwareInterface
  • PositionGo : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositioningAngle : Leica::Disto::Api::HardwareInterface
  • PositioningAxis : Leica::Disto::Api::HardwareInterface
  • PositioningDirection : Leica::Disto::Api::HardwareInterface
  • PositionRelative : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionStop : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionVelocity : Leica::Disto::Api::HardwareInterface
  • Positive : Leica::Disto::Api::HardwareInterface
  • PowerOff : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PpmA : Leica::Disto::Api::HardwareInterface
  • PpmU : Leica::Disto::Api::HardwareInterface
  • Puk : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PukRequired : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- q -

  • QueueAboveNormal : Leica::Disto::Api::AsyncSubsystem
  • QueueHigh : Leica::Disto::Api::AsyncSubsystem
  • QueueLastItem : Leica::Disto::Api::AsyncSubsystem
  • QueueNormal : Leica::Disto::Api::AsyncSubsystem
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • Ready : Leica::Disto::Api::HardwareInterface
  • real : Leica::Disto::Api::CommandInterface
  • RefT : Leica::Disto::Api::HardwareInterface
  • RemoteControlKeyPressed : Leica::Disto::Api::HardwareInterface
  • ResetUserCalibration : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • Resume : Leica::Disto::Api::HardwareInterface
  • Rev : Leica::Disto::Api::HardwareInterface
  • RTime : Leica::Disto::Api::HardwareInterface
  • Rugged : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • SaveUserCalibration : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • Sensitive : Leica::Disto::Api::HardwareInterface
  • SensorDataChangedHandler() : Leica::Disto::Api::HardwareInterface
  • SensorState : Leica::Disto::Api::HardwareInterface
  • SensorSubsystem : Leica::Disto::Api::HardwareInterface
  • sep : Leica::Disto::Api::CommandInterface
  • Set : Leica::Disto::Api::HardwareInterface
  • SetDoubleValue : Leica::Disto::Api::SystemInterface
  • SetImageBrightness : Leica::Disto::Api::SystemInterface
  • SetImageMode : Leica::Disto::Api::SystemInterface
  • SetImageZoom : Leica::Disto::Api::SystemInterface
  • SetIntegerValue : Leica::Disto::Api::SystemInterface
  • SetIp : Leica::Disto::Api::HardwareInterface
  • SetLaserMode : Leica::Disto::Api::SystemInterface
  • SetLevelMode : Leica::Disto::Api::SystemInterface
  • SetPositionDirection : Leica::Disto::Api::SystemInterface
  • SetPositionVelocity : Leica::Disto::Api::SystemInterface
  • SetStringValue : Leica::Disto::Api::SystemInterface
  • SetValue : Leica::Disto::Api::HardwareInterface
  • SN : Leica::Disto::Api::HardwareInterface
  • Status : Leica::Disto::Api::HardwareInterface
  • Stopped : Leica::Disto::Api::HardwareInterface
  • Stopping : Leica::Disto::Api::HardwareInterface
  • str : Leica::Disto::Api::CommandInterface
  • Super : Leica::Disto::Api::HardwareInterface
  • Suspend : Leica::Disto::Api::HardwareInterface
  • SwColl : Leica::Disto::Api::HardwareInterface
  • SwIncl : Leica::Disto::Api::HardwareInterface
  • SwName : Leica::Disto::Api::HardwareInterface
  • SwOffset : Leica::Disto::Api::HardwareInterface
  • SwTemp : Leica::Disto::Api::HardwareInterface
  • SwTiltAxis : Leica::Disto::Api::HardwareInterface
  • SwVers : Leica::Disto::Api::HardwareInterface
  • SystemMessage : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- t -

  • TcpCmdPort : Leica::Disto::Api::HardwareInterface
  • TcpEvtPort : Leica::Disto::Api::HardwareInterface
  • Tele : Leica::Disto::Api::HardwareInterface
  • TemperatureOutOfRange : Leica::Disto::Api::HardwareInterface
  • Text1 : Leica::Disto::Api::HardwareInterface
  • Text2 : Leica::Disto::Api::HardwareInterface
  • TiltAxis : Leica::Disto::Api::HardwareInterface
  • TiltBigCTol : Leica::Disto::Api::HardwareInterface
  • TiltBlockBigC : Leica::Disto::Api::HardwareInterface
  • TiltBlockStart : Leica::Disto::Api::HardwareInterface
  • TiltBubExposure : Leica::Disto::Api::HardwareInterface
  • TiltBubSize20 : Leica::Disto::Api::HardwareInterface
  • TiltBubSIzeAct : Leica::Disto::Api::HardwareInterface
  • TiltFQ00 : Leica::Disto::Api::HardwareInterface
  • TiltFQ01 : Leica::Disto::Api::HardwareInterface
  • TiltFQ02 : Leica::Disto::Api::HardwareInterface
  • TiltFQ10 : Leica::Disto::Api::HardwareInterface
  • TiltFQ11 : Leica::Disto::Api::HardwareInterface
  • TiltFQ12 : Leica::Disto::Api::HardwareInterface
  • TiltFQ20 : Leica::Disto::Api::HardwareInterface
  • TiltFQ21 : Leica::Disto::Api::HardwareInterface
  • TiltFQ22 : Leica::Disto::Api::HardwareInterface
  • TiltHCenter : Leica::Disto::Api::HardwareInterface
  • TiltHCenterSet : Leica::Disto::Api::HardwareInterface
  • TiltK01 : Leica::Disto::Api::HardwareInterface
  • TiltK02 : Leica::Disto::Api::HardwareInterface
  • TiltK03 : Leica::Disto::Api::HardwareInterface
  • TiltK04 : Leica::Disto::Api::HardwareInterface
  • TiltK05 : Leica::Disto::Api::HardwareInterface
  • TiltK06 : Leica::Disto::Api::HardwareInterface
  • TiltK07 : Leica::Disto::Api::HardwareInterface
  • TiltK08 : Leica::Disto::Api::HardwareInterface
  • TiltK09 : Leica::Disto::Api::HardwareInterface
  • TiltK10 : Leica::Disto::Api::HardwareInterface
  • TiltK11 : Leica::Disto::Api::HardwareInterface
  • TiltK12 : Leica::Disto::Api::HardwareInterface
  • TiltK13 : Leica::Disto::Api::HardwareInterface
  • TiltK14 : Leica::Disto::Api::HardwareInterface
  • TiltK15 : Leica::Disto::Api::HardwareInterface
  • TiltK16 : Leica::Disto::Api::HardwareInterface
  • TiltK17 : Leica::Disto::Api::HardwareInterface
  • TiltK18 : Leica::Disto::Api::HardwareInterface
  • TiltK19 : Leica::Disto::Api::HardwareInterface
  • TiltK20 : Leica::Disto::Api::HardwareInterface
  • TiltLightX : Leica::Disto::Api::HardwareInterface
  • TiltLightY : Leica::Disto::Api::HardwareInterface
  • TiltLTempSlope : Leica::Disto::Api::HardwareInterface
  • TiltMu00 : Leica::Disto::Api::HardwareInterface
  • TiltMu01 : Leica::Disto::Api::HardwareInterface
  • TiltNCal : Leica::Disto::Api::HardwareInterface
  • TiltNDamage : Leica::Disto::Api::HardwareInterface
  • TiltPlaneThresh : Leica::Disto::Api::HardwareInterface
  • TiltQ00 : Leica::Disto::Api::HardwareInterface
  • TiltQ01 : Leica::Disto::Api::HardwareInterface
  • TiltQ02 : Leica::Disto::Api::HardwareInterface
  • TiltQ10 : Leica::Disto::Api::HardwareInterface
  • TiltQ11 : Leica::Disto::Api::HardwareInterface
  • TiltQ12 : Leica::Disto::Api::HardwareInterface
  • TiltQ20 : Leica::Disto::Api::HardwareInterface
  • TiltQ21 : Leica::Disto::Api::HardwareInterface
  • TiltQ22 : Leica::Disto::Api::HardwareInterface
  • TiltQTempSlope : Leica::Disto::Api::HardwareInterface
  • TiltRcCounter : Leica::Disto::Api::HardwareInterface
  • TiltRefTemp : Leica::Disto::Api::HardwareInterface
  • TiltRho : Leica::Disto::Api::HardwareInterface
  • TiltSelfCalMax : Leica::Disto::Api::HardwareInterface
  • TiltSelfCalTol : Leica::Disto::Api::HardwareInterface
  • TiltSensitivityMode : Leica::Disto::Api::HardwareInterface
  • TiltSensorMode : Leica::Disto::Api::HardwareInterface
  • TiltSkal : Leica::Disto::Api::HardwareInterface
  • TiltTempCompEnabled : Leica::Disto::Api::HardwareInterface
  • TiltTFast : Leica::Disto::Api::HardwareInterface
  • TiltTNormal : Leica::Disto::Api::HardwareInterface
  • TiltUpExposure : Leica::Disto::Api::HardwareInterface
  • TiltXBigZero : Leica::Disto::Api::HardwareInterface
  • TiltXBubZero : Leica::Disto::Api::HardwareInterface
  • TiltYBigZero : Leica::Disto::Api::HardwareInterface
  • TiltYBubZero : Leica::Disto::Api::HardwareInterface
  • Timeout : Leica::Disto::Api::AsyncSubsystem
  • trm : Leica::Disto::Api::CommandInterface
  • Two : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- u -

  • UART : Leica::Disto::Api::HardwareInterface
  • UblVers : Leica::Disto::Api::HardwareInterface
  • UblVersion : Leica::Disto::Api::HardwareInterface
  • UbootVers : Leica::Disto::Api::HardwareInterface
  • UbootVersion : Leica::Disto::Api::HardwareInterface
  • UdpCmdPort : Leica::Disto::Api::HardwareInterface
  • Undefined : Leica::Disto::Api::GeoMath , Leica::Disto::Api::HardwareInterface
  • UnknownDevice : Leica::Disto::Api::HardwareInterface
  • Unstable : Leica::Disto::Api::GeoMath
  • Up : Leica::Disto::Api::HardwareInterface
  • UpToDate : Leica::Disto::Api::GeoMath
  • Usb : Leica::Disto::Api::HardwareInterface
  • UsbKpAct : Leica::Disto::Api::HardwareInterface
  • UsbKpCnt : Leica::Disto::Api::HardwareInterface
  • UsbKpIdle : Leica::Disto::Api::HardwareInterface
  • UsbKpInt : Leica::Disto::Api::HardwareInterface
  • UsrCamLasX : Leica::Disto::Api::HardwareInterface
  • UsrCamLasY : Leica::Disto::Api::HardwareInterface
  • UsrColl : Leica::Disto::Api::HardwareInterface
  • UsrTiltAxis : Leica::Disto::Api::HardwareInterface
  • UsrVInd : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • V : Leica::Disto::Api::HardwareInterface
  • Vax : Leica::Disto::Api::HardwareInterface
  • Vertical : Leica::Disto::Api::HardwareInterface
  • VerticalAxisFace : Leica::Disto::Api::HardwareInterface
  • ViewFinder : Leica::Disto::Api::HardwareInterface
  • VInd : Leica::Disto::Api::HardwareInterface
  • VIndTk : Leica::Disto::Api::HardwareInterface
  • VMotRc : Leica::Disto::Api::HardwareInterface
  • VMotStat : Leica::Disto::Api::HardwareInterface
  • VRange : Leica::Disto::Api::HardwareInterface
  • VRaw : Leica::Disto::Api::HardwareInterface
  • VTemp : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- w -

  • WakeUpCommandAboveNormal : Leica::Disto::Api::AsyncSubsystem
  • WakeUpCommandHigh : Leica::Disto::Api::AsyncSubsystem
  • WakeUpCommandNormal : Leica::Disto::Api::AsyncSubsystem
  • WakeUpImplEvent : Leica::Disto::Api::AsyncSubsystem
  • WakeUpLastItem : Leica::Disto::Api::AsyncSubsystem
  • WakeUpTerminateThread : Leica::Disto::Api::AsyncSubsystem
  • WakeUpTimeout : Leica::Disto::Api::AsyncSubsystem
  • Warning : Leica::Disto::Api::EventInterface
  • Wide : Leica::Disto::Api::HardwareInterface
  • Wlan : Leica::Disto::Api::HardwareInterface
  • WlanCard : Leica::Disto::Api::HardwareInterface
  • WlanChannel : Leica::Disto::Api::HardwareInterface
  • WlanChn : Leica::Disto::Api::HardwareInterface
  • WlanEssid : Leica::Disto::Api::HardwareInterface
  • WlanFreq : Leica::Disto::Api::HardwareInterface
  • WlanKpAct : Leica::Disto::Api::HardwareInterface
  • WlanKpCnt : Leica::Disto::Api::HardwareInterface
  • WlanKpIdle : Leica::Disto::Api::HardwareInterface
  • WlanKpInt : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- x -

  • XCh : Leica::Disto::Api::HardwareInterface
  • XICenter : Leica::Disto::Api::HardwareInterface
  • XSpot : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- y -

  • YCh : Leica::Disto::Api::HardwareInterface
  • YICenter : Leica::Disto::Api::HardwareInterface
  • YSpot : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • ErrorCallbackDelegate() : Leica::Disto::Api::AsyncSubsystem
  • EventReceivedHandler() : Leica::Disto::Api::HardwareInterface
  • LiveImageChangedHandler() : Leica::Disto::Api::HardwareInterface
  • SensorDataChangedHandler() : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • AxisState : Leica::Disto::Api::HardwareInterface
  • EAsyncCallQueue : Leica::Disto::Api::AsyncSubsystem
  • EAsyncThreadWakeUpReason : Leica::Disto::Api::AsyncSubsystem
  • ECommand : Leica::Disto::Api::HardwareInterface
  • EDeviceType : Leica::Disto::Api::HardwareInterface
  • EEvent : Leica::Disto::Api::HardwareInterface
  • EInterruptReason : Leica::Disto::Api::AsyncSubsystem
  • ENetworkAccess : Leica::Disto::Api::HardwareInterface
  • ERemoteControlKeyAction : Leica::Disto::Api::HardwareInterface
  • ESystemError : Leica::Disto::Api::HardwareInterface
  • ESystemMessage : Leica::Disto::Api::EventInterface
  • ESystemWarning : Leica::Disto::Api::HardwareInterface
  • ETokenKind : Leica::Disto::Api::CommandInterface
  • ImageBrightness : Leica::Disto::Api::HardwareInterface
  • ImageMode : Leica::Disto::Api::HardwareInterface
  • ImageResolution : Leica::Disto::Api::HardwareInterface
  • ImageZoom : Leica::Disto::Api::HardwareInterface
  • InclinationPlaneState : Leica::Disto::Api::GeoMath
  • LaserMode : Leica::Disto::Api::HardwareInterface
  • LevelMode : Leica::Disto::Api::HardwareInterface
  • PositioningAngle : Leica::Disto::Api::HardwareInterface
  • PositioningAxis : Leica::Disto::Api::HardwareInterface
  • PositioningDirection : Leica::Disto::Api::HardwareInterface
  • SensorState : Leica::Disto::Api::HardwareInterface
  • SensorSubsystem : Leica::Disto::Api::HardwareInterface
  • TiltSensorMode : Leica::Disto::Api::HardwareInterface
  • VerticalAxisFace : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • ActionsDone : Leica::Disto::Api::AsyncSubsystem
  • AddConst : Leica::Disto::Api::HardwareInterface
  • All : Leica::Disto::Api::HardwareInterface
  • AOffset : Leica::Disto::Api::HardwareInterface
  • AutoHalt : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • BatS : Leica::Disto::Api::HardwareInterface
  • BatteryStateChanged : Leica::Disto::Api::HardwareInterface
  • BatV : Leica::Disto::Api::HardwareInterface
  • Blink : Leica::Disto::Api::HardwareInterface
  • Both : Leica::Disto::Api::HardwareInterface
  • Busy : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • Calibrate : Leica::Disto::Api::HardwareInterface
  • Calibration : Leica::Disto::Api::HardwareInterface
  • CAM : Leica::Disto::Api::HardwareInterface
  • Cam : Leica::Disto::Api::HardwareInterface
  • CamExp : Leica::Disto::Api::HardwareInterface
  • CamGain : Leica::Disto::Api::HardwareInterface
  • CamLasX : Leica::Disto::Api::HardwareInterface
  • CamLasXTk : Leica::Disto::Api::HardwareInterface
  • CamLasY : Leica::Disto::Api::HardwareInterface
  • CamLasYTk : Leica::Disto::Api::HardwareInterface
  • CamRefTemp : Leica::Disto::Api::HardwareInterface
  • CamRelB : Leica::Disto::Api::HardwareInterface
  • CamRelG1 : Leica::Disto::Api::HardwareInterface
  • CamRelG2 : Leica::Disto::Api::HardwareInterface
  • CamRelR : Leica::Disto::Api::HardwareInterface
  • Cco : Leica::Disto::Api::HardwareInterface
  • Changed : Leica::Disto::Api::GeoMath
  • Check : Leica::Disto::Api::HardwareInterface
  • cmd : Leica::Disto::Api::CommandInterface
  • Cmd : Leica::Disto::Api::HardwareInterface
  • Coll20 : Leica::Disto::Api::HardwareInterface
  • CollTk : Leica::Disto::Api::HardwareInterface
  • CommandAboveNormal : Leica::Disto::Api::AsyncSubsystem
  • CommandHigh : Leica::Disto::Api::AsyncSubsystem
  • ConnectCommandChannel : Leica::Disto::Api::SystemInterface
  • ConnectEventChannel : Leica::Disto::Api::SystemInterface
  • Connecting : Leica::Disto::Api::HardwareInterface
  • Continuous : Leica::Disto::Api::HardwareInterface
  • Corrected : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • Dark : Leica::Disto::Api::HardwareInterface
  • Device : Leica::Disto::Api::HardwareInterface
  • DeviceLocked : Leica::Disto::Api::HardwareInterface
  • Disabled : Leica::Disto::Api::GeoMath , Leica::Disto::Api::HardwareInterface
  • DisconnectCommandChannel : Leica::Disto::Api::SystemInterface
  • Disconnected : Leica::Disto::Api::HardwareInterface
  • DisconnectEventChannel : Leica::Disto::Api::SystemInterface
  • Dist : Leica::Disto::Api::HardwareInterface
  • Disto3D : Leica::Disto::Api::HardwareInterface
  • DistoLd5Plus : Leica::Disto::Api::HardwareInterface
  • DOffset : Leica::Disto::Api::HardwareInterface
  • Down : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • Edm : Leica::Disto::Api::HardwareInterface
  • EDM : Leica::Disto::Api::HardwareInterface
  • EdmTemp : Leica::Disto::Api::HardwareInterface
  • EdmVersion : Leica::Disto::Api::HardwareInterface
  • Enabled : Leica::Disto::Api::HardwareInterface
  • Equipment : Leica::Disto::Api::HardwareInterface
  • error : Leica::Disto::Api::CommandInterface
  • Error : Leica::Disto::Api::EventInterface
  • EventChannelBroken : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • Face : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • Get : Leica::Disto::Api::HardwareInterface
  • GetBattery : Leica::Disto::Api::HardwareInterface
  • GetBatteryState : Leica::Disto::Api::SystemInterface
  • GetFace : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • GetMotorStatus : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • GetTemperature : Leica::Disto::Api::HardwareInterface
  • GetTemperatures : Leica::Disto::Api::SystemInterface
  • GetValue : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • Hax : Leica::Disto::Api::HardwareInterface
  • High : Leica::Disto::Api::HardwareInterface
  • Horizontal : Leica::Disto::Api::HardwareInterface
  • HTime : Leica::Disto::Api::HardwareInterface
  • Hz : Leica::Disto::Api::HardwareInterface
  • HzMotRc : Leica::Disto::Api::HardwareInterface
  • HzMotStat : Leica::Disto::Api::HardwareInterface
  • HzOffset : Leica::Disto::Api::HardwareInterface
  • HzRaw : Leica::Disto::Api::HardwareInterface
  • HzTemp : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • ICRaw : Leica::Disto::Api::HardwareInterface
  • ICross : Leica::Disto::Api::HardwareInterface
  • Identical : Leica::Disto::Api::GeoMath
  • IHz : Leica::Disto::Api::HardwareInterface
  • ILen : Leica::Disto::Api::HardwareInterface
  • ILRaw : Leica::Disto::Api::HardwareInterface
  • ImageBrightness : Leica::Disto::Api::HardwareInterface
  • ImageMode : Leica::Disto::Api::HardwareInterface
  • ImageSnap : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • ImageZoom : Leica::Disto::Api::HardwareInterface
  • ImgHigh : Leica::Disto::Api::HardwareInterface
  • ImgLow : Leica::Disto::Api::HardwareInterface
  • ImgMega : Leica::Disto::Api::HardwareInterface
  • ImgNorm : Leica::Disto::Api::HardwareInterface
  • ImgSvga : Leica::Disto::Api::HardwareInterface
  • ImgUxga : Leica::Disto::Api::HardwareInterface
  • Immediate : Leica::Disto::Api::HardwareInterface
  • InclinationPlaneChanged : Leica::Disto::Api::HardwareInterface
  • Initializing : Leica::Disto::Api::HardwareInterface
  • integer : Leica::Disto::Api::CommandInterface
  • Invalid : Leica::Disto::Api::HardwareInterface
  • IpAddr : Leica::Disto::Api::HardwareInterface
  • IState : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • KernelVers : Leica::Disto::Api::HardwareInterface
  • KernelVersion : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • LaserMode : Leica::Disto::Api::HardwareInterface
  • Last : Leica::Disto::Api::HardwareInterface
  • LedSe : Leica::Disto::Api::HardwareInterface
  • LedW : Leica::Disto::Api::HardwareInterface
  • Lev : Leica::Disto::Api::HardwareInterface
  • LevelMode : Leica::Disto::Api::HardwareInterface
  • LevelSensor : Leica::Disto::Api::HardwareInterface
  • LevelSensorCalibrating : Leica::Disto::Api::HardwareInterface
  • LevelSensorInitializing : Leica::Disto::Api::HardwareInterface
  • LevExp : Leica::Disto::Api::HardwareInterface
  • LevLibX : Leica::Disto::Api::HardwareInterface
  • LevLibY : Leica::Disto::Api::HardwareInterface
  • LevRoi : Leica::Disto::Api::HardwareInterface
  • LiveImageDisabled : Leica::Disto::Api::HardwareInterface
  • LiveImageEnabled : Leica::Disto::Api::HardwareInterface
  • Locked : Leica::Disto::Api::HardwareInterface
  • Low : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • MeasureAngle : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • MeasureIncline : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • MeasurePolar : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • MeasurePolarWithImage : Leica::Disto::Api::HardwareInterface
  • Mega : Leica::Disto::Api::HardwareInterface
  • Middle : Leica::Disto::Api::HardwareInterface
  • Mon : Leica::Disto::Api::HardwareInterface
  • MotorStopped : Leica::Disto::Api::HardwareInterface
  • MotWhile : Leica::Disto::Api::HardwareInterface
  • Moving : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • Negative : Leica::Disto::Api::HardwareInterface
  • NiHz : Leica::Disto::Api::HardwareInterface
  • NiV : Leica::Disto::Api::HardwareInterface
  • Normal : Leica::Disto::Api::HardwareInterface
  • NotCorrected : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • Obsolete : Leica::Disto::Api::GeoMath
  • Off : Leica::Disto::Api::HardwareInterface
  • OffLevel : Leica::Disto::Api::HardwareInterface
  • ok : Leica::Disto::Api::CommandInterface
  • One : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • PcbNr : Leica::Disto::Api::HardwareInterface
  • PDate : Leica::Disto::Api::HardwareInterface
  • Pin : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • Ping : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PingEventChannel : Leica::Disto::Api::SystemInterface
  • PinRequired : Leica::Disto::Api::HardwareInterface
  • PinState : Leica::Disto::Api::HardwareInterface
  • Point : Leica::Disto::Api::HardwareInterface
  • PositionAbsolute : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionDirection : Leica::Disto::Api::HardwareInterface
  • PositionGo : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionRelative : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionStop : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PositionVelocity : Leica::Disto::Api::HardwareInterface
  • Positive : Leica::Disto::Api::HardwareInterface
  • PowerOff : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PpmA : Leica::Disto::Api::HardwareInterface
  • PpmU : Leica::Disto::Api::HardwareInterface
  • Puk : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • PukRequired : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- q -

  • QueueAboveNormal : Leica::Disto::Api::AsyncSubsystem
  • QueueHigh : Leica::Disto::Api::AsyncSubsystem
  • QueueLastItem : Leica::Disto::Api::AsyncSubsystem
  • QueueNormal : Leica::Disto::Api::AsyncSubsystem
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • Ready : Leica::Disto::Api::HardwareInterface
  • real : Leica::Disto::Api::CommandInterface
  • RefT : Leica::Disto::Api::HardwareInterface
  • RemoteControlKeyPressed : Leica::Disto::Api::HardwareInterface
  • ResetUserCalibration : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • Resume : Leica::Disto::Api::HardwareInterface
  • Rev : Leica::Disto::Api::HardwareInterface
  • RTime : Leica::Disto::Api::HardwareInterface
  • Rugged : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • SaveUserCalibration : Leica::Disto::Api::HardwareInterface , Leica::Disto::Api::SystemInterface
  • Sensitive : Leica::Disto::Api::HardwareInterface
  • sep : Leica::Disto::Api::CommandInterface
  • Set : Leica::Disto::Api::HardwareInterface
  • SetDoubleValue : Leica::Disto::Api::SystemInterface
  • SetImageBrightness : Leica::Disto::Api::SystemInterface
  • SetImageMode : Leica::Disto::Api::SystemInterface
  • SetImageZoom : Leica::Disto::Api::SystemInterface
  • SetIntegerValue : Leica::Disto::Api::SystemInterface
  • SetIp : Leica::Disto::Api::HardwareInterface
  • SetLaserMode : Leica::Disto::Api::SystemInterface
  • SetLevelMode : Leica::Disto::Api::SystemInterface
  • SetPositionDirection : Leica::Disto::Api::SystemInterface
  • SetPositionVelocity : Leica::Disto::Api::SystemInterface
  • SetStringValue : Leica::Disto::Api::SystemInterface
  • SetValue : Leica::Disto::Api::HardwareInterface
  • SN : Leica::Disto::Api::HardwareInterface
  • Status : Leica::Disto::Api::HardwareInterface
  • Stopped : Leica::Disto::Api::HardwareInterface
  • Stopping : Leica::Disto::Api::HardwareInterface
  • str : Leica::Disto::Api::CommandInterface
  • Super : Leica::Disto::Api::HardwareInterface
  • Suspend : Leica::Disto::Api::HardwareInterface
  • SwColl : Leica::Disto::Api::HardwareInterface
  • SwIncl : Leica::Disto::Api::HardwareInterface
  • SwName : Leica::Disto::Api::HardwareInterface
  • SwOffset : Leica::Disto::Api::HardwareInterface
  • SwTemp : Leica::Disto::Api::HardwareInterface
  • SwTiltAxis : Leica::Disto::Api::HardwareInterface
  • SwVers : Leica::Disto::Api::HardwareInterface
  • SystemMessage : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • TcpCmdPort : Leica::Disto::Api::HardwareInterface
  • TcpEvtPort : Leica::Disto::Api::HardwareInterface
  • Tele : Leica::Disto::Api::HardwareInterface
  • TemperatureOutOfRange : Leica::Disto::Api::HardwareInterface
  • Text1 : Leica::Disto::Api::HardwareInterface
  • Text2 : Leica::Disto::Api::HardwareInterface
  • TiltAxis : Leica::Disto::Api::HardwareInterface
  • TiltBigCTol : Leica::Disto::Api::HardwareInterface
  • TiltBlockBigC : Leica::Disto::Api::HardwareInterface
  • TiltBlockStart : Leica::Disto::Api::HardwareInterface
  • TiltBubExposure : Leica::Disto::Api::HardwareInterface
  • TiltBubSize20 : Leica::Disto::Api::HardwareInterface
  • TiltBubSIzeAct : Leica::Disto::Api::HardwareInterface
  • TiltFQ00 : Leica::Disto::Api::HardwareInterface
  • TiltFQ01 : Leica::Disto::Api::HardwareInterface
  • TiltFQ02 : Leica::Disto::Api::HardwareInterface
  • TiltFQ10 : Leica::Disto::Api::HardwareInterface
  • TiltFQ11 : Leica::Disto::Api::HardwareInterface
  • TiltFQ12 : Leica::Disto::Api::HardwareInterface
  • TiltFQ20 : Leica::Disto::Api::HardwareInterface
  • TiltFQ21 : Leica::Disto::Api::HardwareInterface
  • TiltFQ22 : Leica::Disto::Api::HardwareInterface
  • TiltHCenter : Leica::Disto::Api::HardwareInterface
  • TiltHCenterSet : Leica::Disto::Api::HardwareInterface
  • TiltK01 : Leica::Disto::Api::HardwareInterface
  • TiltK02 : Leica::Disto::Api::HardwareInterface
  • TiltK03 : Leica::Disto::Api::HardwareInterface
  • TiltK04 : Leica::Disto::Api::HardwareInterface
  • TiltK05 : Leica::Disto::Api::HardwareInterface
  • TiltK06 : Leica::Disto::Api::HardwareInterface
  • TiltK07 : Leica::Disto::Api::HardwareInterface
  • TiltK08 : Leica::Disto::Api::HardwareInterface
  • TiltK09 : Leica::Disto::Api::HardwareInterface
  • TiltK10 : Leica::Disto::Api::HardwareInterface
  • TiltK11 : Leica::Disto::Api::HardwareInterface
  • TiltK12 : Leica::Disto::Api::HardwareInterface
  • TiltK13 : Leica::Disto::Api::HardwareInterface
  • TiltK14 : Leica::Disto::Api::HardwareInterface
  • TiltK15 : Leica::Disto::Api::HardwareInterface
  • TiltK16 : Leica::Disto::Api::HardwareInterface
  • TiltK17 : Leica::Disto::Api::HardwareInterface
  • TiltK18 : Leica::Disto::Api::HardwareInterface
  • TiltK19 : Leica::Disto::Api::HardwareInterface
  • TiltK20 : Leica::Disto::Api::HardwareInterface
  • TiltLightX : Leica::Disto::Api::HardwareInterface
  • TiltLightY : Leica::Disto::Api::HardwareInterface
  • TiltLTempSlope : Leica::Disto::Api::HardwareInterface
  • TiltMu00 : Leica::Disto::Api::HardwareInterface
  • TiltMu01 : Leica::Disto::Api::HardwareInterface
  • TiltNCal : Leica::Disto::Api::HardwareInterface
  • TiltNDamage : Leica::Disto::Api::HardwareInterface
  • TiltPlaneThresh : Leica::Disto::Api::HardwareInterface
  • TiltQ00 : Leica::Disto::Api::HardwareInterface
  • TiltQ01 : Leica::Disto::Api::HardwareInterface
  • TiltQ02 : Leica::Disto::Api::HardwareInterface
  • TiltQ10 : Leica::Disto::Api::HardwareInterface
  • TiltQ11 : Leica::Disto::Api::HardwareInterface
  • TiltQ12 : Leica::Disto::Api::HardwareInterface
  • TiltQ20 : Leica::Disto::Api::HardwareInterface
  • TiltQ21 : Leica::Disto::Api::HardwareInterface
  • TiltQ22 : Leica::Disto::Api::HardwareInterface
  • TiltQTempSlope : Leica::Disto::Api::HardwareInterface
  • TiltRcCounter : Leica::Disto::Api::HardwareInterface
  • TiltRefTemp : Leica::Disto::Api::HardwareInterface
  • TiltRho : Leica::Disto::Api::HardwareInterface
  • TiltSelfCalMax : Leica::Disto::Api::HardwareInterface
  • TiltSelfCalTol : Leica::Disto::Api::HardwareInterface
  • TiltSensitivityMode : Leica::Disto::Api::HardwareInterface
  • TiltSkal : Leica::Disto::Api::HardwareInterface
  • TiltTempCompEnabled : Leica::Disto::Api::HardwareInterface
  • TiltTFast : Leica::Disto::Api::HardwareInterface
  • TiltTNormal : Leica::Disto::Api::HardwareInterface
  • TiltUpExposure : Leica::Disto::Api::HardwareInterface
  • TiltXBigZero : Leica::Disto::Api::HardwareInterface
  • TiltXBubZero : Leica::Disto::Api::HardwareInterface
  • TiltYBigZero : Leica::Disto::Api::HardwareInterface
  • TiltYBubZero : Leica::Disto::Api::HardwareInterface
  • Timeout : Leica::Disto::Api::AsyncSubsystem
  • trm : Leica::Disto::Api::CommandInterface
  • Two : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • UART : Leica::Disto::Api::HardwareInterface
  • UblVers : Leica::Disto::Api::HardwareInterface
  • UblVersion : Leica::Disto::Api::HardwareInterface
  • UbootVers : Leica::Disto::Api::HardwareInterface
  • UbootVersion : Leica::Disto::Api::HardwareInterface
  • UdpCmdPort : Leica::Disto::Api::HardwareInterface
  • Undefined : Leica::Disto::Api::GeoMath , Leica::Disto::Api::HardwareInterface
  • UnknownDevice : Leica::Disto::Api::HardwareInterface
  • Unstable : Leica::Disto::Api::GeoMath
  • Up : Leica::Disto::Api::HardwareInterface
  • UpToDate : Leica::Disto::Api::GeoMath
  • Usb : Leica::Disto::Api::HardwareInterface
  • UsbKpAct : Leica::Disto::Api::HardwareInterface
  • UsbKpCnt : Leica::Disto::Api::HardwareInterface
  • UsbKpIdle : Leica::Disto::Api::HardwareInterface
  • UsbKpInt : Leica::Disto::Api::HardwareInterface
  • UsrCamLasX : Leica::Disto::Api::HardwareInterface
  • UsrCamLasY : Leica::Disto::Api::HardwareInterface
  • UsrColl : Leica::Disto::Api::HardwareInterface
  • UsrTiltAxis : Leica::Disto::Api::HardwareInterface
  • UsrVInd : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • V : Leica::Disto::Api::HardwareInterface
  • Vax : Leica::Disto::Api::HardwareInterface
  • Vertical : Leica::Disto::Api::HardwareInterface
  • ViewFinder : Leica::Disto::Api::HardwareInterface
  • VInd : Leica::Disto::Api::HardwareInterface
  • VIndTk : Leica::Disto::Api::HardwareInterface
  • VMotRc : Leica::Disto::Api::HardwareInterface
  • VMotStat : Leica::Disto::Api::HardwareInterface
  • VRange : Leica::Disto::Api::HardwareInterface
  • VRaw : Leica::Disto::Api::HardwareInterface
  • VTemp : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WakeUpCommandAboveNormal : Leica::Disto::Api::AsyncSubsystem
  • WakeUpCommandHigh : Leica::Disto::Api::AsyncSubsystem
  • WakeUpCommandNormal : Leica::Disto::Api::AsyncSubsystem
  • WakeUpImplEvent : Leica::Disto::Api::AsyncSubsystem
  • WakeUpLastItem : Leica::Disto::Api::AsyncSubsystem
  • WakeUpTerminateThread : Leica::Disto::Api::AsyncSubsystem
  • WakeUpTimeout : Leica::Disto::Api::AsyncSubsystem
  • Warning : Leica::Disto::Api::EventInterface
  • Wide : Leica::Disto::Api::HardwareInterface
  • Wlan : Leica::Disto::Api::HardwareInterface
  • WlanCard : Leica::Disto::Api::HardwareInterface
  • WlanChannel : Leica::Disto::Api::HardwareInterface
  • WlanChn : Leica::Disto::Api::HardwareInterface
  • WlanEssid : Leica::Disto::Api::HardwareInterface
  • WlanFreq : Leica::Disto::Api::HardwareInterface
  • WlanKpAct : Leica::Disto::Api::HardwareInterface
  • WlanKpCnt : Leica::Disto::Api::HardwareInterface
  • WlanKpIdle : Leica::Disto::Api::HardwareInterface
  • WlanKpInt : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • XCh : Leica::Disto::Api::HardwareInterface
  • XICenter : Leica::Disto::Api::HardwareInterface
  • XSpot : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Package Functions

  • Packages
  • Package Functions
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • YCh : Leica::Disto::Api::HardwareInterface
  • YICenter : Leica::Disto::Api::HardwareInterface
  • YSpot : Leica::Disto::Api::HardwareInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345]
\ N Leica |
\ N Disto |
o N Api |
| o N AsyncSubsystem |
| | o C InterruptReasonMask | wakeup mask for calls to WaitOnActionDone
| | o C ExceptionCleanupInitialize | system needs to initialize excetpion
| | o C ExceptionInvalidState | invalid state exception
| | o C ExceptionCleanupStop | system has stopped exception
| | o C ExceptionError | generic error exception
| | o C ExceptionCleanup | generic cleanup exception (cleanup = reaction exception after error messages have been displayed)
| | o C ExceptionCore | generic core exception
| | o C ExceptionTimeout | generic timeout exception
| | o C ExceptionInvalidParameter | generic timeout exception
| | o C ExceptionInvalidUsage | generic timeout exception
| | o C Subsystem | asynchronous subsystem base class
| | o C SyncObject | Object used for thread synchronization. It is mainly used as return value of asynchronous methods for communicating with the sensor.
| | \ C SyncObject< T > | Object used for thread synchronization. It is mainly used as return value in asynchronous method declaration.
| o N CommandInterface |
| | o C ExceptionCommandInterface | exception that is thrown from the command interface, when something bad is encountered in the input
| | o C Response | Represents the result that is returned by the Sensor, translated into binary data. The object contains a result object or an error code, but not boththey are mutually exclusive
| | \ C SnapshotImage | Implements a snapshot image that is returned from the sensor.
| o N Communication |
| o N Configuration |
| | \ C SystemSettings | This class contains sensor settings like its (fixed) IP address over USB and WLAN.
| o N EventInterface |
| | o C ExceptionEventInterface | exception that is thrown from the command interface, when something bad is encountered in the input
| | o C SensorEvent | Base class for concrete sensor events
| | o C SensorEventMotorStopped | concrete event representing the event when a motor(s) has been stopped
| | o C SensorEventBatteryStateChanged | concrete event representing the event when the battery's state has changed
| | o C SensorEventRemoteControlKeyPressed | concrete event representing the event when the remote control's key has been pressed
| | o C SensorEventInclinationPlaneChanged | concrete event representing the event when the state of the inclination plane has changed
| | o C SensorEventCalibration | concrete event representing the event when a calibration sequence finished
| | o C SensorEventSystemMessage | Concrete event representing the occurence of a system error or warning
| | \ C SensorEventMeasurePolar | Concrete event representing the occurence of a Measure Polar with Image Event
| o N GeoMath |
| | o C Angle | functions that can be applied to angles in [rad]
| | o C IdentifiedObject | Base class for objects which need a unique id for persisting them
| | o C LiveImagePixelConverter | Converter class for transforming sensor directions to pixel coordinates and back
| | o C Point | Struct representing a point, with double coordinates
| | o C SensorDirection |
| | o C SensorIncline | Represents the inclination plane values from the sensor
| | o C SensorPoint | Point defined with polar coordinates
| | o C Size | Struct representing a size defined by width and heigt
| | \ C Vector | Class for 3d vectors
| o N HardwareInterface |
| | o C Resolution5Mpix | 5M pix image resolution
| | o C ResolutionDVGA | DVGA image resolution
| | o C ResolutionVGA | VGA image resolution
| | o C ResolutionQVGA | QVGA image resolution
| | o C ResolutionSVGA | SVGA image resolution, supported on LD5+ devices
| | o C ResolutionUXGA | UXGA image resolution, supported on LD5+ devices
| | o C SensorError | Error numbers (SkyCom 3.6)
| | o C ILiveImage | Represents the image that is returned from the sensor when live-image is turned on.
| | o C ISensorData | Description: Provides the interface to the Sensor's mirrored data values Responsibilities: mirrors the Sensor's data values and provides an interface to it Collaborators: an implementation of ISensor
| | o C IAxisData | Description: Provides the interface to an Axis's mirrored data values
| | o C SensorTemperatures | consolidates the different temperatures measured on the sensor
| | o C SensorBatteryState | the sensor battery's state, i.e. current voltage level and an indicator of the battery's charging level.
| | o C ISensorEvent |
| | o C ISensorEvents | Defines the sensor's event interface, i.e. which events the sensor generates.
| | o C ISnapImage | Represents a snapshot image that is returned from the sensor by a image-snap command.
| | \ C RemoteControlKey | the keys on the remote control
| o N Logging |
| | o C DummyLogger |
| | \ C ILog |
| \ N SystemInterface |
| o C ExceptionSensorInterface | exception that is thrown from the sensor interface
| o C ExceptionEmptyImageBuffer | Exception thrown when accessing a live image containing no data
| o C ExceptionUnsupportedDeviceType | Exception thrown when the connected device is not supported by this API
| o C ExceptionUnsupportedCommand | Exception thrown when the command is not supported by the connected device
| o C SensorData | collection of the Sensor's current, internal data
| o C AxisData | Represents the iternal data of eitherthe Hz or V axis
| \ C SensorInterface | API for the Leica 3D Disto sensor
\ N Networking |
o N Windows |
| o C DistoOnWlanSearcher |
| \ C UDPer |
o C PlatformWindowsNet | Class for network configuration on Windows platforms (XP, Vista, Win7, Win8)
| o C WlanInterfaceWithNetwork | Contains information about a WLAN network and the adapter where its available
| \ C WlanNetwork | Contains information about a WLAN network.
o C IpDeviceDescriptor | Description of a connected Device
\ C WlanInterfaceException | Custom Exception to catch Wlan Problems with special Utilities (Lenovo etc.)
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask Class Reference

  • Class Hierarchy
  • Class Members
  • Leica
  • Disto
  • Api
  • AsyncSubsystem
  • InterruptReasonMask
Public Attributes | List of all members
Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask Class Reference

wakeup mask for calls to WaitOnActionDone More...

Public Attributes

const uint | WakeMaskCommandAboveNormal = 1
wait on above normal prio commands More...
const uint | WakeMaskCommandHigh = 2
wait on high prio commands More...
const uint | WakeMaskActionsOne = 32
wait for one action More...
const uint | WakeMaskActionsAll = 64
wait on all actions More...
const uint | WakeMaskDefault = (WakeMaskCommandAboveNormal+WakeMaskCommandHigh+WakeMaskActionsAll)
default wake up mask More...

Detailed Description

wakeup mask for calls to WaitOnActionDone

Member Data Documentation

const uint Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask.WakeMaskActionsAll = 64

wait on all actions

const uint Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask.WakeMaskActionsOne = 32

wait for one action

const uint Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask.WakeMaskCommandAboveNormal = 1

wait on above normal prio commands

const uint Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask.WakeMaskCommandHigh = 2

wait on high prio commands

const uint Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask.WakeMaskDefault = (WakeMaskCommandAboveNormal+WakeMaskCommandHigh+WakeMaskActionsAll)

default wake up mask

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize Class Reference

  • Disto
  • Api
  • AsyncSubsystem
  • ExceptionCleanupInitialize
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize Class Reference

system needs to initialize excetpion More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize:
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionCleanupInitialize ()
constructs a cleanup initialize exception More...
ExceptionCleanupInitialize (Exception nestedException)
Initializes a new instance of the T:ExceptionCleanupInitialize class. More...

Protected Member Functions

ExceptionCleanupInitialize (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup
ExceptionCleanup ()
default constructor More...
ExceptionCleanup (Exception nestedException)
Initializes a new instance of the T:ExceptionCleanup class. More...
ExceptionCleanup (SerializationInfo info, StreamingContext context)
constructor used for deserialization More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

system needs to initialize excetpion

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize.ExceptionCleanupInitialize ( )

constructs a cleanup initialize exception

Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize.ExceptionCleanupInitialize ( Exception nestedException )

Initializes a new instance of the T:ExceptionCleanupInitialize class.

Parameters
nestedException The nested exception.
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize.ExceptionCleanupInitialize | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState Class Reference

  • AsyncSubsystem
  • ExceptionInvalidState
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState Class Reference

invalid state exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState:
Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionInvalidState ()
constructs an invalid state exception More...

Protected Member Functions

ExceptionInvalidState (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

invalid state exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState.ExceptionInvalidState ( )

constructs an invalid state exception

Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState.ExceptionInvalidState | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop Class Reference

  • AsyncSubsystem
  • ExceptionCleanupStop
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop Class Reference

system has stopped exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop:
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionCleanupStop ()
constructs a cleanup stop exception More...
ExceptionCleanupStop (Exception nestedException)
Initializes a new instance of the T:ExceptionCleanupStop class. More...

Protected Member Functions

ExceptionCleanupStop (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup
ExceptionCleanup ()
default constructor More...
ExceptionCleanup (Exception nestedException)
Initializes a new instance of the T:ExceptionCleanup class. More...
ExceptionCleanup (SerializationInfo info, StreamingContext context)
constructor used for deserialization More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

system has stopped exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop.ExceptionCleanupStop ( )

constructs a cleanup stop exception

Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop.ExceptionCleanupStop ( Exception nestedException )

Initializes a new instance of the T:ExceptionCleanupStop class.

Parameters
nestedException The nested exception.
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop.ExceptionCleanupStop | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionError Class Reference

  • AsyncSubsystem
  • ExceptionError
Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionError Class Reference

generic error exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionError:
Leica.Disto.Api.AsyncSubsystem.ExceptionCore Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout Leica.Disto.Api.CommandInterface.ExceptionCommandInterface Leica.Disto.Api.EventInterface.ExceptionEventInterface Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer Leica.Disto.Api.SystemInterface.ExceptionSensorInterface Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType

Protected Member Functions

ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

generic error exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionError.ExceptionError ( )
protected

constructs a core error exception

Leica.Disto.Api.AsyncSubsystem.ExceptionError.ExceptionError ( Exception innerException )
protected

constructs a core error exception

Parameters
innerException inner exception
Leica.Disto.Api.AsyncSubsystem.ExceptionError.ExceptionError | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup Class Reference

  • AsyncSubsystem
  • ExceptionCleanup
Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup Class Reference

generic cleanup exception (cleanup = reaction exception after error messages have been displayed) More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup:
Leica.Disto.Api.AsyncSubsystem.ExceptionCore Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop

Protected Member Functions

ExceptionCleanup ()
default constructor More...
ExceptionCleanup (Exception nestedException)
Initializes a new instance of the T:ExceptionCleanup class. More...
ExceptionCleanup (SerializationInfo info, StreamingContext context)
constructor used for deserialization More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

generic cleanup exception (cleanup = reaction exception after error messages have been displayed)

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup.ExceptionCleanup ( )
protected

default constructor

Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup.ExceptionCleanup ( Exception nestedException )
protected

Initializes a new instance of the T:ExceptionCleanup class.

Parameters
nestedException The nested exception.
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup.ExceptionCleanup | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructor used for deserialization

Parameters
info
context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionCore Class Reference

  • AsyncSubsystem
  • ExceptionCore
Protected Member Functions | Properties | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionCore Class Reference

generic core exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionCore:
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout Leica.Disto.Api.CommandInterface.ExceptionCommandInterface Leica.Disto.Api.EventInterface.ExceptionEventInterface Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer Leica.Disto.Api.SystemInterface.ExceptionSensorInterface Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType

Protected Member Functions

ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Properties

ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

generic core exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionCore.ExceptionCore ( )
protected

default constructor

Leica.Disto.Api.AsyncSubsystem.ExceptionCore.ExceptionCore ( Exception innerException )
protected

constructor with native exception

Parameters
innerException native exeption
Leica.Disto.Api.AsyncSubsystem.ExceptionCore.ExceptionCore | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructor used for deserialization of exceptions

Parameters
info | serialization info
context | stream context

Property Documentation

ILog Leica.Disto.Api.AsyncSubsystem.ExceptionCore.Logger
getprotected

Returns the logger associated with the package that has thrown this exception.

The lookup is done based on the UnitId that has been specified to the ctor.

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout Class Reference

  • AsyncSubsystem
  • ExceptionTimeout
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout Class Reference

generic timeout exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionTimeout ()
constructs a timeout exception More...

Protected Member Functions

ExceptionTimeout (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

generic timeout exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout.ExceptionTimeout ( )

constructs a timeout exception

Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout.ExceptionTimeout | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter Class Reference

  • AsyncSubsystem
  • ExceptionInvalidParameter
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter Class Reference

generic timeout exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionInvalidParameter ()
constructs a ExceptionInvalidParameter exception More...

Protected Member Functions

ExceptionInvalidParameter (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

generic timeout exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter.ExceptionInvalidParameter ( )

constructs a ExceptionInvalidParameter exception

Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter.ExceptionInvalidParameter | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage Class Reference

  • AsyncSubsystem
  • ExceptionInvalidUsage
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage Class Reference

generic timeout exception More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionInvalidUsage ()
constructs a ExceptionInvalidParameter exception More...

Protected Member Functions

ExceptionInvalidUsage (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Additional Inherited Members

- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

generic timeout exception

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage.ExceptionInvalidUsage ( )

constructs a ExceptionInvalidParameter exception

Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage.ExceptionInvalidUsage | ( | SerializationInfo | info,
 |  | StreamingContext | context
 | ) |  |
protected

constructs a serialized exception

Parameters
info | serialization info
context | stream context
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.Subsystem Class Reference

  • AsyncSubsystem
  • Subsystem
Public Member Functions | Protected Member Functions | List of all members
Leica.Disto.Api.AsyncSubsystem.Subsystem Class Reference

asynchronous subsystem base class More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.Subsystem:
Leica.Disto.Api.SystemInterface.SensorInterface

Public Member Functions

virtual void | InitInstance ()
Makes the basic initialisation and gets the worker thread running More...
virtual void | ExitInstance ()
stops the implementation's worker thread and prepares for the final cleanup More...
virtual string | GetCurrentState ()
Returns the current state of the Subsystem in text. More...
virtual string | GetSubsystemID ()
Returns the ID of the Subsystem More...
virtual SyncObject | Startup ()
Brings the subsystem into 'ConfigProcessModelSetup' and processes all model dependent and fixed parameters More...
virtual SyncObject | Shutdown ()
Brings the subsystem down to the entry state 'created' More...

Protected Member Functions

Subsystem (string subsystemID, string instanceInfo)
construction More...

Detailed Description

asynchronous subsystem base class

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.Subsystem.Subsystem | ( | string | subsystemID,
 |  | string | instanceInfo
 | ) |  |
protected

construction

Parameters
subsystemID | Subsystem identification
instanceInfo | subsystem inst information

Member Function Documentation

virtual void Leica.Disto.Api.AsyncSubsystem.Subsystem.ExitInstance ( )
virtual

stops the implementation's worker thread and prepares for the final cleanup

Reimplemented in Leica.Disto.Api.SystemInterface.SensorInterface.

virtual string Leica.Disto.Api.AsyncSubsystem.Subsystem.GetCurrentState ( )
virtual

Returns the current state of the Subsystem in text.

Returns
current state
virtual string Leica.Disto.Api.AsyncSubsystem.Subsystem.GetSubsystemID ( )
virtual

Returns the ID of the Subsystem

Returns
Subsystem identification string
virtual void Leica.Disto.Api.AsyncSubsystem.Subsystem.InitInstance ( )
virtual

Makes the basic initialisation and gets the worker thread running

Reimplemented in Leica.Disto.Api.SystemInterface.SensorInterface.

virtual SyncObject Leica.Disto.Api.AsyncSubsystem.Subsystem.Shutdown ( )
virtual

Brings the subsystem down to the entry state 'created'

Returns
async void
virtual SyncObject Leica.Disto.Api.AsyncSubsystem.Subsystem.Startup ( )
virtual

Brings the subsystem into 'ConfigProcessModelSetup' and processes all model dependent and fixed parameters

Returns
async void
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.SyncObject Class Reference

  • AsyncSubsystem
  • SyncObject
Public Member Functions | Static Public Member Functions | Protected Attributes | Properties | List of all members
Leica.Disto.Api.AsyncSubsystem.SyncObject Class Reference

Object used for thread synchronization. It is mainly used as return value of asynchronous methods for communicating with the sensor. More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.SyncObject:
Leica.Disto.Api.AsyncSubsystem.SyncObject< T >

Public Member Functions

virtual void | HasException ()
Checks for pending exceptions. If there is one, it is thrown. More...
virtual object | Synchronize ()
Locks the caller until the event has been signalled. More...
virtual void | Synchronize (int p_TimeoutMs)
Locks the caller until the event has been signalled or the given timeout has been expired More...
virtual bool | HasResult ()
Checks whether a result object is stored. More...
override string | ToString ()
String representation of the object More...

Static Public Member Functions

static implicit operator WaitHandle (SyncObject p_Right)
casting operator for transforming the object into a common 'WaitHandle' object More...

Protected Attributes

readonly ManualResetEvent | _Evt
maintained event object More...
object | ResultObj
result object, if any More...

Properties

object Result [get, set]
Returns the result of the call stored in this object. See HasResult. More...

Detailed Description

Object used for thread synchronization. It is mainly used as return value of asynchronous methods for communicating with the sensor.

Member Function Documentation

virtual void Leica.Disto.Api.AsyncSubsystem.SyncObject.HasException ( )
virtual

Checks for pending exceptions. If there is one, it is thrown.

virtual bool Leica.Disto.Api.AsyncSubsystem.SyncObject.HasResult ( )
virtual

Checks whether a result object is stored.

Returns
true, if a result object is stored
static implicit Leica.Disto.Api.AsyncSubsystem.SyncObject.operator WaitHandle ( SyncObject p_Right )
static

casting operator for transforming the object into a common 'WaitHandle' object

Parameters
p_Right object to convert
Returns
Native WaitHandle
virtual object Leica.Disto.Api.AsyncSubsystem.SyncObject.Synchronize ( )
virtual

Locks the caller until the event has been signalled.

Exceptions
Exception

Reimplemented in Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.

virtual void Leica.Disto.Api.AsyncSubsystem.SyncObject.Synchronize ( int p_TimeoutMs )
virtual

Locks the caller until the event has been signalled or the given timeout has been expired

Parameters
p_TimeoutMs the timeout in ms

Reimplemented in Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.

override string Leica.Disto.Api.AsyncSubsystem.SyncObject.ToString ( )

String representation of the object

Member Data Documentation

readonly ManualResetEvent Leica.Disto.Api.AsyncSubsystem.SyncObject._Evt
protected

maintained event object

object Leica.Disto.Api.AsyncSubsystem.SyncObject.ResultObj
protected

result object, if any

Property Documentation

object Leica.Disto.Api.AsyncSubsystem.SyncObject.Result
getset

Returns the result of the call stored in this object. See HasResult.

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.AsyncSubsystem.SyncObject< T > Class Template Reference

  • AsyncSubsystem
  • SyncObject< T >
Public Member Functions | Properties | List of all members
Leica.Disto.Api.AsyncSubsystem.SyncObject< T > Class Template Reference

Object used for thread synchronization. It is mainly used as return value in asynchronous method declaration. More...

Inheritance diagram for Leica.Disto.Api.AsyncSubsystem.SyncObject< T >:
Leica.Disto.Api.AsyncSubsystem.SyncObject

Public Member Functions

SyncObject ()
construct a sync object with the given signalled state More...
SyncObject (bool p_Signalled)
construct a sync object with the given signalled state More...
virtual void | SignalCompletion (T p_Result)
Signals the event object. More...
new T | Synchronize ()
Locks the caller until the event has been signalled. More...
new T | Synchronize (int p_TimeoutMs)
Locks the caller until the event has been signalled or the given timeout has been expired More...
- Public Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.SyncObject
virtual void | HasException ()
Checks for pending exceptions. If there is one, it is thrown. More...
virtual bool | HasResult ()
Checks whether a result object is stored. More...
override string | ToString ()
String representation of the object More...

Properties

new T | Result [get, set]
Returns the result of the call stored in this object. More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.SyncObject
object | Result [get, set]
Returns the result of the call stored in this object. See HasResult. More...

Additional Inherited Members

- Static Public Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.SyncObject
static implicit | operator WaitHandle (SyncObject p_Right)
casting operator for transforming the object into a common 'WaitHandle' object More...
- Protected Attributes inherited from Leica.Disto.Api.AsyncSubsystem.SyncObject
readonly ManualResetEvent | _Evt
maintained event object More...
object | ResultObj
result object, if any More...

Detailed Description

Object used for thread synchronization. It is mainly used as return value in asynchronous method declaration.

Constructor & Destructor Documentation

Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.SyncObject ( )

construct a sync object with the given signalled state

Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.SyncObject ( bool p_Signalled )

construct a sync object with the given signalled state

Parameters
p_Signalled state of the event upon creation

Member Function Documentation

virtual void Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.SignalCompletion ( T p_Result )
virtual

Signals the event object.

Parameters
p_Result result to store in the syncevent
new T Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.Synchronize ( )
virtual

Locks the caller until the event has been signalled.

Exceptions
Exception

Reimplemented from Leica.Disto.Api.AsyncSubsystem.SyncObject.

new T Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.Synchronize ( int p_TimeoutMs )
virtual

Locks the caller until the event has been signalled or the given timeout has been expired

Parameters
p_TimeoutMs the timeout in ms

Reimplemented from Leica.Disto.Api.AsyncSubsystem.SyncObject.

Property Documentation

new T Leica.Disto.Api.AsyncSubsystem.SyncObject< T >.Result
getset

Returns the result of the call stored in this object.

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.CommandInterface.ExceptionCommandInterface Class Reference

  • CommandInterface
  • ExceptionCommandInterface
Public Member Functions | Properties | List of all members
Leica.Disto.Api.CommandInterface.ExceptionCommandInterface Class Reference

exception that is thrown from the command interface, when something bad is encountered in the input More...

Inheritance diagram for Leica.Disto.Api.CommandInterface.ExceptionCommandInterface:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionCommandInterface (string input, int location)

Properties

string | Input [get]
the input that was bad More...
int | Location [get]
index where in the input the error occured More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog | Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Detailed Description

exception that is thrown from the command interface, when something bad is encountered in the input

Constructor & Destructor Documentation

Leica.Disto.Api.CommandInterface.ExceptionCommandInterface.ExceptionCommandInterface | ( | string | input,
 |  | int | location
 | ) |  |

Property Documentation

string Leica.Disto.Api.CommandInterface.ExceptionCommandInterface.Input
get

the input that was bad

int Leica.Disto.Api.CommandInterface.ExceptionCommandInterface.Location
get

index where in the input the error occured

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.CommandInterface.Response Class Reference

  • CommandInterface
  • Response
Properties | List of all members
Leica.Disto.Api.CommandInterface.Response Class Reference

Represents the result that is returned by the Sensor, translated into binary data. The object contains a result object or an error code, but not boththey are mutually exclusive. More...

Properties

bool | IsError [get]
Returns true when the sensor responded with an error code. More...
object | Result [get, set]
Returns a reference to the result object. A cast to the expected type is needed. More...
int | ErrorCode [get, set]
Returns the error code if the sensor responded with an error, 0 otherwise. For a list of error codes, see the description of this class. More...

Detailed Description

Represents the result that is returned by the Sensor, translated into binary data. The object contains a result object or an error code, but not boththey are mutually exclusive.

Error code list:

Error code | Description
0001 | Basic No answer (from subsystem / driver)
0002 | Basic Timeout
0003 | Basic Wrong command or parameter (SkyCom Commands)
0004 | Basic no valid answer
0005 | Basic busy (function / subsystem is use an cannot accept new commands)
0006 | Basic system call error (operating system return values < 0)
0007 | Basic Temperature out of range
0102 | Vertical angle (command parameter) is not in a valid range (service function only)
0103 | Vertical angle (command parameter) must be in second stage (service function only)
0201 | EDM-Task is busy, no commands accepted
0203 | DMM: wrong command or wrong parameter
0210 | Unexpected (unknown) DMM answer (serial communication error)
0211 | UART1 read/write error
0212 | EDM <-> DMM send/receive timeout (no answer in time frame)
0213 | EDM (critical error)
0214 | EDM (distance out of range)
0220 | DMM: UART error (serial communication error)
0252 | DMM: Temperature to high
0253 | DMM: Temperature to low
0255 | DMM: Signal to low or distance not in range
0256 | DMM: Signal to high
0257 | DMM: Too much background light
0260 | DMM: Coarse phase dont match
0270 | DMM: oscillator -> ASIC Error
0284 | DMM: Laser Error
0286 | DMM: APD in break
0288 | DMM: APD Adjust Error
0289 | DMM: Flash configuration error
0290 | DMM: Reference signal out of range
0301 | Unknown command or wrong parameter
0302 | Receive Buffer Overflow (command string to long)
0303 | TCP/IP Socket Error on event channel (impossible to send event messages)
0402 | SPI-Error (Hz-axis)
0403 | SPI-Command String to long (Hz-axis)
0404 | SPI wrong answer (format error)
0405 | SPI Timeout
0406 | Hz-Motor busy (running)
0502 | SPI-Error (V-axis)
0503 | SPI-Command String to long (V-axis)
0504 | SPI wrong answer (format error)
0505 | SPI Timeout
0506 | V-Motor busy (running)
0601 | General Camera Error (I2C)
0602 | Camera Damaged (Subsystem not starting)
0603 | Camera ROI Error
0604 | No DeadPixelCorrection set
0605 | Bad dead pixel correction
0606 | Too many dead pixels detected
0700 | Plane initialization phase
0701 | Bubble out of working range
0702 | Invalid Parameters
0703 | Plane is out of date
0704 | Good snapshot gone bad
0705 | Image too dark to be calculated
0706 | Camera not properly adjusted
0708 | Bubble damaged
0709 | Bad object for housing found
0725 | Too many bad edges for position of bubble
0734 | Undefined object found for bubble
0750 | Too many bad edges for position of glass body
0760 | Compensator not Calibrated -> cannot be switched on and used
0770 | Selfcalibration not possible because of too high instrument error
0771 | Selfcalibration successful and calibration updated
0773 | Selfcalibration Canceled by User
0789 | No bitmap in filesystem
0793 | Lighting Regulation failed
0794 | Selfcalibration cannot be done -> too many image errors
0798 | Sensor was moved during calibration -> calibration canceled
0799 | Level Pool locked
1002 | file open error (occurrence: get WLAN or Operating System settings)
1003 | file size error (the file is to large, it doesnt fit into the read buffer)
1004 | no information about U-Boot version available
1005 | no information about UBL version available
1006 | file not exist, or no WLAN Card found (pnp Plug & Play ID file missing)
1007 | no WLAN Card (token SD_0001 not found)
1008 | file creation error
1009 | file is empty (0 bytes read)
1010 | token in WLAN info file not found (e.g. Frequency:, ESSID:)
1011 | device locked (anti theft protection)
1012 | PIN or PUC entry required (anti theft protection)
1013 | PUC entry required (anti theft protection) PIN entry is locked
1102 | either HZ-motor or V-motor or both motors are running
2101 / 3101 | Wrong command or wrong parameter
2102 / 3102 | invalid parameter
2103 / 3103 | no answer expected
2104 / 3104 | no cr received
2105 / 3105 | SPI sync lost
2106 / 3106 | production write lock
2121 / 3121 | Flash read error
2122 / 3122 | Flash write error
2123 / 3123 | Flash erase error
2124 / 3124 | Flash sector error
2151 / 3151 | motor already running
2152 / 3152 | motor blocking
2153 / 3153 | motor reach or is in forbidden angle area (V print only)
2154 / 3154 | target position not reached
2201 / 3201 | angles invalid
2211 / 3211 | write access angle register not allowed
2212 / 3212 | register value out of range
2219 / 3219 | picture height out of range
2220 / 3220 | positive exposure dynamic overflow
2221 / 3221 | negative exposure dynamic overflow
2222 / 3222 | exposure time overflow
2223 / 3223 | picture underexposured
2224 / 3224 | picture overexposured
2244 / 3244 | too many peaks found
2245 / 3245 | too less peaks found
2246 / 3246 | peak too slim
2247 / 3247 | peak to wide
2248 / 3248 | bad peak difference
2249 / 3249 | too less peak amplitude
2250 / 3250 | peak topp enc topp ences too big
2251 / 3251 | no peak decoding possible
2252 / 3252 | peak decoding not stable
2253 / 3253 | too less valid finepeaks
2260 / 3260 | hardware failure
2261 / 3261 | initialization error

Property Documentation

int Leica.Disto.Api.CommandInterface.Response.ErrorCode
getset

Returns the error code if the sensor responded with an error, 0 otherwise. For a list of error codes, see the description of this class.

bool Leica.Disto.Api.CommandInterface.Response.IsError
get

Returns true when the sensor responded with an error code.

object Leica.Disto.Api.CommandInterface.Response.Result
getset

Returns a reference to the result object. A cast to the expected type is needed.

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.CommandInterface.SnapshotImage Class Reference

  • CommandInterface
  • SnapshotImage
Properties | List of all members
Leica.Disto.Api.CommandInterface.SnapshotImage Class Reference

Implements a snapshot image that is returned from the sensor. More...

Inheritance diagram for Leica.Disto.Api.CommandInterface.SnapshotImage:
Leica.Disto.Api.HardwareInterface.ISnapImage

Properties

byte[] | Data [get]
The encoded jpeg image data associated with this snap-image More...
SensorDirection | Direction [get, set]
The direction with which this snap-image was taken More...
Point | Crosshair [get]
The coordinate of the crosshair in the snapshot image More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISnapImage
byte[] | Data [get]
The encoded jpeg image data associated with this snap-image More...
SensorDirection | Direction [get]
The direction with that this snap-image was taken More...
Point | Crosshair [get]
The coordinate of the crosshair in the snapshot image More...

Detailed Description

Implements a snapshot image that is returned from the sensor.

Property Documentation

Point Leica.Disto.Api.CommandInterface.SnapshotImage.Crosshair
get

The coordinate of the crosshair in the snapshot image

byte [] Leica.Disto.Api.CommandInterface.SnapshotImage.Data
get

The encoded jpeg image data associated with this snap-image

SensorDirection Leica.Disto.Api.CommandInterface.SnapshotImage.Direction
getset

The direction with which this snap-image was taken

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.Configuration.SystemSettings Class Reference

  • Configuration
  • SystemSettings
Properties | List of all members
Leica.Disto.Api.Configuration.SystemSettings Class Reference

This class contains sensor settings like its (fixed) IP address over USB and WLAN. More...

Properties

static string | IpAddressWlan [get]
IP address of the sensor’s WLAN interface. The subnet mask is 255.255.255.0. More...
static string | IpAddressRndis [get]
IP address of the sensor’s RNDIS interface when connecting via USB cable. The subnet mask is 255.255.255.0. More...

Detailed Description

This class contains sensor settings like its (fixed) IP address over USB and WLAN.

Property Documentation

string Leica.Disto.Api.Configuration.SystemSettings.IpAddressRndis
staticget

IP address of the sensor’s RNDIS interface when connecting via USB cable. The subnet mask is 255.255.255.0.

string Leica.Disto.Api.Configuration.SystemSettings.IpAddressWlan
staticget

IP address of the sensor’s WLAN interface. The subnet mask is 255.255.255.0.

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.ExceptionEventInterface Class Reference

  • EventInterface
  • ExceptionEventInterface
Public Member Functions | Properties | List of all members
Leica.Disto.Api.EventInterface.ExceptionEventInterface Class Reference

exception that is thrown from the command interface, when something bad is encountered in the input More...

Inheritance diagram for Leica.Disto.Api.EventInterface.ExceptionEventInterface:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionEventInterface (string input, int location)
Constructor for event thrown by the event interface package More...

Properties

string | Input [get]
the input that was bad More...
int | Location [get]
index where in the input the error occured More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog | Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...

Detailed Description

exception that is thrown from the command interface, when something bad is encountered in the input

Constructor & Destructor Documentation

Leica.Disto.Api.EventInterface.ExceptionEventInterface.ExceptionEventInterface | ( | string | input,
 |  | int | location
 | ) |  |

Constructor for event thrown by the event interface package

Parameters
input
location

Property Documentation

string Leica.Disto.Api.EventInterface.ExceptionEventInterface.Input
get

the input that was bad

int Leica.Disto.Api.EventInterface.ExceptionEventInterface.Location
get

index where in the input the error occured

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEvent Class Reference

  • EventInterface
  • SensorEvent
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEvent Class Reference

Base class for concrete sensor events More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEvent:
Leica.Disto.Api.HardwareInterface.ISensorEvent Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged Leica.Disto.Api.EventInterface.SensorEventCalibration Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged Leica.Disto.Api.EventInterface.SensorEventMeasurePolar Leica.Disto.Api.EventInterface.SensorEventMotorStopped Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed Leica.Disto.Api.EventInterface.SensorEventSystemMessage

Public Member Functions

bool IsError ()
returns true when an error occured More...

Protected Member Functions

SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...

Protected Attributes

EEvent _EventType

Properties

EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Detailed Description

Base class for concrete sensor events

Constructor & Destructor Documentation

Leica.Disto.Api.EventInterface.SensorEvent.SensorEvent | ( | EEvent | p_EventType,
 |  | int | p_ErrorCode,
 |  | SensorState | p_CurrentState
 | ) |  |
protected

Constructor

Parameters
p_EventType
p_ErrorCode
p_CurrentState

Member Function Documentation

bool Leica.Disto.Api.EventInterface.SensorEvent.IsError ( )

returns true when an error occured

Returns
true when an error occured

Implements Leica.Disto.Api.HardwareInterface.ISensorEvent.

Member Data Documentation

EEvent Leica.Disto.Api.EventInterface.SensorEvent._EventType
protected

Property Documentation

SensorState Leica.Disto.Api.EventInterface.SensorEvent.CurrentState
getset

The current state

int Leica.Disto.Api.EventInterface.SensorEvent.ErrorCode
get

A possible error code that was sent with the event (0 means no error)

EEvent Leica.Disto.Api.EventInterface.SensorEvent.EventType
get

The type of the event that occured

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventMotorStopped Class Reference

  • EventInterface
  • SensorEventMotorStopped
Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEventMotorStopped Class Reference

concrete event representing the event when a motor(s) has been stopped More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventMotorStopped:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Properties

PositioningAxis | Axis [get]
returns the axis /axes that was/were stopped More...
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Additional Inherited Members

- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool IsError ()
returns true when an error occured More...
- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType

Detailed Description

concrete event representing the event when a motor(s) has been stopped

Property Documentation

PositioningAxis Leica.Disto.Api.EventInterface.SensorEventMotorStopped.Axis
get

returns the axis /axes that was/were stopped

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged Class Reference

  • EventInterface
  • SensorEventBatteryStateChanged
Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged Class Reference

concrete event representing the event when the battery's state has changed More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Properties

int | Level [get]
returns the actual level the battery changed to More...
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Additional Inherited Members

- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool IsError ()
returns true when an error occured More...
- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType

Detailed Description

concrete event representing the event when the battery's state has changed

This event is fired when the power cable is plugged/unplugged and when the battery's charge falls below a critical value.

Property Documentation

int Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged.Level
get

returns the actual level the battery changed to

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed Class Reference

  • EventInterface
  • SensorEventRemoteControlKeyPressed
Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed Class Reference

concrete event representing the event when the remote control's key has been pressed More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Properties

RemoteControlKey | Key [get]
returns the key that has been pressed More...
ERemoteControlKeyAction | Action [get]
returns the key action associated with the key that has been pressed More...
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Additional Inherited Members

- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool IsError ()
returns true when an error occured More...
- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType

Detailed Description

concrete event representing the event when the remote control's key has been pressed

Property Documentation

ERemoteControlKeyAction Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed.Action
get

returns the key action associated with the key that has been pressed

RemoteControlKey Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed.Key
get

returns the key that has been pressed

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged Class Reference

  • EventInterface
  • SensorEventInclinationPlaneChanged
Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged Class Reference

concrete event representing the event when the state of the inclination plane has changed More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Properties

InclinationPlaneState | State [get]
returns the actual state of the inclination plane More...
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Additional Inherited Members

- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool IsError ()
returns true when an error occured More...
- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType

Detailed Description

concrete event representing the event when the state of the inclination plane has changed

Property Documentation

InclinationPlaneState Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged.State
get

returns the actual state of the inclination plane

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventCalibration Class Reference

  • EventInterface
  • SensorEventCalibration
List of all members
Leica.Disto.Api.EventInterface.SensorEventCalibration Class Reference

concrete event representing the event when a calibration sequence finished More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventCalibration:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Additional Inherited Members

- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool | IsError ()
returns true when an error occured More...
- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Detailed Description

concrete event representing the event when a calibration sequence finished

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventSystemMessage Class Reference

  • EventInterface
  • SensorEventSystemMessage
Public Member Functions | Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEventSystemMessage Class Reference

Concrete event representing the occurence of a system error or warning More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventSystemMessage:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Public Member Functions

ESystemError GetSystemError ()
Get the system error (out of the bit number) More...
ESystemWarning GetSystemWarning ()
Get the system warning (out of the bit number) More...
- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool IsError ()
returns true when an error occured More...

Properties

ESystemMessage | MessageType [get]
The type of the message, either error or warning More...
int | BitNumber [get]
The bit that has been set or cleared More...
bool | MessageSet [get]
True when the message has been set on the sensor, False otherwise More...
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType

Detailed Description

Concrete event representing the occurence of a system error or warning

Lists the possible error and warning numbers (SkyCom 4.6.5)

Member Function Documentation

ESystemError Leica.Disto.Api.EventInterface.SensorEventSystemMessage.GetSystemError ( )

Get the system error (out of the bit number)

Exceptions
ExceptionInvalidParameter Thrown wenn method is called and message type is warning (instead of error)
Returns
ESystemWarning Leica.Disto.Api.EventInterface.SensorEventSystemMessage.GetSystemWarning ( )

Get the system warning (out of the bit number)

Exceptions
ExceptionInvalidParameter Thrown wenn method is called and message type is error (instead of warning)
Returns

Property Documentation

int Leica.Disto.Api.EventInterface.SensorEventSystemMessage.BitNumber
get

The bit that has been set or cleared

bool Leica.Disto.Api.EventInterface.SensorEventSystemMessage.MessageSet
get

True when the message has been set on the sensor, False otherwise

ESystemMessage Leica.Disto.Api.EventInterface.SensorEventSystemMessage.MessageType
get

The type of the message, either error or warning

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.EventInterface.SensorEventMeasurePolar Class Reference

  • EventInterface
  • SensorEventMeasurePolar
Properties | List of all members
Leica.Disto.Api.EventInterface.SensorEventMeasurePolar Class Reference

Concrete event representing the occurence of a Measure Polar with Image Event More...

Inheritance diagram for Leica.Disto.Api.EventInterface.SensorEventMeasurePolar:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.HardwareInterface.ISensorEvent

Properties

SensorPoint | SensorPoint [get]
returns the SensorPoint More...
SnapshotImage | Image [get]
returns the SnapshotImage More...
- Properties inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent | EventType [get]
The type of the event that occured More...
int | ErrorCode [get]
A possible error code that was sent with the event (0 means no error) More...
SensorState | CurrentState [get, set]
The current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorEvent
EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Additional Inherited Members

- Public Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
bool IsError ()
returns true when an error occured More...
- Protected Member Functions inherited from Leica.Disto.Api.EventInterface.SensorEvent
SensorEvent (EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState)
Constructor More...
- Protected Attributes inherited from Leica.Disto.Api.EventInterface.SensorEvent
EEvent _EventType

Detailed Description

Concrete event representing the occurence of a Measure Polar with Image Event

Holds the Values for Vertical and Horizontal Angle, both with and without tilt, skew distance and tilt-status, crosshair position and SVGA Image (SkyCom 4.5.7)

Property Documentation

SnapshotImage Leica.Disto.Api.EventInterface.SensorEventMeasurePolar.Image
get

returns the SnapshotImage

SensorPoint Leica.Disto.Api.EventInterface.SensorEventMeasurePolar.SensorPoint
get

returns the SensorPoint

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.Angle Class Reference

  • GeoMath
  • Angle
Static Public Member Functions | List of all members
Leica.Disto.Api.GeoMath.Angle Class Reference

functions that can be applied to angles in [rad] More...

Static Public Member Functions

static double | NormalAbsolute (double p_Angle)
normalizes an absolute angle to [0...2PI] More...
static double | NormalRelative (double p_Angle)
normalizes a relative angle to [-PI...+PI] More...
static double | GetShortest (double p_From, double p_To)
returns the shortest relative angle to move when starting at p_From and moving to p_To More...

Detailed Description

functions that can be applied to angles in [rad]

Member Function Documentation

static double Leica.Disto.Api.GeoMath.Angle.GetShortest | ( | double | p_From,
 |  | double | p_To
 | ) |  |
static

returns the shortest relative angle to move when starting at p_From and moving to p_To

Parameters
p_From
p_To
static double Leica.Disto.Api.GeoMath.Angle.NormalAbsolute ( double p_Angle )
static

normalizes an absolute angle to [0...2PI]

Parameters
p_Angle
Returns
static double Leica.Disto.Api.GeoMath.Angle.NormalRelative ( double p_Angle )
static

normalizes a relative angle to [-PI...+PI]

Parameters
p_Angle
Returns
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.IdentifiedObject Class Reference

  • GeoMath
  • IdentifiedObject
Public Member Functions | List of all members
Leica.Disto.Api.GeoMath.IdentifiedObject Class Reference

Base class for objects which need a unique id for persisting them More...

Inheritance diagram for Leica.Disto.Api.GeoMath.IdentifiedObject:
Leica.Disto.Api.GeoMath.SensorDirection Leica.Disto.Api.GeoMath.SensorPoint Leica.Disto.Api.GeoMath.Vector

Public Member Functions

IdentifiedObject ()
Constructor More...
override int | GetHashCode ()
Calculate the hash code More...
override bool | Equals (object p_Obj)
compares this and another object More...
virtual bool | Equals (IdentifiedObject p_IdentifiedObject)
Compares the Guid member of this object with the other objects More...

Detailed Description

Base class for objects which need a unique id for persisting them

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.IdentifiedObject.IdentifiedObject ( )

Constructor

Member Function Documentation

override bool Leica.Disto.Api.GeoMath.IdentifiedObject.Equals ( object p_Obj )

compares this and another object

Parameters
p_Obj the other object to compare with
Returns
true when two objects are equal
virtual bool Leica.Disto.Api.GeoMath.IdentifiedObject.Equals ( IdentifiedObject p_IdentifiedObject )
virtual

Compares the Guid member of this object with the other objects

Parameters
p_IdentifiedObject the other object to compare with
Returns
true when the object's Guid are equal
override int Leica.Disto.Api.GeoMath.IdentifiedObject.GetHashCode ( )

Calculate the hash code

Returns
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.LiveImagePixelConverter Class Reference

  • GeoMath
  • LiveImagePixelConverter
Public Member Functions | Static Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.LiveImagePixelConverter Class Reference

Converter class for transforming sensor directions to pixel coordinates and back. More...

Public Member Functions

LiveImagePixelConverter (EDeviceType deviceType, Size imageSize)
Initializes a new instance of the LiveImagePixelConverter class. More...
void | UpdateValues (SensorDirection sensorDirection, VerticalAxisFace imageOrientation, ImageZoom zoomFactor, Point crosshair)
Initialise for gnomonic projection. This function needs to be called before converting coordinates. More...
Point | ToImagePoint (SensorPoint sensorPoint)
Convert a point measured by the sensor to image coordinates More...
SensorDirection | ToPolarCoordinates (Point imagePoint)
Convert sensor image coordinates to sensor angles (NiHz, NiV) More...

Static Public Member Functions

static double GetOpticsConstant (EDeviceType deviceType)

Properties

Size ImageSize [get]
The size of the image the calcualtions are referred to More...

Detailed Description

Converter class for transforming sensor directions to pixel coordinates and back.

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.LiveImagePixelConverter.LiveImagePixelConverter | ( | EDeviceType | deviceType,
 |  | Size | imageSize
 | ) |  |

Initializes a new instance of the LiveImagePixelConverter class.

Parameters
deviceType | The device the images are coming from
imageSize | Size of the image. For the 3D Disto, this is typically 640×480.

Member Function Documentation

static double Leica.Disto.Api.GeoMath.LiveImagePixelConverter.GetOpticsConstant ( EDeviceType deviceType )
static
Point Leica.Disto.Api.GeoMath.LiveImagePixelConverter.ToImagePoint ( SensorPoint sensorPoint )

Convert a point measured by the sensor to image coordinates

Parameters
sensorPoint Polar coordinates of the point
Returns
Image coordinates of the point
SensorDirection Leica.Disto.Api.GeoMath.LiveImagePixelConverter.ToPolarCoordinates ( Point imagePoint )

Convert sensor image coordinates to sensor angles (NiHz, NiV)

Parameters
imagePoint The coordinates of the sensor image
Returns
Sensor direction
void Leica.Disto.Api.GeoMath.LiveImagePixelConverter.UpdateValues | ( | SensorDirection | sensorDirection,
 |  | VerticalAxisFace | imageOrientation,
 |  | ImageZoom | zoomFactor,
 |  | Point | crosshair
 | ) |  |

Initialise for gnomonic projection. This function needs to be called before converting coordinates.

Parameters
sensorDirection | Direction the sensor points to
imageOrientation | The orientation of the image or sensor when the image has been taken
zoomFactor | Zoom factor used when the image has been taken
crosshair | Crosshair position in the live image

Property Documentation

Size Leica.Disto.Api.GeoMath.LiveImagePixelConverter.ImageSize
get

The size of the image the calcualtions are referred to

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.Point Struct Reference

  • GeoMath
  • Point
Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.Point Struct Reference

Struct representing a point, with double coordinates More...

Public Member Functions

Point (double p_X, double p_Y)
Initilaizes a new instance of the Point class More...

Properties

double | X [get, set]
Gets or sets the x coordinate of the point More...
double | Y [get, set]
Gets or sets the y coordinate of the point More...
static Point | Empty [get]
Gets an empty point (has coordinates 0,0) More...

Detailed Description

Struct representing a point, with double coordinates

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.Point.Point | ( | double | p_X,
 |  | double | p_Y
 | ) |  |

Initilaizes a new instance of the Point class

Parameters
p_X | The x coordinate of the point
p_Y | The x coordinate of the point

Property Documentation

Point Leica.Disto.Api.GeoMath.Point.Empty
staticget

Gets an empty point (has coordinates 0,0)

double Leica.Disto.Api.GeoMath.Point.X
getset

Gets or sets the x coordinate of the point

double Leica.Disto.Api.GeoMath.Point.Y
getset

Gets or sets the y coordinate of the point

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.SensorDirection Class Reference

  • GeoMath
  • SensorDirection
Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.SensorDirection Class Reference

More...

Inheritance diagram for Leica.Disto.Api.GeoMath.SensorDirection:
Leica.Disto.Api.GeoMath.IdentifiedObject

Public Member Functions

SensorDirection ()
Parameterless constructor More...
SensorDirection (double p_Hz, double p_V, double p_NiHz, double p_NiV, int p_CompensatorState)
Constructor More...
virtual SensorDirection | Clone ()
Clone the sensor direction object More...
virtual SensorDirection | GetInFaceOne ()
Get a clone of the direction in face one (V [0..Pi]) More...
- Public Member Functions inherited from Leica.Disto.Api.GeoMath.IdentifiedObject
IdentifiedObject ()
Constructor More...
override int | GetHashCode ()
Calculate the hash code More...
override bool | Equals (object p_Obj)
compares this and another object More...
virtual bool | Equals (IdentifiedObject p_IdentifiedObject)
Compares the Guid member of this object with the other objects More...

Properties

virtual double | Hz [get, set]
Horizontal direction More...
virtual double | V [get, set]
Vertical angle More...
virtual double | NiHz [get, set]
Horizontal direction (no inclination correction) More...
virtual double | NiV [get, set]
Vertical angle (no inclination correction) More...
virtual int | CompensatorState [get, set]
State of the sensor level compensator Maps InclinationPlaneState More...

Detailed Description

Represents the measured angles from the sensor

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.SensorDirection.SensorDirection ( )

Parameterless constructor

Leica.Disto.Api.GeoMath.SensorDirection.SensorDirection | ( | double | p_Hz,
 |  | double | p_V,
 |  | double | p_NiHz,
 |  | double | p_NiV,
 |  | int | p_CompensatorState
 | ) |  |

Constructor

Parameters
p_Hz | Horizontal direction
p_V | Vertical direction
p_NiHz | Horizontal direction (no inclination correction)
p_NiV | Vertical direction (no inclination correction)
p_CompensatorState | State of the sensor level compensator Maps InclinationPlaneState

Member Function Documentation

virtual SensorDirection Leica.Disto.Api.GeoMath.SensorDirection.Clone ( )
virtual

Clone the sensor direction object

Returns
A copy of the sensor direction
virtual SensorDirection Leica.Disto.Api.GeoMath.SensorDirection.GetInFaceOne ( )
virtual

Get a clone of the direction in face one (V [0..Pi])

Returns
The clone in face one

Property Documentation

virtual int Leica.Disto.Api.GeoMath.SensorDirection.CompensatorState
getset

State of the sensor level compensator Maps InclinationPlaneState

virtual double Leica.Disto.Api.GeoMath.SensorDirection.Hz
getset

Horizontal direction

virtual double Leica.Disto.Api.GeoMath.SensorDirection.NiHz
getset

Horizontal direction (no inclination correction)

virtual double Leica.Disto.Api.GeoMath.SensorDirection.NiV
getset

Vertical angle (no inclination correction)

virtual double Leica.Disto.Api.GeoMath.SensorDirection.V
getset

Vertical angle

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.SensorIncline Class Reference

  • GeoMath
  • SensorIncline
Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.SensorIncline Class Reference

Represents the inclination plane values from the sensor. More...

Public Member Functions

SensorIncline (bool p_RawValues)
constructor More...
SensorIncline (double p_IHz, double p_ILen, double p_ICross, int p_CompensatorState, bool p_RawValues)
Constructor for raw or corrected values More...
override string ToString ()
To String More...

Properties

bool | Raw [get]
Returns whether the values are raw values or not More...
virtual double | IHz [get, set]
horizontal angle without corrections for that the inclination applies More...
virtual double | ILen [get, set]
longitudal inclination with respect to IHz More...
virtual double | ICross [get, set]
lateral inclination with respect to IHz More...
virtual int | CompensatorState [get, set]
State of the sensor level compensator Maps InclinationPlaneState More...

Detailed Description

Represents the inclination plane values from the sensor.

Note that ILen and ICross may either be inclination corrected or raw values

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.SensorIncline.SensorIncline ( bool p_RawValues )

constructor

Leica.Disto.Api.GeoMath.SensorIncline.SensorIncline | ( | double | p_IHz,
 |  | double | p_ILen,
 |  | double | p_ICross,
 |  | int | p_CompensatorState,
 |  | bool | p_RawValues
 | ) |  |

Constructor for raw or corrected values

Parameters
p_IHz | horizontal angle without corrections for that the inclination applies
p_ILen | longitudal inclination with respect to IHz or standard procedure corrected
p_ICross | lateral inclination with respect to IHz or standard procedure corrected
p_CompensatorState | State of the sensor level compensator. Maps InclinationPlaneState
p_RawValues | specify true when passing raw values, i.e. standard procedure corrected

Member Function Documentation

override string Leica.Disto.Api.GeoMath.SensorIncline.ToString ( )

To String

Returns

Property Documentation

virtual int Leica.Disto.Api.GeoMath.SensorIncline.CompensatorState
getset

State of the sensor level compensator Maps InclinationPlaneState

virtual double Leica.Disto.Api.GeoMath.SensorIncline.ICross
getset

lateral inclination with respect to IHz

virtual double Leica.Disto.Api.GeoMath.SensorIncline.IHz
getset

horizontal angle without corrections for that the inclination applies

virtual double Leica.Disto.Api.GeoMath.SensorIncline.ILen
getset

longitudal inclination with respect to IHz

bool Leica.Disto.Api.GeoMath.SensorIncline.Raw
get

Returns whether the values are raw values or not

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.SensorPoint Class Reference

  • GeoMath
  • SensorPoint
Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.SensorPoint Class Reference

Point defined with polar coordinates More...

Inheritance diagram for Leica.Disto.Api.GeoMath.SensorPoint:
Leica.Disto.Api.GeoMath.IdentifiedObject

Public Member Functions

SensorPoint ()
Default constructor for point with undefined polar coordinates More...
SensorPoint (double p_Hz, double p_V, double p_Dist, double p_NiHz, double p_NiV, InclinationPlaneState p_CompensatorState, int p_SensorSerialNumber)
Constructor for point defined with polar coordinates More...
virtual double | GetHorDist ()
Calculates the horizontal distance from Sensor More...
virtual double | GetHorDist (SensorPoint p_SecondPoint)
Calculates the horizontal distance from a Point More...
virtual double | GetVertDist ()
Calculates the vertical distance from Sensor. More...
virtual SensorPoint | GetInFaceOne ()
Get a clone of the point in face one (V [0..Pi]) More...
override string | ToString ()
To String More...
- Public Member Functions inherited from Leica.Disto.Api.GeoMath.IdentifiedObject
IdentifiedObject ()
Constructor More...
override int | GetHashCode ()
Calculate the hash code More...
override bool | Equals (object p_Obj)
compares this and another object More...
virtual bool | Equals (IdentifiedObject p_IdentifiedObject)
Compares the Guid member of this object with the other objects More...

Properties

virtual double | Hz [get, set]
Horizontal direction. This value contains all corrections including inclination correction iff the compensator state is still valid. More...
virtual double | V [get, set]
Vertical angle. This value contains all corrections including inclination correction iff the compensator state is still valid. More...
virtual double | Dist [get, set]
Slope distance More...
virtual double | NiHz [get, set]
Horizontal direction (with all corrections but sensor inclination) More...
virtual double | NiV [get, set]
Vertical angle (with all corrections but sensor inclination) More...
virtual InclinationPlaneState | CompensatorState [get, set]
State of the sensor level compensator for this measurement. This affects Hz and V values. More...
int | SensorSerialNumber [get, set]
The serial number of the sensor that measured the point More...

Detailed Description

Point defined with polar coordinates

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.SensorPoint.SensorPoint ( )

Default constructor for point with undefined polar coordinates

Leica.Disto.Api.GeoMath.SensorPoint.SensorPoint | ( | double | p_Hz,
 |  | double | p_V,
 |  | double | p_Dist,
 |  | double | p_NiHz,
 |  | double | p_NiV,
 |  | InclinationPlaneState | p_CompensatorState,
 |  | int | p_SensorSerialNumber
 | ) |  |

Constructor for point defined with polar coordinates

Parameters
p_Hz | Horizontal direction
p_V | Vertical angle
p_Dist | Slope distance
p_NiHz | Horizontal direction without correction of sensor inclination
p_NiV | Vertical angle without correction of sensor inclination
p_CompensatorState | State of the sensor level compensator. Maps InclinationPlaneState
p_SensorSerialNumber

Member Function Documentation

virtual double Leica.Disto.Api.GeoMath.SensorPoint.GetHorDist ( )
virtual

Calculates the horizontal distance from Sensor

Returns
Horizontal Distance
virtual double Leica.Disto.Api.GeoMath.SensorPoint.GetHorDist ( SensorPoint p_SecondPoint )
virtual

Calculates the horizontal distance from a Point

Parameters
p_SecondPoint Second point
Returns
Horizontal distance
virtual SensorPoint Leica.Disto.Api.GeoMath.SensorPoint.GetInFaceOne ( )
virtual

Get a clone of the point in face one (V [0..Pi])

Returns
The clone in face one
virtual double Leica.Disto.Api.GeoMath.SensorPoint.GetVertDist ( )
virtual

Calculates the vertical distance from Sensor.

Returns
override string Leica.Disto.Api.GeoMath.SensorPoint.ToString ( )

To String

Returns

Property Documentation

virtual InclinationPlaneState Leica.Disto.Api.GeoMath.SensorPoint.CompensatorState
getset

State of the sensor level compensator for this measurement. This affects Hz and V values.

virtual double Leica.Disto.Api.GeoMath.SensorPoint.Dist
getset

Slope distance

virtual double Leica.Disto.Api.GeoMath.SensorPoint.Hz
getset

Horizontal direction. This value contains all corrections including inclination correction iff the compensator state is still valid.

virtual double Leica.Disto.Api.GeoMath.SensorPoint.NiHz
getset

Horizontal direction (with all corrections but sensor inclination)

virtual double Leica.Disto.Api.GeoMath.SensorPoint.NiV
getset

Vertical angle (with all corrections but sensor inclination)

int Leica.Disto.Api.GeoMath.SensorPoint.SensorSerialNumber
getset

The serial number of the sensor that measured the point

Note: this property is not persistent

virtual double Leica.Disto.Api.GeoMath.SensorPoint.V
getset

Vertical angle. This value contains all corrections including inclination correction iff the compensator state is still valid.

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.Size Struct Reference

  • GeoMath
  • Size
Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.Size Struct Reference

Struct representing a size defined by width and heigt More...

Public Member Functions

Size (int p_Width, int p_Height)
Initializes a new instance of the Size class. More...

Properties

int | Width [get, set]
Gets or sets the horizontal extent of the size More...
int | Height [get, set]
Gets or sets the vertical extent of the size More...

Detailed Description

Struct representing a size defined by width and heigt

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.Size.Size | ( | int | p_Width,
 |  | int | p_Height
 | ) |  |

Initializes a new instance of the Size class.

Parameters
p_Width | The width
p_Height | The height

Property Documentation

int Leica.Disto.Api.GeoMath.Size.Height
getset

Gets or sets the vertical extent of the size

int Leica.Disto.Api.GeoMath.Size.Width
getset

Gets or sets the horizontal extent of the size

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.GeoMath.Vector Class Reference

  • GeoMath
  • Vector
Public Member Functions | Static Public Member Functions | Properties | List of all members
Leica.Disto.Api.GeoMath.Vector Class Reference

Class for 3d vectors More...

Inheritance diagram for Leica.Disto.Api.GeoMath.Vector:
Leica.Disto.Api.GeoMath.IdentifiedObject

Public Member Functions

Vector (double p_DeltaEast, double p_DeltaNorth, double p_DeltaH)
Constructor taking the 3 components of the vector More...
virtual double | GetAngle (Vector p_SecondVector)
Calculate the angle between two vectors More...
override string | ToString ()
To string More...
virtual Vector | Clone ()
Get a clone of the vector More...
- Public Member Functions inherited from Leica.Disto.Api.GeoMath.IdentifiedObject
IdentifiedObject ()
Constructor More...
override int | GetHashCode ()
Calculate the hash code More...
override bool | Equals (object p_Obj)
compares this and another object More...
virtual bool | Equals (IdentifiedObject p_IdentifiedObject)
Compares the Guid member of this object with the other objects More...

Static Public Member Functions

static bool | AreParallel (Vector p_Vector1, Vector p_Vector2, double p_MaxAngle, bool p_SameDirection)
static Vector | CrossProduct (Vector p_Vector1, Vector p_Vector2)
Calculate the cross product of two vectors. Note: the cross product is not commutative! More...
static double | ScalarProduct (Vector p_Vector1, Vector p_Vector2)
Calculate the scalar product of two vectors More...
static Vector | operator+ (Vector p_FirstVector, Vector p_SecondVector)
Sum of two vectors More...
static Vector | operator- (Vector p_FirstVector, Vector p_SecondVector)
Subtraction of two vectors More...
static Vector | operator* (double p_Number, Vector p_Vector)
Multiply the vector by a number More...
static Vector | operator* (Vector p_Vector, double p_Number)
Multiply the vector by a number More...

Properties

virtual double | V1 [get, set]
Vector length in east direction More...
virtual double | V2 [get, set]
Vector length in north direction More...
virtual double | V3 [get, set]
Vector length in height direction More...
virtual double | DeltaEast [get, set]
Vector length in east direction More...
virtual double | DeltaNorth [get, set]
Vector length in north direction More...
virtual double | DeltaH [get, set]
Vector length in height direction More...
virtual double | Length [get]
Vector lenght More...

Detailed Description

Class for 3d vectors

Persistable with NHibernate –> all public funtions and properties must be virtual

Constructor & Destructor Documentation

Leica.Disto.Api.GeoMath.Vector.Vector | ( | double | p_DeltaEast,
 |  | double | p_DeltaNorth,
 |  | double | p_DeltaH
 | ) |  |

Constructor taking the 3 components of the vector

Parameters
p_DeltaEast | East component
p_DeltaNorth | North component
p_DeltaH | H component

Member Function Documentation

static bool Leica.Disto.Api.GeoMath.Vector.AreParallel | ( | Vector | p_Vector1,
 |  | Vector | p_Vector2,
 |  | double | p_MaxAngle,
 |  | bool | p_SameDirection
 | ) |  |
static

Parameters
p_Vector1
p_Vector2
p_MaxAngle
p_SameDirection
Returns
virtual Vector Leica.Disto.Api.GeoMath.Vector.Clone ( )
virtual

Get a clone of the vector

Returns
The clone
static Vector Leica.Disto.Api.GeoMath.Vector.CrossProduct | ( | Vector | p_Vector1,
 |  | Vector | p_Vector2
 | ) |  |
static

Calculate the cross product of two vectors. Note: the cross product is not commutative!

Parameters
p_Vector1 | First vector
p_Vector2 | Second vector
Returns
virtual double Leica.Disto.Api.GeoMath.Vector.GetAngle ( Vector p_SecondVector )
virtual

Calculate the angle between two vectors

Parameters
p_SecondVector
Returns
static Vector Leica.Disto.Api.GeoMath.Vector.operator* | ( | double | p_Number,
 |  | Vector | p_Vector
 | ) |  |
static

Multiply the vector by a number

Parameters
p_Number | Number
p_Vector | Vector
Returns
static Vector Leica.Disto.Api.GeoMath.Vector.operator* | ( | Vector | p_Vector,
 |  | double | p_Number
 | ) |  |
static

Multiply the vector by a number

Parameters
p_Vector | Vector
p_Number | Number
Returns
static Vector Leica.Disto.Api.GeoMath.Vector.operator+ | ( | Vector | p_FirstVector,
 |  | Vector | p_SecondVector
 | ) |  |
static

Sum of two vectors

Parameters
p_FirstVector | First vector
p_SecondVector | Second vector
Returns
Sum
static Vector Leica.Disto.Api.GeoMath.Vector.operator- | ( | Vector | p_FirstVector,
 |  | Vector | p_SecondVector
 | ) |  |
static

Subtraction of two vectors

Parameters
p_FirstVector | First vector
p_SecondVector | Second vector
Returns
subtraction
static double Leica.Disto.Api.GeoMath.Vector.ScalarProduct | ( | Vector | p_Vector1,
 |  | Vector | p_Vector2
 | ) |  |
static

Calculate the scalar product of two vectors

Parameters
p_Vector1 | First vector
p_Vector2 | Second vector
Returns
override string Leica.Disto.Api.GeoMath.Vector.ToString ( )

To string

Returns

Property Documentation

virtual double Leica.Disto.Api.GeoMath.Vector.DeltaEast
getset

Vector length in east direction

virtual double Leica.Disto.Api.GeoMath.Vector.DeltaH
getset

Vector length in height direction

virtual double Leica.Disto.Api.GeoMath.Vector.DeltaNorth
getset

Vector length in north direction

virtual double Leica.Disto.Api.GeoMath.Vector.Length
get

Vector lenght

virtual double Leica.Disto.Api.GeoMath.Vector.V1
getset

Vector length in east direction

virtual double Leica.Disto.Api.GeoMath.Vector.V2
getset

Vector length in north direction

virtual double Leica.Disto.Api.GeoMath.Vector.V3
getset

Vector length in height direction

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.Resolution5Mpix Class Reference

  • HardwareInterface
  • Resolution5Mpix
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.Resolution5Mpix Class Reference

5M pix image resolution More...

Public Attributes

const int | Width = 2752
width of an image with 5M pix resolution More...
const int | Height = 2004
height of an image with 5M pix resolution More...

Detailed Description

5M pix image resolution

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.Resolution5Mpix.Height = 2004

height of an image with 5M pix resolution

const int Leica.Disto.Api.HardwareInterface.Resolution5Mpix.Width = 2752

width of an image with 5M pix resolution

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ResolutionDVGA Class Reference

  • HardwareInterface
  • ResolutionDVGA
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.ResolutionDVGA Class Reference

DVGA image resolution More...

Public Attributes

const int | Width = 1280
width of an image with DVGA resolution More...
const int | Height = 960
height of an image with DVGA resolution More...

Detailed Description

DVGA image resolution

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.ResolutionDVGA.Height = 960

height of an image with DVGA resolution

const int Leica.Disto.Api.HardwareInterface.ResolutionDVGA.Width = 1280

width of an image with DVGA resolution

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ResolutionVGA Class Reference

  • HardwareInterface
  • ResolutionVGA
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.ResolutionVGA Class Reference

VGA image resolution More...

Public Attributes

const int | Width = 640
width of an image with VGA resolution More...
const int | Height = 480
height of an image with VGA resolution More...

Detailed Description

VGA image resolution

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.ResolutionVGA.Height = 480

height of an image with VGA resolution

const int Leica.Disto.Api.HardwareInterface.ResolutionVGA.Width = 640

width of an image with VGA resolution

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ResolutionQVGA Class Reference

  • HardwareInterface
  • ResolutionQVGA
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.ResolutionQVGA Class Reference

QVGA image resolution More...

Public Attributes

const int | Width = 320
width of an image with QVGA resolution More...
const int | Height = 240
height of an image with QVGA resolution More...

Detailed Description

QVGA image resolution

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.ResolutionQVGA.Height = 240

height of an image with QVGA resolution

const int Leica.Disto.Api.HardwareInterface.ResolutionQVGA.Width = 320

width of an image with QVGA resolution

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ResolutionSVGA Class Reference

  • HardwareInterface
  • ResolutionSVGA
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.ResolutionSVGA Class Reference

SVGA image resolution, supported on LD5+ devices More...

Public Attributes

const int | Width = 800
const int | Height = 600

Detailed Description

SVGA image resolution, supported on LD5+ devices

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.ResolutionSVGA.Height = 600
const int Leica.Disto.Api.HardwareInterface.ResolutionSVGA.Width = 800
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ResolutionUXGA Class Reference

  • HardwareInterface
  • ResolutionUXGA
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.ResolutionUXGA Class Reference

UXGA image resolution, supported on LD5+ devices More...

Public Attributes

const int | Width = 1600
const int | Height = 1200

Detailed Description

UXGA image resolution, supported on LD5+ devices

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.ResolutionUXGA.Height = 1200
const int Leica.Disto.Api.HardwareInterface.ResolutionUXGA.Width = 1600
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.SensorError Class Reference

  • HardwareInterface
  • SensorError
Public Attributes | List of all members
Leica.Disto.Api.HardwareInterface.SensorError Class Reference

Error numbers (SkyCom 3.6) More...

Public Attributes

const int | EdmWorkingRange = 214
EDM measurement out of range (0.5 - 50 m) More...
const int | LevelSensorInitializing = 700
the level sensor ("bubble") was not ready and initializing when the command was issued More...
const int | LevOutOfWorkingRange = 701
bubble is out of its working range More...
const int | LevCalibrationChanged = 771
bubble calbration was successfull, new values are stored More...
const int | LevCalibrationCancelled = 773
bubble calbration was cancelled with lm D More...
const int | HzMotorBlocked = 2152
Hz motor blocking More...
const int | HzOutOfRange = 2153
Hz motor reach or is in forbidden angle area More...
const int | VMotorBlocked = 3152
V motor blocking More...
const int | VOutOfRange = 3153
V motor reach or is in forbidden angle area More...

Detailed Description

Error numbers (SkyCom 3.6)

Returned from various commands

Member Data Documentation

const int Leica.Disto.Api.HardwareInterface.SensorError.EdmWorkingRange = 214

EDM measurement out of range (0.5 - 50 m)

const int Leica.Disto.Api.HardwareInterface.SensorError.HzMotorBlocked = 2152

Hz motor blocking

const int Leica.Disto.Api.HardwareInterface.SensorError.HzOutOfRange = 2153

Hz motor reach or is in forbidden angle area

const int Leica.Disto.Api.HardwareInterface.SensorError.LevCalibrationCancelled = 773

bubble calbration was cancelled with lm D

const int Leica.Disto.Api.HardwareInterface.SensorError.LevCalibrationChanged = 771

bubble calbration was successfull, new values are stored

const int Leica.Disto.Api.HardwareInterface.SensorError.LevelSensorInitializing = 700

the level sensor ("bubble") was not ready and initializing when the command was issued

const int Leica.Disto.Api.HardwareInterface.SensorError.LevOutOfWorkingRange = 701

bubble is out of its working range

const int Leica.Disto.Api.HardwareInterface.SensorError.VMotorBlocked = 3152

V motor blocking

const int Leica.Disto.Api.HardwareInterface.SensorError.VOutOfRange = 3153

V motor reach or is in forbidden angle area

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ILiveImage Interface Reference

  • HardwareInterface
  • ILiveImage
Public Member Functions | Events | List of all members
Leica.Disto.Api.HardwareInterface.ILiveImage Interface Reference

Represents the image that is returned from the sensor when live-image is turned on. More...

Inherited by Leica.Disto.Api.SystemInterface.LiveImage.

Public Member Functions

void | Get (out SensorDirection direction, out Point crosshair, out VerticalAxisFace orientation, out byte[] buffer, out int bufferSize)
Returns the latest live image as raw byte array (JPEG stream) plus the direction associated with it. More...
void | Set (byte[] p_RawData, int p_Size)
Assigns a new datagam to the image object. The datagram contains the angles and image. More...

Events

LiveImageChangedHandler LiveImageChanged
event that is fired when the live-image has changed More...

Detailed Description

Represents the image that is returned from the sensor when live-image is turned on.

Member Function Documentation

void Leica.Disto.Api.HardwareInterface.ILiveImage.Get | ( | out SensorDirection | direction,
 |  | out Point | crosshair,
 |  | out VerticalAxisFace | orientation,
 |  | out byte[] | buffer,
 |  | out int | bufferSize
 | ) |  |

Returns the latest live image as raw byte array (JPEG stream) plus the direction associated with it.

Note that the returned image is removed from the queue, subsequent reads will return a different image. If there is no image currently available, this method will throw an ExceptionEmptyImageBuffer.

Parameters
direction | Returns the direction associated with this live image
crosshair | The coordinates of the crosshair to plot on the image, in image coordinates (pixels, origin is top left).
orientation | The orientation of the image
buffer | The raw buffer that contains the JPEG image data
bufferSize | The valid size of the raw data in the buffer
Exceptions
ExceptionEmptyImageBuffer
void Leica.Disto.Api.HardwareInterface.ILiveImage.Set | ( | byte[] | p_RawData,
 |  | int | p_Size
 | ) |  |

Assigns a new datagam to the image object. The datagram contains the angles and image.

Parameters
p_RawData | the raw datagram buffer received from the server (sensor)
p_Size | the size of valid bytes contained in the buffer

Event Documentation

LiveImageChangedHandler Leica.Disto.Api.HardwareInterface.ILiveImage.LiveImageChanged

event that is fired when the live-image has changed

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ISensorData Interface Reference

  • HardwareInterface
  • ISensorData
Public Member Functions | Properties | Events | List of all members
Leica.Disto.Api.HardwareInterface.ISensorData Interface Reference

Description: Provides the interface to the Sensor's mirrored data values Responsibilities: mirrors the Sensor's data values and provides an interface to it Collaborators: an implementation of ISensor More...

Inheritance diagram for Leica.Disto.Api.HardwareInterface.ISensorData:
Leica.Disto.Api.SystemInterface.SensorData

Public Member Functions

IAxisData | AxisData (PositioningAxis p_Axis)
returns an IAxisData interface; allowd read access to the corresponding axis's data More...
void | Reset ()
Sets all concrete data values to default/undefined More...
void | SetErrors (UInt16 p_ErrorBits)
sets the system error bits More...
UInt16 | GetErrors ()
Returns a a 16bit unsigned int each bit representing an error More...
void | Set (ESystemError p_Error)
Sets the specified error More...
void | Clear (ESystemError p_Error)
Clears the specified error More...
bool | IsSet (ESystemError p_Error)
Returns true when the specified error is set, false otherwise More...
void | SetWarnings (UInt16 p_WarningBits)
Sets the system warning bits (internal) More...
UInt16 | GetWarnings ()
Returns a a 16bit unsigned int each bit representing a warning More...
void | Set (ESystemWarning p_Warning)
Sets the specified warning More...
void | Clear (ESystemWarning p_Warning)
Clears the specified warning More...
bool | IsSet (ESystemWarning p_Warning)
Returns true when the specified warning is set, false otherwise More...

Properties

SensorState | State [get]
the current State More...
bool | SecurityEnabled [get]
indicates whether the theft protection is enabled on the sensor, i.e. a PIN must be entered More...
ImageZoom | ImageZoom [get]
the current image zoom More...
ImageBrightness | ImageBrightness [get]
the current image brightness More...
ImageMode | ImageMode [get]
the current image mode (live-image on/off) More...
LaserMode | LaserMode [get]
the current laser mode More...
LevelMode | LevelMode [get]
the current inclination error compensation mode More...
TiltSensorMode | LevelSensitivity [get]
the current inclination error compensation sensitivity More...
InclinationPlaneState | InclinationPlaneState [get]
the state of the plane that is determined periodically More...
VerticalAxisFace | Face [get]
the current face More...
string | SensorIp [get]
how the sensor is accessed More...
SensorBatteryState | BatteryState [get]
the battery's state (voltage and charging level) More...
SensorDirection | SensorDirection [get]
the sensor's current direction More...
EDeviceType | DeviceType [get]
the sensor's device / firmware type More...
int | SerialNumber [get]
the sensor's serial number More...
int | EquipmentNumber [get]
the sensor's equipment number (ERP) More...
double | OperatingHours [get]
the total accumulated uptime of the sensor [hours] More...

Events

SensorDataChangedHandler SensorDataChanged
event that is fired when a Sensor's mirrored data value has changed More...

Detailed Description

Description: Provides the interface to the Sensor's mirrored data values Responsibilities: mirrors the Sensor's data values and provides an interface to it Collaborators: an implementation of ISensor

Member Function Documentation

IAxisData Leica.Disto.Api.HardwareInterface.ISensorData.AxisData ( PositioningAxis p_Axis )

returns an IAxisData interface; allowd read access to the corresponding axis's data

Parameters
p_Axis
Returns

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.Clear ( ESystemError p_Error )

Clears the specified error

Parameters
p_Error the error to clear

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.Clear ( ESystemWarning p_Warning )

Clears the specified warning

Parameters
p_Warning the warning to clear

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

UInt16 Leica.Disto.Api.HardwareInterface.ISensorData.GetErrors ( )

Returns a a 16bit unsigned int each bit representing an error

Returns

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

UInt16 Leica.Disto.Api.HardwareInterface.ISensorData.GetWarnings ( )

Returns a a 16bit unsigned int each bit representing a warning

Returns

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

bool Leica.Disto.Api.HardwareInterface.ISensorData.IsSet ( ESystemError p_Error )

Returns true when the specified error is set, false otherwise

Parameters
p_Error the error to query
Returns

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

bool Leica.Disto.Api.HardwareInterface.ISensorData.IsSet ( ESystemWarning p_Warning )

Returns true when the specified warning is set, false otherwise

Parameters
p_Warning the warning to query
Returns

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.Reset ( )

Sets all concrete data values to default/undefined

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.Set ( ESystemError p_Error )

Sets the specified error

Parameters
p_Error the error to set

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.Set ( ESystemWarning p_Warning )

Sets the specified warning

Parameters
p_Warning the warning to set

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.SetErrors ( UInt16 p_ErrorBits )

sets the system error bits

Parameters
p_ErrorBits

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

void Leica.Disto.Api.HardwareInterface.ISensorData.SetWarnings ( UInt16 p_WarningBits )

Sets the system warning bits (internal)

Parameters
p_WarningBits

Implemented in Leica.Disto.Api.SystemInterface.SensorData.

Property Documentation

SensorBatteryState Leica.Disto.Api.HardwareInterface.ISensorData.BatteryState
get

the battery's state (voltage and charging level)

EDeviceType Leica.Disto.Api.HardwareInterface.ISensorData.DeviceType
get

the sensor's device / firmware type

int Leica.Disto.Api.HardwareInterface.ISensorData.EquipmentNumber
get

the sensor's equipment number (ERP)

VerticalAxisFace Leica.Disto.Api.HardwareInterface.ISensorData.Face
get

the current face

ImageBrightness Leica.Disto.Api.HardwareInterface.ISensorData.ImageBrightness
get

the current image brightness

ImageMode Leica.Disto.Api.HardwareInterface.ISensorData.ImageMode
get

the current image mode (live-image on/off)

ImageZoom Leica.Disto.Api.HardwareInterface.ISensorData.ImageZoom
get

the current image zoom

InclinationPlaneState Leica.Disto.Api.HardwareInterface.ISensorData.InclinationPlaneState
get

the state of the plane that is determined periodically

LaserMode Leica.Disto.Api.HardwareInterface.ISensorData.LaserMode
get

the current laser mode

LevelMode Leica.Disto.Api.HardwareInterface.ISensorData.LevelMode
get

the current inclination error compensation mode

TiltSensorMode Leica.Disto.Api.HardwareInterface.ISensorData.LevelSensitivity
get

the current inclination error compensation sensitivity

double Leica.Disto.Api.HardwareInterface.ISensorData.OperatingHours
get

the total accumulated uptime of the sensor [hours]

bool Leica.Disto.Api.HardwareInterface.ISensorData.SecurityEnabled
get

indicates whether the theft protection is enabled on the sensor, i.e. a PIN must be entered

SensorDirection Leica.Disto.Api.HardwareInterface.ISensorData.SensorDirection
get

the sensor's current direction

string Leica.Disto.Api.HardwareInterface.ISensorData.SensorIp
get

how the sensor is accessed

int Leica.Disto.Api.HardwareInterface.ISensorData.SerialNumber
get

the sensor's serial number

SensorState Leica.Disto.Api.HardwareInterface.ISensorData.State
get

the current State

Event Documentation

SensorDataChangedHandler Leica.Disto.Api.HardwareInterface.ISensorData.SensorDataChanged

event that is fired when a Sensor's mirrored data value has changed

Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.IAxisData Interface Reference

  • HardwareInterface
  • IAxisData
Properties | List of all members
Leica.Disto.Api.HardwareInterface.IAxisData Interface Reference

Description: Provides the interface to an Axis's mirrored data values More...

Inheritance diagram for Leica.Disto.Api.HardwareInterface.IAxisData:
Leica.Disto.Api.SystemInterface.AxisData

Properties

PositioningAxis | Axis [get]
this axis's identifier More...
double | Angle [get]
the current angle of this axis, containing all corrections More...
double | NiAngle [get]
the current angle of this axis, not corrected by the inclination (but all other corrections) More...
PositioningDirection | Direction [get]
the current direction of this axis More...
int | Velocity [get]
the current velocity of this axis More...
AxisState | State [get]
the current state of this axis More...

Detailed Description

Description: Provides the interface to an Axis's mirrored data values

Responsibilities: mirrors the Axis data values and provides an interface to it

Collaborators: an implementation of ISensorData

Property Documentation

double Leica.Disto.Api.HardwareInterface.IAxisData.Angle
get

the current angle of this axis, containing all corrections

PositioningAxis Leica.Disto.Api.HardwareInterface.IAxisData.Axis
get

this axis's identifier

PositioningDirection Leica.Disto.Api.HardwareInterface.IAxisData.Direction
get

the current direction of this axis

double Leica.Disto.Api.HardwareInterface.IAxisData.NiAngle
get

the current angle of this axis, not corrected by the inclination (but all other corrections)

AxisState Leica.Disto.Api.HardwareInterface.IAxisData.State
get

the current state of this axis

int Leica.Disto.Api.HardwareInterface.IAxisData.Velocity
get

the current velocity of this axis

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.SensorTemperatures Class Reference

  • HardwareInterface
  • SensorTemperatures
Public Member Functions | Properties | List of all members
Leica.Disto.Api.HardwareInterface.SensorTemperatures Class Reference

consolidates the different temperatures measured on the sensor More...

Public Member Functions

SensorTemperatures ()
default constructor initializing all values to the smallest possible integer More...

Properties

double | EdmSensor [get, set]
the temperature of the EDM sensor More...
double | HzSensor [get, set]
the temperature of the HZ sensor More...
double | VSensor [get, set]
the temperature of the V sensor More...

Detailed Description

consolidates the different temperatures measured on the sensor

Constructor & Destructor Documentation

Leica.Disto.Api.HardwareInterface.SensorTemperatures.SensorTemperatures ( )

default constructor initializing all values to the smallest possible integer

Property Documentation

double Leica.Disto.Api.HardwareInterface.SensorTemperatures.EdmSensor
getset

the temperature of the EDM sensor

double Leica.Disto.Api.HardwareInterface.SensorTemperatures.HzSensor
getset

the temperature of the HZ sensor

double Leica.Disto.Api.HardwareInterface.SensorTemperatures.VSensor
getset

the temperature of the V sensor

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.SensorBatteryState Class Reference

  • HardwareInterface
  • SensorBatteryState
Public Member Functions | Properties | List of all members
Leica.Disto.Api.HardwareInterface.SensorBatteryState Class Reference

the sensor battery's state, i.e. current voltage level and an indicator of the battery's charging level. More...

Public Member Functions

SensorBatteryState ()
default constructor initializing all values to the smallest possible integer or NaN More...
SensorBatteryState (double p_Voltage, int p_ChargingLevel)
constructor initializing voltage and level More...

Properties

int | ChargingLevel [get, set]
the battery's state [0..6] More...
double | Voltage [get, set]
the battery's voltage level [0..18V] More...

Detailed Description

the sensor battery's state, i.e. current voltage level and an indicator of the battery's charging level.

Constructor & Destructor Documentation

Leica.Disto.Api.HardwareInterface.SensorBatteryState.SensorBatteryState ( )

default constructor initializing all values to the smallest possible integer or NaN

Leica.Disto.Api.HardwareInterface.SensorBatteryState.SensorBatteryState | ( | double | p_Voltage,
 |  | int | p_ChargingLevel
 | ) |  |

constructor initializing voltage and level

Property Documentation

int Leica.Disto.Api.HardwareInterface.SensorBatteryState.ChargingLevel
getset

the battery's state [0..6]

double Leica.Disto.Api.HardwareInterface.SensorBatteryState.Voltage
getset

the battery's voltage level [0..18V]

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ISensorEvent Interface Reference

  • HardwareInterface
  • ISensorEvent
Public Member Functions | Properties | List of all members
Leica.Disto.Api.HardwareInterface.ISensorEvent Interface Reference

More...

Inheritance diagram for Leica.Disto.Api.HardwareInterface.ISensorEvent:
Leica.Disto.Api.EventInterface.SensorEvent Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged Leica.Disto.Api.EventInterface.SensorEventCalibration Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged Leica.Disto.Api.EventInterface.SensorEventMeasurePolar Leica.Disto.Api.EventInterface.SensorEventMotorStopped Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed Leica.Disto.Api.EventInterface.SensorEventSystemMessage

Public Member Functions

bool IsError ()
returns true when an error occured More...

Properties

EEvent | EventType [get]
returns the event type of a concrete event More...
int | ErrorCode [get]
returns the error code in case an error occured, 0 otherwise More...

Detailed Description

interface for events that are reveived from the sensor events can originate from: - axes - remote control - battery - measurements

Member Function Documentation

bool Leica.Disto.Api.HardwareInterface.ISensorEvent.IsError ( )

returns true when an error occured

Returns
true when an error occured

Implemented in Leica.Disto.Api.EventInterface.SensorEvent.

Property Documentation

int Leica.Disto.Api.HardwareInterface.ISensorEvent.ErrorCode
get

returns the error code in case an error occured, 0 otherwise

Returns
the error code or 0
EEvent Leica.Disto.Api.HardwareInterface.ISensorEvent.EventType
get

returns the event type of a concrete event

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ISensorEvents Interface Reference

  • HardwareInterface
  • ISensorEvents
Events | List of all members
Leica.Disto.Api.HardwareInterface.ISensorEvents Interface Reference

Defines the sensor's event interface, i.e. which events the sensor generates. More...

Inheritance diagram for Leica.Disto.Api.HardwareInterface.ISensorEvents:
Leica.Disto.Api.SystemInterface.SensorInterface

Events

EventReceivedHandler BatteryStateChanged
event when the battery's state changed, i.e. when the power cord is plugged/unlugged or when the battery goes empty More...
EventReceivedHandler RemoteControlKeyPressed
event when the key of the remote control is pressed More...
EventReceivedHandler InclinationPlaneChanged
event when the inclination plane changed More...
EventReceivedHandler SystemMessageReceived
event when a system message (warnign/error) has been received from the sensor More...
EventReceivedHandler MeasurePolarEvent
event when a MeasurePolarWithImage Event has been received from the sensor More...

Detailed Description

Defines the sensor's event interface, i.e. which events the sensor generates.

Event Documentation

EventReceivedHandler Leica.Disto.Api.HardwareInterface.ISensorEvents.BatteryStateChanged

event when the battery's state changed, i.e. when the power cord is plugged/unlugged or when the battery goes empty

EventReceivedHandler Leica.Disto.Api.HardwareInterface.ISensorEvents.InclinationPlaneChanged

event when the inclination plane changed

EventReceivedHandler Leica.Disto.Api.HardwareInterface.ISensorEvents.MeasurePolarEvent

event when a MeasurePolarWithImage Event has been received from the sensor

EventReceivedHandler Leica.Disto.Api.HardwareInterface.ISensorEvents.RemoteControlKeyPressed

event when the key of the remote control is pressed

EventReceivedHandler Leica.Disto.Api.HardwareInterface.ISensorEvents.SystemMessageReceived

event when a system message (warnign/error) has been received from the sensor

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.ISnapImage Interface Reference

  • HardwareInterface
  • ISnapImage
Properties | List of all members
Leica.Disto.Api.HardwareInterface.ISnapImage Interface Reference

Represents a snapshot image that is returned from the sensor by a image-snap command. More...

Inheritance diagram for Leica.Disto.Api.HardwareInterface.ISnapImage:
Leica.Disto.Api.CommandInterface.SnapshotImage

Properties

byte[] | Data [get]
The encoded jpeg image data associated with this snap-image More...
SensorDirection | Direction [get]
The direction with that this snap-image was taken More...
Point | Crosshair [get]
The coordinate of the crosshair in the snapshot image More...

Detailed Description

Represents a snapshot image that is returned from the sensor by a image-snap command.

Property Documentation

Point Leica.Disto.Api.HardwareInterface.ISnapImage.Crosshair
get

The coordinate of the crosshair in the snapshot image

byte [] Leica.Disto.Api.HardwareInterface.ISnapImage.Data
get

The encoded jpeg image data associated with this snap-image

SensorDirection Leica.Disto.Api.HardwareInterface.ISnapImage.Direction
get

The direction with that this snap-image was taken

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.HardwareInterface.RemoteControlKey Class Reference

  • HardwareInterface
  • RemoteControlKey
Public Member Functions | Properties | List of all members
Leica.Disto.Api.HardwareInterface.RemoteControlKey Class Reference

the keys on the remote control More...

Public Member Functions

bool | IsUp ()
checks whether the UP key has been pressed More...
bool | IsDown ()
checks whether the DOWN key has been pressed More...
bool | IsLeft ()
checks whether the LEFT key has been pressed More...
bool | IsRight ()
checks whether the RIGHT key has been pressed More...
bool | IsDist ()
checks whether the DIST key has been pressed More...
RemoteControlKey (int p_Code)
ctor More...
override string | ToString ()
Returns a string representation for this key More...

Properties

static int | Up [get]
code for key up More...
static int | Down [get]
code for key down More...
static int | Left [get]
code for key left More...
static int | Right [get]
code for key right More...
static int | Dist [get]
code for key to trigger measurement More...
int | Code [get]
the key code that was pressed More...

Detailed Description

the keys on the remote control

Constructor & Destructor Documentation

Leica.Disto.Api.HardwareInterface.RemoteControlKey.RemoteControlKey ( int p_Code )

ctor

Parameters
p_Code

Member Function Documentation

bool Leica.Disto.Api.HardwareInterface.RemoteControlKey.IsDist ( )

checks whether the DIST key has been pressed

Returns
true when the DIST key has been pressed, false otherwise
bool Leica.Disto.Api.HardwareInterface.RemoteControlKey.IsDown ( )

checks whether the DOWN key has been pressed

Returns
true when the DOWN key has been pressed, false otherwise
bool Leica.Disto.Api.HardwareInterface.RemoteControlKey.IsLeft ( )

checks whether the LEFT key has been pressed

Returns
true when the LEFT key has been pressed, false otherwise
bool Leica.Disto.Api.HardwareInterface.RemoteControlKey.IsRight ( )

checks whether the RIGHT key has been pressed

Returns
true when the RIGHT key has been pressed, false otherwise
bool Leica.Disto.Api.HardwareInterface.RemoteControlKey.IsUp ( )

checks whether the UP key has been pressed

Returns
true when the UP key has been pressed, false otherwise
override string Leica.Disto.Api.HardwareInterface.RemoteControlKey.ToString ( )

Returns a string representation for this key

Returns

Property Documentation

int Leica.Disto.Api.HardwareInterface.RemoteControlKey.Code
get

the key code that was pressed

int Leica.Disto.Api.HardwareInterface.RemoteControlKey.Dist
staticget

code for key to trigger measurement

int Leica.Disto.Api.HardwareInterface.RemoteControlKey.Down
staticget

code for key down

int Leica.Disto.Api.HardwareInterface.RemoteControlKey.Left
staticget

code for key left

int Leica.Disto.Api.HardwareInterface.RemoteControlKey.Right
staticget

code for key right

int Leica.Disto.Api.HardwareInterface.RemoteControlKey.Up
staticget

code for key up

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.Logging.DummyLogger Class Reference

  • Logging
  • DummyLogger
Public Member Functions | List of all members
Leica.Disto.Api.Logging.DummyLogger Class Reference
Inheritance diagram for Leica.Disto.Api.Logging.DummyLogger:
Leica.Disto.Api.Logging.ILog

Public Member Functions

void | Debug (object message)
void | Info (object message)
void | Info (object message, Exception exception)
void | Warn (object message)
void | Warn (object message, Exception exception)
void | Error (object message)
void | Error (object message, Exception exception)

Member Function Documentation

void Leica.Disto.Api.Logging.DummyLogger.Debug ( object message )

Implements Leica.Disto.Api.Logging.ILog.

void Leica.Disto.Api.Logging.DummyLogger.Error ( object message )

Implements Leica.Disto.Api.Logging.ILog.

void Leica.Disto.Api.Logging.DummyLogger.Error | ( | object | message,
 |  | Exception | exception
 | ) |  |

Implements Leica.Disto.Api.Logging.ILog.

void Leica.Disto.Api.Logging.DummyLogger.Info ( object message )

Implements Leica.Disto.Api.Logging.ILog.

void Leica.Disto.Api.Logging.DummyLogger.Info | ( | object | message,
 |  | Exception | exception
 | ) |  |

Implements Leica.Disto.Api.Logging.ILog.

void Leica.Disto.Api.Logging.DummyLogger.Warn ( object message )

Implements Leica.Disto.Api.Logging.ILog.

void Leica.Disto.Api.Logging.DummyLogger.Warn | ( | object | message,
 |  | Exception | exception
 | ) |  |

Implements Leica.Disto.Api.Logging.ILog.

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.Logging.ILog Interface Reference

  • Logging
  • ILog
Public Member Functions | List of all members
Leica.Disto.Api.Logging.ILog Interface Reference
Inheritance diagram for Leica.Disto.Api.Logging.ILog:
Leica.Disto.Api.Logging.DummyLogger

Public Member Functions

void | Debug (object message)
void | Info (object message)
void | Info (object message, Exception exception)
void | Warn (object message)
void | Warn (object message, Exception exception)
void | Error (object message)
void | Error (object message, Exception exception)

Member Function Documentation

void Leica.Disto.Api.Logging.ILog.Debug ( object message )

Implemented in Leica.Disto.Api.Logging.DummyLogger.

void Leica.Disto.Api.Logging.ILog.Error ( object message )

Implemented in Leica.Disto.Api.Logging.DummyLogger.

void Leica.Disto.Api.Logging.ILog.Error | ( | object | message,
 |  | Exception | exception
 | ) |  |

Implemented in Leica.Disto.Api.Logging.DummyLogger.

void Leica.Disto.Api.Logging.ILog.Info ( object message )

Implemented in Leica.Disto.Api.Logging.DummyLogger.

void Leica.Disto.Api.Logging.ILog.Info | ( | object | message,
 |  | Exception | exception
 | ) |  |

Implemented in Leica.Disto.Api.Logging.DummyLogger.

void Leica.Disto.Api.Logging.ILog.Warn ( object message )

Implemented in Leica.Disto.Api.Logging.DummyLogger.

void Leica.Disto.Api.Logging.ILog.Warn | ( | object | message,
 |  | Exception | exception
 | ) |  |

Implemented in Leica.Disto.Api.Logging.DummyLogger.

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.ExceptionSensorInterface Class Reference

  • SystemInterface
  • ExceptionSensorInterface
Public Member Functions | List of all members
Leica.Disto.Api.SystemInterface.ExceptionSensorInterface Class Reference

exception that is thrown from the sensor interface More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.ExceptionSensorInterface:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Public Member Functions

ExceptionSensorInterface ()
Constructor More...

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

exception that is thrown from the sensor interface

Constructor & Destructor Documentation

Leica.Disto.Api.SystemInterface.ExceptionSensorInterface.ExceptionSensorInterface ( )

Constructor

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer Class Reference

  • SystemInterface
  • ExceptionEmptyImageBuffer
List of all members
Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer Class Reference

Exception thrown when accessing a live image containing no data More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

Exception thrown when accessing a live image containing no data

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType Class Reference

  • SystemInterface
  • ExceptionUnsupportedDeviceType
List of all members
Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType Class Reference

Exception thrown when the connected device is not supported by this API More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

Exception thrown when the connected device is not supported by this API

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand Class Reference

  • SystemInterface
  • ExceptionUnsupportedCommand
List of all members
Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand Class Reference

Exception thrown when the command is not supported by the connected device More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand:
Leica.Disto.Api.AsyncSubsystem.ExceptionError Leica.Disto.Api.AsyncSubsystem.ExceptionCore

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionError
ExceptionError ()
constructs a core error exception More...
ExceptionError (Exception innerException)
constructs a core error exception More...
ExceptionError (SerializationInfo info, StreamingContext context)
constructs a serialized exception More...
- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ExceptionCore ()
default constructor More...
ExceptionCore (Exception innerException)
constructor with native exception More...
ExceptionCore (SerializationInfo info, StreamingContext context)
constructor used for deserialization of exceptions More...
- Properties inherited from Leica.Disto.Api.AsyncSubsystem.ExceptionCore
ILog Logger [get]
Returns the logger associated with the package that has thrown this exception. More...

Detailed Description

Exception thrown when the command is not supported by the connected device

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.SensorData Class Reference

  • SystemInterface
  • SensorData
Public Member Functions | Properties | Events | List of all members
Leica.Disto.Api.SystemInterface.SensorData Class Reference

collection of the Sensor's current, internal data More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.SensorData:
Leica.Disto.Api.HardwareInterface.ISensorData

Public Member Functions

SensorData ()
Constructor More...
IAxisData | AxisData (PositioningAxis p_Axis)
Returns a reference to each axis's data More...
void | Reset ()
Sets all concrete data values to default/undefined More...
void | SetErrors (UInt16 p_ErrorBits)
sets the system error bits More...
UInt16 | GetErrors ()
Returns a a 16bit unsigned int each bit representing an error More...
void | Set (ESystemError p_Error)
Sets the specified error More...
void | Clear (ESystemError p_Error)
Clears the specified error More...
bool | IsSet (ESystemError p_Error)
Returns true when the specified error is set, false otherwise More...
void | Set (ESystemWarning p_Warning)
Sets the specified warning More...
void | SetWarnings (UInt16 p_WarningBits)
sets the system warning bits More...
UInt16 | GetWarnings ()
Returns a a 16bit unsigned int each bit representing a warning More...
void | Clear (ESystemWarning p_Warning)
Clears the specified warning More...
bool | IsSet (ESystemWarning p_Warning)
Returns true when the specified warning is set, false otherwise More...

Properties

ImageZoom | ImageZoom [get, set]
the current zoom level More...
ImageBrightness | ImageBrightness [get, set]
the current brightness for an image More...
ImageMode | ImageMode [get, set]
the current image mode More...
LaserMode | LaserMode [get, set]
the current laser mode More...
LevelMode | LevelMode [get, set]
the current level mode More...
TiltSensorMode | LevelSensitivity [get, set]
the current inclination error compensation sensitivity More...
InclinationPlaneState | InclinationPlaneState [get, set]
the state of the plane that is determined periodically More...
VerticalAxisFace | Face [get]
the current face More...
string | SensorIp [get, set]
IP of the sensor; it depends on the physical connection method (WLAN or RNDIS). More...
SensorBatteryState | BatteryState [get, set]
the battery's state More...
EDeviceType | DeviceType [get, set]
the sensor's device / firmware type More...
int | SerialNumber [get, set]
the sensor's serial number More...
int | EquipmentNumber [get, set]
the sensor's equipment number (ERP) More...
double | OperatingHours [get, set]
the sensor's total accumulated uptime [hours] More...
SensorState | State [get, set]
the current externally visible state of the sensor More...
bool | SecurityEnabled [get]
indicates whether the theft protection is enabled on the sensor, i.e. a PIN must be entered More...
int | PinState [set]
retains the PIN state More...
SensorDirection | SensorDirection [get]
the sensor's current direction More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.ISensorData
SensorState | State [get]
the current State More...
bool | SecurityEnabled [get]
indicates whether the theft protection is enabled on the sensor, i.e. a PIN must be entered More...
ImageZoom | ImageZoom [get]
the current image zoom More...
ImageBrightness | ImageBrightness [get]
the current image brightness More...
ImageMode | ImageMode [get]
the current image mode (live-image on/off) More...
LaserMode | LaserMode [get]
the current laser mode More...
LevelMode | LevelMode [get]
the current inclination error compensation mode More...
TiltSensorMode | LevelSensitivity [get]
the current inclination error compensation sensitivity More...
InclinationPlaneState | InclinationPlaneState [get]
the state of the plane that is determined periodically More...
VerticalAxisFace | Face [get]
the current face More...
string | SensorIp [get]
how the sensor is accessed More...
SensorBatteryState | BatteryState [get]
the battery's state (voltage and charging level) More...
SensorDirection | SensorDirection [get]
the sensor's current direction More...
EDeviceType | DeviceType [get]
the sensor's device / firmware type More...
int | SerialNumber [get]
the sensor's serial number More...
int | EquipmentNumber [get]
the sensor's equipment number (ERP) More...
double | OperatingHours [get]
the total accumulated uptime of the sensor [hours] More...

Events

SensorDataChangedHandler SensorDataChanged
event that is fired when a member changed More...
- Events inherited from Leica.Disto.Api.HardwareInterface.ISensorData
SensorDataChangedHandler SensorDataChanged
event that is fired when a Sensor's mirrored data value has changed More...

Detailed Description

collection of the Sensor's current, internal data

Constructor & Destructor Documentation

Leica.Disto.Api.SystemInterface.SensorData.SensorData ( )

Constructor

Member Function Documentation

IAxisData Leica.Disto.Api.SystemInterface.SensorData.AxisData ( PositioningAxis p_Axis )

Returns a reference to each axis's data

Parameters
p_Axis
Returns

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.Clear ( ESystemError p_Error )

Clears the specified error

Parameters
p_Error the error to clear

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.Clear ( ESystemWarning p_Warning )

Clears the specified warning

Parameters
p_Warning the warning to clear

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

UInt16 Leica.Disto.Api.SystemInterface.SensorData.GetErrors ( )

Returns a a 16bit unsigned int each bit representing an error

Returns

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

UInt16 Leica.Disto.Api.SystemInterface.SensorData.GetWarnings ( )

Returns a a 16bit unsigned int each bit representing a warning

Returns

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

bool Leica.Disto.Api.SystemInterface.SensorData.IsSet ( ESystemError p_Error )

Returns true when the specified error is set, false otherwise

Parameters
p_Error the error to query
Returns

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

bool Leica.Disto.Api.SystemInterface.SensorData.IsSet ( ESystemWarning p_Warning )

Returns true when the specified warning is set, false otherwise

Parameters
p_Warning the warning to query
Returns

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.Reset ( )

Sets all concrete data values to default/undefined

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.Set ( ESystemError p_Error )

Sets the specified error

Parameters
p_Error the error to set

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.Set ( ESystemWarning p_Warning )

Sets the specified warning

Parameters
p_Warning the warning to set

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.SetErrors ( UInt16 p_ErrorBits )

sets the system error bits

Parameters
p_ErrorBits

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

void Leica.Disto.Api.SystemInterface.SensorData.SetWarnings ( UInt16 p_WarningBits )

sets the system warning bits

Parameters
p_WarningBits

Implements Leica.Disto.Api.HardwareInterface.ISensorData.

Property Documentation

SensorBatteryState Leica.Disto.Api.SystemInterface.SensorData.BatteryState
getset

the battery's state

{updated periodically}

EDeviceType Leica.Disto.Api.SystemInterface.SensorData.DeviceType
getset

the sensor's device / firmware type

{read once after connecting to the sensor}

int Leica.Disto.Api.SystemInterface.SensorData.EquipmentNumber
getset

the sensor's equipment number (ERP)

{read once after connecting to the sensor}

VerticalAxisFace Leica.Disto.Api.SystemInterface.SensorData.Face
get

the current face

ImageBrightness Leica.Disto.Api.SystemInterface.SensorData.ImageBrightness
getset

the current brightness for an image

ImageMode Leica.Disto.Api.SystemInterface.SensorData.ImageMode
getset

the current image mode

ImageZoom Leica.Disto.Api.SystemInterface.SensorData.ImageZoom
getset

the current zoom level

InclinationPlaneState Leica.Disto.Api.SystemInterface.SensorData.InclinationPlaneState
getset

the state of the plane that is determined periodically

LaserMode Leica.Disto.Api.SystemInterface.SensorData.LaserMode
getset

the current laser mode

LevelMode Leica.Disto.Api.SystemInterface.SensorData.LevelMode
getset

the current level mode

TiltSensorMode Leica.Disto.Api.SystemInterface.SensorData.LevelSensitivity
getset

the current inclination error compensation sensitivity

double Leica.Disto.Api.SystemInterface.SensorData.OperatingHours
getset

the sensor's total accumulated uptime [hours]

{updated periodically}

int Leica.Disto.Api.SystemInterface.SensorData.PinState
set

retains the PIN state

bool Leica.Disto.Api.SystemInterface.SensorData.SecurityEnabled
get

indicates whether the theft protection is enabled on the sensor, i.e. a PIN must be entered

SensorDirection Leica.Disto.Api.SystemInterface.SensorData.SensorDirection
get

the sensor's current direction

string Leica.Disto.Api.SystemInterface.SensorData.SensorIp
getset

IP of the sensor; it depends on the physical connection method (WLAN or RNDIS).

int Leica.Disto.Api.SystemInterface.SensorData.SerialNumber
getset

the sensor's serial number

{read once after connecting to the sensor}

SensorState Leica.Disto.Api.SystemInterface.SensorData.State
getset

the current externally visible state of the sensor

Event Documentation

SensorDataChangedHandler Leica.Disto.Api.SystemInterface.SensorData.SensorDataChanged

event that is fired when a member changed

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.AxisData Class Reference

  • SystemInterface
  • AxisData
Public Member Functions | Properties | List of all members
Leica.Disto.Api.SystemInterface.AxisData Class Reference

Represents the iternal data of eitherthe Hz or V axis More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.AxisData:
Leica.Disto.Api.HardwareInterface.IAxisData

Public Member Functions

AxisData (SensorData p_Owner, PositioningAxis p_Axis, double p_Angle, PositioningDirection p_Direction, int p_Velocity)
Constructor More...

Properties

PositioningAxis | Axis [get, set]
Identifier for this axis More...
double | Angle [get, set]
The axis' current angle More...
double | NiAngle [get, set]
The axis' current angle with all corrections but the inclination More...
PositioningDirection | Direction [get, set]
The axis' currently set direction More...
int | Velocity [get, set]
The axis' currently set velocity More...
AxisState | State [get, set]
The axis' current state More...
- Properties inherited from Leica.Disto.Api.HardwareInterface.IAxisData
PositioningAxis | Axis [get]
this axis's identifier More...
double | Angle [get]
the current angle of this axis, containing all corrections More...
double | NiAngle [get]
the current angle of this axis, not corrected by the inclination (but all other corrections) More...
PositioningDirection | Direction [get]
the current direction of this axis More...
int | Velocity [get]
the current velocity of this axis More...
AxisState | State [get]
the current state of this axis More...

Detailed Description

Represents the iternal data of eitherthe Hz or V axis

Constructor & Destructor Documentation

Leica.Disto.Api.SystemInterface.AxisData.AxisData | ( | SensorData | p_Owner,
 |  | PositioningAxis | p_Axis,
 |  | double | p_Angle,
 |  | PositioningDirection | p_Direction,
 |  | int | p_Velocity
 | ) |  |

Constructor

Property Documentation

double Leica.Disto.Api.SystemInterface.AxisData.Angle
getset

The axis' current angle

PositioningAxis Leica.Disto.Api.SystemInterface.AxisData.Axis
getset

Identifier for this axis

PositioningDirection Leica.Disto.Api.SystemInterface.AxisData.Direction
getset

The axis' currently set direction

double Leica.Disto.Api.SystemInterface.AxisData.NiAngle
getset

The axis' current angle with all corrections but the inclination

AxisState Leica.Disto.Api.SystemInterface.AxisData.State
getset

The axis' current state

int Leica.Disto.Api.SystemInterface.AxisData.Velocity
getset

The axis' currently set velocity

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Api.SystemInterface.SensorInterface Class Reference

  • SystemInterface
  • SensorInterface
Public Member Functions | Properties | Events | List of all members
Leica.Disto.Api.SystemInterface.SensorInterface Class Reference

API for the Leica 3D Disto sensor. More...

Inheritance diagram for Leica.Disto.Api.SystemInterface.SensorInterface:
Leica.Disto.Api.AsyncSubsystem.Subsystem Leica.Disto.Api.HardwareInterface.ISensorEvents

Public Member Functions

SensorInterface ()
Constructor More...
override void | InitInstance ()
Initialises the instance so that it can be started with its Subsystem.Startup method and connect to the sensor with Connect. More...
override void | ExitInstance ()
This method should be called on exit. See InitInstance. More...
SyncObject< Response > | Connect (string sensorIp)
Establishes a TCP connection to the sensor. The sensor interface instance must be initialized already. More...
SyncObject< Response > Disconnect ()
Closes the TCP connection to the Sensor. More...
SyncObject< Response > Ping ()
Pings the sensor to check if the connection is still alive. More...
SyncObject< Response > | EnterPin (int pin)
Enter the 4-digit PIN to activate the sensor, i.e. change its PIN status from PIN required to active. More...
SyncObject< Response > | SetPin (int pin)
Changes the 4-digit PIN. More...
SyncObject< Response > | EnterPuk (int puk)
Enter the 8-digit PUK code to unlock the sensor if the PIN has been entered incorrectly multiple times. More...
SyncObject< Response > GetFace ()
Retrieves the sensor's vertical axis' logical in direction it currently has. More...
SyncObject< Response > GetWlanChannel ()
Returns the WLAN channel currently used as an int. More...
SyncObject< Response > | SetWlanChannel (int channel, bool appendChannelToEssid)
Sets the WLAN channel to use. More...
SyncObject< Response > GetWlanFreq ()
Returns the WLAN frequency as string, for example "2.442 GHz" More...
SyncObject< Response > GetWlanEssid ()
Returns the current WLAN ESSID as string, for example "3DD_00000035_Chn007" More...
SyncObject< Response > GetSerialNumber ()
Returns the sensors serial number as int in [0, 999 999 999] More...
SyncObject< Response > GetSoftwareVersion ()
Returns the software version of the sensor as string. More...
SyncObject< Response > GetLedSyserror ()
System errors are signalled by an illuminated red LED and a disabled green LED. More...
SyncObject< Response > GetLedWarning ()
Warnings are signalled by a flashing LED (··· ··· ··· etc.) and a disabled green LED. More...
SyncObject< Response > GetTiltSensitivity ()
Returns the sensitivity mode of the tilt sensor as TiltSensorMode More...
SyncObject< Response > | SetTiltSensitivity (TiltSensorMode mode)
Sets the sensitivity mode on the tilt sensor. More...
SyncObject< Response > | Snapshot (ImageResolution resolution)
Triggers a single snapshot image from the viewfinders camera with the specified resolution. More...
SyncObject< Response > MeasureAngle ()
Triggers a single measurement of the angles. More...
SyncObject< Response > MeasurePolar ()
Triggers a single measurement of the polar coordinates. More...
SyncObject< Response > | SetLevelMode (LevelMode levelMode)
Sets the sensors level mode. More...
SyncObject< Response > | SetLaserMode (LaserMode laserMode)
Sets the laser mode (on/off/blinking). More...
SyncObject< Response > EnableLiveImage ()
Live images are provided through the ILiveImage.LiveImageChanged event in LiveImage. More...
SyncObject< Response > DisableLiveImage ()
Stops providing live images. More...
SyncObject< Response > | SetPositioningVelocity (PositioningAxis axis, int velocity)
Sets an axis velocity for a subsequent motion command. More...
SyncObject< Response > | SetPositioningDirection (PositioningAxis axis, PositioningDirection direction)
Sets an axis direction for a subsequent motion command. More...
SyncObject< Response > | PositionAccelerate (PositioningAxis axis, int velocity, PositioningDirection direction)
Accelerates the specified axis with the specified velocity and direction. More...
SyncObject< Response > | StartPositioning (PositioningAxis axis)
Accelerates the specified axis to the predefined velocity and in the predefined direction. More...
SyncObject< Response > | StopPositioning (PositioningAxis axis)
Stops moving the specified axis. Use this call when the axis has been triggered with StartPositioning or PositionAccelerate. More...
SyncObject< Response > | GetMotorStatus (PositioningAxis axis)
Queries the status of an axis motor. More...
SyncObject< Response > | PositionAbsolute (PositioningAxis axis, double angle)
Moves the specified axis to the desired inclination-corrected absolute angle. More...
SyncObject< Response > | PositionAbsoluteNi (PositioningAxis axis, double angleNi)
Moves the specified axis/axes to the desired absolute angle (not inclination-corrected). More...
SyncObject< Response > | PositionAbsolute (double horizontal, double vertical)
Moves the Hz and V axes to the desired inclination-corrected absolute angles in [rad]. More...
SyncObject< Response > | PositionAbsoluteNi (double horizontalNi, double verticalNi)
Moves the Hz and V axes to the desired absolute angles in rad. More...
SyncObject< Response > | PositionRelative (PositioningAxis axis, double angle)
Moves the axis by the desired inclination-corrected relative angle in [rad]. More...
SyncObject< Response > | PositionRelativeNi (PositioningAxis axis, double angleNi)
Moves the axis/axes by the desired relative angle in rad.. More...
SyncObject< Response > | PositionRelative (double horizontal, double vertical)
Moves the axes by the desired inclination-corrected relative angles in [rad]. More...
SyncObject< Response > | PositionRelativeNi (double horizontalNi, double verticalNi)
Moves the axes to the desired relative angles in rad More...
SyncObject< Response > | SetImageZoom (ImageZoom zoomFactor)
Sets the image zoom factor. More...
SyncObject< Response > | SetImageBrightness (ImageBrightness p_ImageBrightness)
Sets the image brightness factor of the viewfinders camera. More...
SyncObject< Response > MeasureIncline ()
Returns the inclination plane values as SensorIncline. More...
SyncObject< Response > PowerOff ()
Shutdown and power off the sensor. More...
SyncObject< Response > GetTemperatures ()
Returns the status of each temperature sensor in a SensorTemperatures object. More...
SyncObject< Response > GetBatteryState ()
Returns the status of the sensors battery as SensorBatteryState object. More...
- Public Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.Subsystem
virtual string | GetCurrentState ()
Returns the current state of the Subsystem in text. More...
virtual string | GetSubsystemID ()
Returns the ID of the Subsystem More...
virtual SyncObject | Startup ()
Brings the subsystem into 'ConfigProcessModelSetup' and processes all model dependent and fixed parameters More...
virtual SyncObject | Shutdown ()
Brings the subsystem down to the entry state 'created' More...

Properties

ISensorData | SensorData [get]
The sensors data attributes that mirror the state of the actual hardware. See ISensorData.SensorDataChanged for monitoring sensor data. More...
ILiveImage | LiveImage [get]
The sensors live image (read only), updated periodically when live image mode is enabled (see EnableLiveImage). See ILiveImage.LiveImageChanged for monitoring live images. More...
Version | ApiVersion [get]
Gets the current api assembly version More...

Events

EventReceivedHandler | BatteryStateChanged
Event when the battery's state changed, i.e. when the power cord is (un)plugged or when the battery goes empty More...
EventReceivedHandler | RemoteControlKeyPressed
Event when a key of the remote control is pressed More...
EventReceivedHandler | MeasurePolarEvent
Event when a MeasurePolarEvent (with or without image) Event is received More...
EventReceivedHandler | InclinationPlaneChanged
Event when the inclination plane changed. The inclination plane changes when the sensor is moved or tilted. More...
EventReceivedHandler | SystemMessageReceived
Event when a system message (warning/error) has been received from the sensor More...
- Events inherited from Leica.Disto.Api.HardwareInterface.ISensorEvents
EventReceivedHandler BatteryStateChanged
event when the battery's state changed, i.e. when the power cord is plugged/unlugged or when the battery goes empty More...
EventReceivedHandler RemoteControlKeyPressed
event when the key of the remote control is pressed More...
EventReceivedHandler InclinationPlaneChanged
event when the inclination plane changed More...
EventReceivedHandler SystemMessageReceived
event when a system message (warnign/error) has been received from the sensor More...
EventReceivedHandler MeasurePolarEvent
event when a MeasurePolarWithImage Event has been received from the sensor More...

Additional Inherited Members

- Protected Member Functions inherited from Leica.Disto.Api.AsyncSubsystem.Subsystem
Subsystem (string subsystemID, string instanceInfo)
construction More...

Detailed Description

API for the Leica 3D Disto sensor.

Values returned by functions can be found in the SyncObject{T}.Result object. They may be anything from ordinary objects to string and int values. The return sections are abbreviated and only mention the type of Response.Result.

Typically, SyncObject{T}.Synchronize() is used to wait for completion of a task.

See Also
SyncObject{T}

Constructor & Destructor Documentation

Leica.Disto.Api.SystemInterface.SensorInterface.SensorInterface ( )

Constructor

Member Function Documentation

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.Connect ( string sensorIp )

Establishes a TCP connection to the sensor. The sensor interface instance must be initialized already.

Connection on network level (IPv4) must already be present, either via WLAN or via Ethernet (USB/RNDIS). The corresponding IP addresses of the interfaces are stored in SystemSettings.IpAddressWlan and SystemSettings.IpAddressRndis.

Returns
The returned object is signalled when the connection can be established or when it failed.
See Also
Disconnect, InitInstance
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.DisableLiveImage ( )

Stops providing live images.

This method does not need to be called when shutting down the SensorInterface instance.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.Disconnect ( )

Closes the TCP connection to the Sensor.

Returns
The returned object is signalled when the connection is closed or on an exception.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.EnableLiveImage ( )

Live images are provided through the ILiveImage.LiveImageChanged event in LiveImage.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.EnterPin ( int pin )

Enter the 4-digit PIN to activate the sensor, i.e. change its PIN status from PIN required to active.

If the PIN code is entered incorrectly 3 times, then the current PIN code becomes invalid and the device changes into the PIN status PUK required. If a valid PUK code is entered (max. 2 tries), the PIN code is set to 0000 and the device is unlocked.

Parameters
pin PIN in [0,9999]. When setting a new PIN, 0000 disables the PIN, any number != 0 enables it and sets it to this value.

SensorState.PinRequired

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.EnterPuk ( int puk )

Enter the 8-digit PUK code to unlock the sensor if the PIN has been entered incorrectly multiple times.

The PUK is a number in [10000000,99999999]. When entered correctly, the PIN will be reset to 0000 (disabled). If the PUK is entered incorrectly twice, the sensor changes to PIN status device locked and has to be restarted in order to enter the correct PUK.

See Also
EnterPin
Parameters
puk The 8-digit PUK
Returns
The returned object is signalled when the PUK action completed.
override void Leica.Disto.Api.SystemInterface.SensorInterface.ExitInstance ( )
virtual

This method should be called on exit. See InitInstance.

This instances Subsystem.Shutdown method should be called before exiting.

Reimplemented from Leica.Disto.Api.AsyncSubsystem.Subsystem.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetBatteryState ( )

Returns the status of the sensors battery as SensorBatteryState object.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetFace ( )

Retrieves the sensor's vertical axis' logical in direction it currently has.

If the 3D Disto device rotates by 180 degrees, the sensor can still aim at the same point, but it is rotated headfirst.

Returns
The returned object contains a VerticalAxisFace result object.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetLedSyserror ( )

System errors are signalled by an illuminated red LED and a disabled green LED.

The status is returned as uint as described in the following table.

Hex (Dec) | System Error
0x0001 (1) | UART (to EDM) defective
0x0002 (2) | Tilt sensor defective
0x0004 (4) | EDM (laser safety) single fault (laser output too high)
0x0008 (8) | CAM (camera subsystem not started)
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetLedWarning ( )

Warnings are signalled by a flashing LED (··· ··· ··· etc.) and a disabled green LED.

The status is returned as uint as described in the following table.

Hex (Dec) | Warning
0x0001 (1) | Device temperature not within recommended range (< 10 °C or > 50 °C)
0x0002 (2) | Tilt sensor out of range; device tilt is too great
0x0004 (4) | Tilt sensor is performing an initialisation
0x0008 (8) | Device is locked (needs to be restarted as most commands are locked)
0x0010 (16) | PIN entry required
0x0020 (32) | PUK entry required
0x0040 (64) | No TCP/IP sockets could be opened for the event channel, thus no events are available
0x0080 (128) | Tilt sensor is performing a calibration

ESystemError

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetMotorStatus ( PositioningAxis axis )

Queries the status of an axis motor.

Returns
An List{T} containing AxisState enums. If both axes are returned, the horizontal motor status is the first entry in the list.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetSerialNumber ( )

Returns the sensors serial number as int in [0, 999 999 999]

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetSoftwareVersion ( )

Returns the software version of the sensor as string.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetTemperatures ( )

Returns the status of each temperature sensor in a SensorTemperatures object.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetTiltSensitivity ( )

Returns the sensitivity mode of the tilt sensor as TiltSensorMode

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetWlanChannel ( )

Returns the WLAN channel currently used as an int.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetWlanEssid ( )

Returns the current WLAN ESSID as string, for example "3DD_00000035_Chn007"

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.GetWlanFreq ( )

Returns the WLAN frequency as string, for example "2.442 GHz"

override void Leica.Disto.Api.SystemInterface.SensorInterface.InitInstance ( )
virtual

Initialises the instance so that it can be started with its Subsystem.Startup method and connect to the sensor with Connect.

This method has to be called after constructing the instance. On exit, ExitInstance should be called.

Reimplemented from Leica.Disto.Api.AsyncSubsystem.Subsystem.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.MeasureAngle ( )

Triggers a single measurement of the angles.

The measurement returns Hz and V containing all corrections, and NiHz and NiV containing all corrections but the inclination (which is calculated when the sensor is leveling). If the level mode is set to disabled, Hz and V will too be returned without inclination correction.

Measuring usually takes around 50 ms.

Returns
Returns a SensorDirection or an error-code from the sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.MeasureIncline ( )

Returns the inclination plane values as SensorIncline.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.MeasurePolar ( )

Triggers a single measurement of the polar coordinates.

The measurement returns Hz and V containing all corrections, NiHz and NiV without inclination correction, and the distance. If the level mode is set to disabled, Hz and V will too be returned without inclination correction.

Measuring usually takes around 300 to 3000 ms.

Returns
Returns a SensorPoint or an error-code from the sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.Ping ( )

Pings the sensor to check if the connection is still alive.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionAbsolute | ( | PositioningAxis | axis,
 |  | double | angle
 | ) |  |

Moves the specified axis to the desired inclination-corrected absolute angle.

Parameters
axis | The axis to move to the specified angle.
angle | The desired absolute angle [rad]
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionAbsolute | ( | double | horizontal,
 |  | double | vertical
 | ) |  |

Moves the Hz and V axes to the desired inclination-corrected absolute angles in [rad].

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionAbsoluteNi | ( | PositioningAxis | axis,
 |  | double | angleNi
 | ) |  |

Moves the specified axis/axes to the desired absolute angle (not inclination-corrected).

Note that the viewfinder image is not inclination-corrected.

Parameters
axis | The axis to move to the specified angle.
angleNi | The desired absolute angle [rad] (not corrected by the inclination).
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionAbsoluteNi | ( | double | horizontalNi,
 |  | double | verticalNi
 | ) |  |

Moves the Hz and V axes to the desired absolute angles in rad.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionAccelerate | ( | PositioningAxis | axis,
 |  | int | velocity,
 |  | PositioningDirection | direction
 | ) |  |

Accelerates the specified axis with the specified velocity and direction.

This command is in most cases faster than setting direction and velocity separately as values are only updated if required.

Parameters
axis | The axis to accelerate
velocity | The desired end velocity, in [0,100]
direction | The desired direction
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionRelative | ( | PositioningAxis | axis,
 |  | double | angle
 | ) |  |

Moves the axis by the desired inclination-corrected relative angle in [rad].

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionRelative | ( | double | horizontal,
 |  | double | vertical
 | ) |  |

Moves the axes by the desired inclination-corrected relative angles in [rad].

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionRelativeNi | ( | PositioningAxis | axis,
 |  | double | angleNi
 | ) |  |

Moves the axis/axes by the desired relative angle in rad..

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PositionRelativeNi | ( | double | horizontalNi,
 |  | double | verticalNi
 | ) |  |

Moves the axes to the desired relative angles in rad

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.PowerOff ( )

Shutdown and power off the sensor.

Note that you need to power on the sensor manually and reconnect after this command. The sensor is powered off automatically after 15 minutes without data traffic.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetImageBrightness ( ImageBrightness p_ImageBrightness )

Sets the image brightness factor of the viewfinders camera.

The value is used to adjust the automatic exposure of the camera. Automatic exposure takes into account the image region around the center of the image.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetImageZoom ( ImageZoom zoomFactor )

Sets the image zoom factor.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetLaserMode ( LaserMode laserMode )

Sets the laser mode (on/off/blinking).

The laser does not need to be enabled in order to measure; this happens automatically.

Returns
The returned object is signalled when the mode has been applied to the Sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetLevelMode ( LevelMode levelMode )

Sets the sensors level mode.

Returns
The returned object is signalled when the mode has been applied to the Sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetPin ( int pin )

Changes the 4-digit PIN.

The device must either be in PIN status active (i.e. a correct PIN has been entered), or in disabled, meaning that no pin has been set.

Parameters
pin PIN in [0,9999]. 0000 disables the PIN, any number != 0 enables it and sets it to this value.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetPositioningDirection | ( | PositioningAxis | axis,
 |  | PositioningDirection | direction
 | ) |  |

Sets an axis direction for a subsequent motion command.

Returns
The returned object is signalled when the direction has been applied to the Sensor. The response may contain an error-code from the sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetPositioningVelocity | ( | PositioningAxis | axis,
 |  | int | velocity
 | ) |  |

Sets an axis velocity for a subsequent motion command.

Parameters
axis | The axis whose velocity should be changed
velocity | The desired velocity, in [0,100]
Returns
The returned object is signalled when the velocity has been applied to the Sensor. The response may contain an error-code from the sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetTiltSensitivity ( TiltSensorMode mode )

Sets the sensitivity mode on the tilt sensor.

SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.SetWlanChannel | ( | int | channel,
 |  | bool | appendChannelToEssid
 | ) |  |

Sets the WLAN channel to use.

The ESSID is set to 3DD_[0-9]{8}(_Chn[0-9]{3})?, as regular expression, or to

  • 3DD_<sn>_Chn<channel> if appendChannelToEssid is set to true
  • 3DD_<sn> otherwise

where <sn> is the sensors serial number and <channel> is the WLAN channel number with zero-padding to length 3. Example: 3DD_00000035_Chn007"

Parameters
channel | Channel number, between 1 and 11
appendChannelToEssid | See description.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.Snapshot ( ImageResolution resolution )

Triggers a single snapshot image from the viewfinders camera with the specified resolution.

Note that the image is not inclination corrected.

Returns
The result contains a SnapshotImage object or an error code from the sensor.
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.StartPositioning ( PositioningAxis axis )

Accelerates the specified axis to the predefined velocity and in the predefined direction.

See Also
SetPositioningVelocity, SetPositioningDirection
SyncObject<Response> Leica.Disto.Api.SystemInterface.SensorInterface.StopPositioning ( PositioningAxis axis )

Stops moving the specified axis. Use this call when the axis has been triggered with StartPositioning or PositionAccelerate.

Property Documentation

Version Leica.Disto.Api.SystemInterface.SensorInterface.ApiVersion
get

Gets the current api assembly version

ILiveImage Leica.Disto.Api.SystemInterface.SensorInterface.LiveImage
get

The sensors live image (read only), updated periodically when live image mode is enabled (see EnableLiveImage). See ILiveImage.LiveImageChanged for monitoring live images.

Note that the viewfinder image is not inclincation corrected. For angles, the according functions without inclination correction should be used in this regard.

There is no guarantee on the reception interval. Images are transferred via UDP stream, and other sensor actions have priority.

ISensorData Leica.Disto.Api.SystemInterface.SensorInterface.SensorData
get

The sensors data attributes that mirror the state of the actual hardware. See ISensorData.SensorDataChanged for monitoring sensor data.

Event Documentation

EventReceivedHandler Leica.Disto.Api.SystemInterface.SensorInterface.BatteryStateChanged

Event when the battery's state changed, i.e. when the power cord is (un)plugged or when the battery goes empty

EventReceivedHandler Leica.Disto.Api.SystemInterface.SensorInterface.InclinationPlaneChanged

Event when the inclination plane changed. The inclination plane changes when the sensor is moved or tilted.

EventReceivedHandler Leica.Disto.Api.SystemInterface.SensorInterface.MeasurePolarEvent

Event when a MeasurePolarEvent (with or without image) Event is received

EventReceivedHandler Leica.Disto.Api.SystemInterface.SensorInterface.RemoteControlKeyPressed

Event when a key of the remote control is pressed

EventReceivedHandler Leica.Disto.Api.SystemInterface.SensorInterface.SystemMessageReceived

Event when a system message (warning/error) has been received from the sensor

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.Windows.DistoOnWlanSearcher Class Reference

  • Networking
  • Windows
  • DistoOnWlanSearcher
Public Member Functions | List of all members
Leica.Disto.Networking.Windows.DistoOnWlanSearcher Class Reference

Public Member Functions

void | StartSearch ()
void | Stop ()
bool | Finished ()
List< IpDeviceDescriptor > | GetIpDeviceDescriptorList ()

Member Function Documentation

bool Leica.Disto.Networking.Windows.DistoOnWlanSearcher.Finished ( )
List<IpDeviceDescriptor> Leica.Disto.Networking.Windows.DistoOnWlanSearcher.GetIpDeviceDescriptorList ( )
void Leica.Disto.Networking.Windows.DistoOnWlanSearcher.StartSearch ( )
void Leica.Disto.Networking.Windows.DistoOnWlanSearcher.Stop ( )
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.Windows.UDPer Class Reference

  • Networking
  • Windows
  • UDPer
Public Member Functions | List of all members
Leica.Disto.Networking.Windows.UDPer Class Reference

Public Member Functions

void | Start ()
void | Stop ()
bool | Finished ()
void | Send (string message)

Member Function Documentation

bool Leica.Disto.Networking.Windows.UDPer.Finished ( )
void Leica.Disto.Networking.Windows.UDPer.Send ( string message )
void Leica.Disto.Networking.Windows.UDPer.Start ( )
void Leica.Disto.Networking.Windows.UDPer.Stop ( )
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.PlatformWindowsNet Class Reference

  • Networking
  • PlatformWindowsNet
Classes | Public Member Functions | List of all members
Leica.Disto.Networking.PlatformWindowsNet Class Reference

Class for network configuration on Windows platforms (XP, Vista, Win7, Win8) More...

Classes

class | WlanInterfaceWithNetwork
Contains information about a WLAN network and the adapter where its available More...
class | WlanNetwork
Contains information about a WLAN network. More...

Public Member Functions

PlatformWindowsNet ()
Contructor More...
bool | CheckRndisIp (string sensorRndisIp)
Check that the host RNDIS IP is a valid IPv4 address and that it matches the subnet of the sensor’s RNDIS IP address. If it does not match, the IP address is adjusted accordingly. More...
virtual bool | EnableWlan (string adapterName, string essid, string sensorWlanIp)
Enables the hosts WLAN interface. More...
virtual bool | EnableWlan (string adapterName, string essid, string sensorWlanIp, bool useExistingProfile)
Enables the hosts WLAN interface. More...
virtual bool | EnableWlan (string adapterName, string essid, string sensorWlanIp, string key)
Enables the hosts WLAN interface. More...
virtual bool | EnableWlan (string adapterName, string essid, string sensorWlanIp, string key, bool useExistingProfile)
Enables the hosts WLAN interface. More...
bool | DisableWlan ()
Disable the hosts WLAN interface and restores the previous configuration. More...
List< string > | GetWlanInterfaces ()
Returns a list of WLAN interfaces available on the machine. More...
List< WlanInterfaceWithNetwork > | GetDistoWlanNetworks ()
Returns a List of DISTO WLAN Networks available on the machine More...
bool | ConnectToDistoWlanNetwork (WlanInterfaceWithNetwork p_Net, bool p_UseExistingProfile)
Connect to a Disto Wlan-Network. If no key is set in the parameter, the usage of existing Wlan profiles is tried. More...
IEnumerable< WlanNetwork > | ScanWlanNetworks (string wlanInterfaceName)
Returns a list of WLAN networks available on the given interface. More...
List< IpDeviceDescriptor > | ScanForDistoDevices ()
Returns a list of Devices which can be accessed More...

Detailed Description

Class for network configuration on Windows platforms (XP, Vista, Win7, Win8)

Constructor & Destructor Documentation

Leica.Disto.Networking.PlatformWindowsNet.PlatformWindowsNet ( )

Contructor

Member Function Documentation

bool Leica.Disto.Networking.PlatformWindowsNet.CheckRndisIp ( string sensorRndisIp )

Check that the host RNDIS IP is a valid IPv4 address and that it matches the subnet of the sensor’s RNDIS IP address. If it does not match, the IP address is adjusted accordingly.

Changing the IP address requires admin rights. Without the required permissions, an UnauthorizedAccessException will be thrown.

Parameters
sensorRndisIp Sensor’s IP address of the RNDIS adapter
Exceptions
UnauthorizedAccessException
bool Leica.Disto.Networking.PlatformWindowsNet.ConnectToDistoWlanNetwork | ( | WlanInterfaceWithNetwork | p_Net,
 |  | bool | p_UseExistingProfile
 | ) |  |

Connect to a Disto Wlan-Network. If no key is set in the parameter, the usage of existing Wlan profiles is tried.

Parameters
p_Net | the wlan to connect
p_UseExistingProfile | connect using an existing wlan profile (if available)
Returns
bool Leica.Disto.Networking.PlatformWindowsNet.DisableWlan ( )

Disable the hosts WLAN interface and restores the previous configuration.

Returns
True when successful, false otherwise.
virtual bool Leica.Disto.Networking.PlatformWindowsNet.EnableWlan | ( | string | adapterName,
 |  | string | essid,
 |  | string | sensorWlanIp
 | ) |  |
virtual

Enables the hosts WLAN interface.

Parameters
adapterName | Name of the wlan adapter to be used
essid | The WLAN's ESSID.
sensorWlanIp | The sensor's WLAN IP Address
Returns
True when enabling the WLAN succeeded and the sensor could be pinged, false otherwise.
virtual bool Leica.Disto.Networking.PlatformWindowsNet.EnableWlan | ( | string | adapterName,
 |  | string | essid,
 |  | string | sensorWlanIp,
 |  | bool | useExistingProfile
 | ) |  |
virtual

Enables the hosts WLAN interface.

Parameters
adapterName | Name of the wlan adapter to be used
essid | The WLAN's ESSID.
sensorWlanIp | The sensor's WLAN IP Address
useExistingProfile | Use any existing wlan profile for this Ssid
Returns
True when enabling the WLAN succeeded and the sensor could be pinged, false otherwise.
virtual bool Leica.Disto.Networking.PlatformWindowsNet.EnableWlan | ( | string | adapterName,
 |  | string | essid,
 |  | string | sensorWlanIp,
 |  | string | key
 | ) |  |
virtual

Enables the hosts WLAN interface.

Parameters
adapterName | Name of the wlan adapter to be used
essid | The WLAN's ESSID.
sensorWlanIp | The sensor's WLAN IP Address
key | The Key to the Wlan
Returns
True when enabling the WLAN succeeded and the sensor could be pinged, false otherwise.
virtual bool Leica.Disto.Networking.PlatformWindowsNet.EnableWlan | ( | string | adapterName,
 |  | string | essid,
 |  | string | sensorWlanIp,
 |  | string | key,
 |  | bool | useExistingProfile
 | ) |  |
virtual

Enables the hosts WLAN interface.

Parameters
adapterName | Name of the wlan adapter to be used
essid | The WLAN's ESSID.
sensorWlanIp | The sensor's WLAN IP Address
key | The Key to the Wlan
useExistingProfile | Use any existing wlan profile for this Ssid
Returns
True when enabling the WLAN succeeded and the sensor could be pinged, false otherwise.
List<WlanInterfaceWithNetwork> Leica.Disto.Networking.PlatformWindowsNet.GetDistoWlanNetworks ( )

Returns a List of DISTO WLAN Networks available on the machine

Returns
List<string> Leica.Disto.Networking.PlatformWindowsNet.GetWlanInterfaces ( )

Returns a list of WLAN interfaces available on the machine.

List<IpDeviceDescriptor> Leica.Disto.Networking.PlatformWindowsNet.ScanForDistoDevices ( )

Returns a list of Devices which can be accessed

A scan cam take a few seconds

Returns
IEnumerable<WlanNetwork> Leica.Disto.Networking.PlatformWindowsNet.ScanWlanNetworks ( string wlanInterfaceName )

Returns a list of WLAN networks available on the given interface.

A scan takes at most 4 seconds.

Parameters
wlanInterfaceName WLAN interface, or null for a default interface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork Class Reference

  • Networking
  • PlatformWindowsNet
  • WlanInterfaceWithNetwork
Public Member Functions | Properties | List of all members
Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork Class Reference

Contains information about a WLAN network and the adapter where its available More...

Public Member Functions

WlanInterfaceWithNetwork (string ssid, uint linkQuality, string adapter)
Constructor. More...
WlanInterfaceWithNetwork (WlanNetwork network, string p_Adapter)
Constructor. More...

Properties

WlanNetwork | Network [get, set]
Contains information about a WLAN network. More...
string | Adapter [get, set]
Contains information about a WLAN interface. More...

Detailed Description

Contains information about a WLAN network and the adapter where its available

Constructor & Destructor Documentation

Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork.WlanInterfaceWithNetwork | ( | string | ssid,
 |  | uint | linkQuality,
 |  | string | adapter
 | ) |  |

Constructor.

Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork.WlanInterfaceWithNetwork | ( | WlanNetwork | network,
 |  | string | p_Adapter
 | ) |  |

Constructor.

Property Documentation

string Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork.Adapter
getset

Contains information about a WLAN interface.

WlanNetwork Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork.Network
getset

Contains information about a WLAN network.

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork Class Reference

  • Networking
  • PlatformWindowsNet
  • WlanNetwork
Public Member Functions | Properties | List of all members
Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork Class Reference

Contains information about a WLAN network. More...

Public Member Functions

WlanNetwork (string p_Ssid, uint p_LinkQuality)
Constructor. More...
WlanNetwork (string p_Ssid, uint p_LinkQuality, bool p_Secured, string p_Key)
Constructor. More...

Properties

string | Ssid [get, set]
Network name (SSID) More...
bool | Secured [get, set]
Secured (means need Key) More...
string | Key [get, set]
Network Key More...
uint | LinkQuality [get, set]
Link quality in [0,100] More...

Detailed Description

Contains information about a WLAN network.

Constructor & Destructor Documentation

Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork.WlanNetwork | ( | string | p_Ssid,
 |  | uint | p_LinkQuality
 | ) |  |

Constructor.

Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork.WlanNetwork | ( | string | p_Ssid,
 |  | uint | p_LinkQuality,
 |  | bool | p_Secured,
 |  | string | p_Key
 | ) |  |

Constructor.

Property Documentation

string Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork.Key
getset

Network Key

uint Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork.LinkQuality
getset

Link quality in [0,100]

bool Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork.Secured
getset

Secured (means need Key)

string Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork.Ssid
getset

Network name (SSID)

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.IpDeviceDescriptor Class Reference

  • Networking
  • IpDeviceDescriptor
Public Member Functions | Properties | List of all members
Leica.Disto.Networking.IpDeviceDescriptor Class Reference

Description of a connected Device More...

Public Member Functions

IpDeviceDescriptor (string p_IPAdress, string p_SerialNumber, string p_SoftwareName, string p_SoftwareVersion, string p_SoftwareVersionWlan)
Constructor for IpDeviceDescriptor. Sets all attributes. More...

Properties

string | IpAdress [get]
Ip Adress of the device More...
string | SerialNumber [get]
Serial Number of the device More...
string | SoftwareName [get]
Software Name of the device More...
string | SoftwareVersion [get]
Software Version of the device More...
string | SoftwareVersionWlan [get]
WLAN-Software Version of the device More...

Detailed Description

Description of a connected Device

Constructor & Destructor Documentation

Leica.Disto.Networking.IpDeviceDescriptor.IpDeviceDescriptor | ( | string | p_IPAdress,
 |  | string | p_SerialNumber,
 |  | string | p_SoftwareName,
 |  | string | p_SoftwareVersion,
 |  | string | p_SoftwareVersionWlan
 | ) |  |

Constructor for IpDeviceDescriptor. Sets all attributes.

Parameters
p_IPAdress
p_SerialNumber
p_SoftwareName
p_SoftwareVersion
p_SoftwareVersionWlan

Property Documentation

string Leica.Disto.Networking.IpDeviceDescriptor.IpAdress
get

Ip Adress of the device

string Leica.Disto.Networking.IpDeviceDescriptor.SerialNumber
get

Serial Number of the device

string Leica.Disto.Networking.IpDeviceDescriptor.SoftwareName
get

Software Name of the device

string Leica.Disto.Networking.IpDeviceDescriptor.SoftwareVersion
get

Software Version of the device

string Leica.Disto.Networking.IpDeviceDescriptor.SoftwareVersionWlan
get

WLAN-Software Version of the device

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.WlanInterfaceException Class Reference

  • Networking
  • WlanInterfaceException
Public Member Functions | List of all members
Leica.Disto.Networking.WlanInterfaceException Class Reference

Custom Exception to catch Wlan Problems with special Utilities (Lenovo etc.) More...

Inheritance diagram for Leica.Disto.Networking.WlanInterfaceException:

Public Member Functions

WlanInterfaceException ()
Parameterless Constructor for WlanInterfaceException More...
WlanInterfaceException (string p_Message, Exception p_InnerException)
Constructor for WlanInterfaceException More...

Detailed Description

Custom Exception to catch Wlan Problems with special Utilities (Lenovo etc.)

Constructor & Destructor Documentation

Leica.Disto.Networking.WlanInterfaceException.WlanInterfaceException ( )

Parameterless Constructor for WlanInterfaceException

Leica.Disto.Networking.WlanInterfaceException.WlanInterfaceException | ( | string | p_Message,
 |  | Exception | p_InnerException
 | ) |  |

Constructor for WlanInterfaceException

Parameters
p_Message
p_InnerException Inner Causing Exception
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Index

Class Index
A | D | E | I | L | P | R | S | U | V | W
A
ExceptionTimeout (Leica.Disto.Api.AsyncSubsystem) Resolution5Mpix (Leica.Disto.Api.HardwareInterface) SensorPoint (Leica.Disto.Api.GeoMath)
ExceptionUnsupportedCommand (Leica.Disto.Api.SystemInterface) ResolutionDVGA (Leica.Disto.Api.HardwareInterface) SensorTemperatures (Leica.Disto.Api.HardwareInterface)
Angle (Leica.Disto.Api.GeoMath) ExceptionUnsupportedDeviceType (Leica.Disto.Api.SystemInterface) ResolutionQVGA (Leica.Disto.Api.HardwareInterface) Size (Leica.Disto.Api.GeoMath)
AxisData (Leica.Disto.Api.SystemInterface)
I
ResolutionSVGA (Leica.Disto.Api.HardwareInterface) SnapshotImage (Leica.Disto.Api.CommandInterface)
D
ResolutionUXGA (Leica.Disto.Api.HardwareInterface) Subsystem (Leica.Disto.Api.AsyncSubsystem)
IAxisData (Leica.Disto.Api.HardwareInterface) ResolutionVGA (Leica.Disto.Api.HardwareInterface) SyncObject (Leica.Disto.Api.AsyncSubsystem)
DistoOnWlanSearcher (Leica.Disto.Networking.Windows) IdentifiedObject (Leica.Disto.Api.GeoMath) Response (Leica.Disto.Api.CommandInterface) SyncObject< T > (Leica.Disto.Api.AsyncSubsystem)
Wlan.Dot11Ssid (Leica.Disto.Networking.Windows) ILiveImage (Leica.Disto.Api.HardwareInterface)
S
SystemSettings (Leica.Disto.Api.Configuration)
DummyLogger (Leica.Disto.Api.Logging) ILog (Leica.Disto.Api.Logging)
U
E
InterruptReasonMask (Leica.Disto.Api.AsyncSubsystem) SensorBatteryState (Leica.Disto.Api.HardwareInterface)
IpDeviceDescriptor (Leica.Disto.Networking) SensorData (Leica.Disto.Api.SystemInterface) UDPer (Leica.Disto.Networking.Windows)
ExceptionCleanup (Leica.Disto.Api.AsyncSubsystem) ISensorData (Leica.Disto.Api.HardwareInterface) SensorDirection (Leica.Disto.Api.GeoMath)
V
ExceptionCleanupInitialize (Leica.Disto.Api.AsyncSubsystem) ISensorEvent (Leica.Disto.Api.HardwareInterface) SensorError (Leica.Disto.Api.HardwareInterface)
ExceptionCleanupStop (Leica.Disto.Api.AsyncSubsystem) ISensorEvents (Leica.Disto.Api.HardwareInterface) SensorEvent (Leica.Disto.Api.EventInterface) Vector (Leica.Disto.Api.GeoMath)
ExceptionCommandInterface (Leica.Disto.Api.CommandInterface) ISnapImage (Leica.Disto.Api.HardwareInterface) SensorEventBatteryStateChanged (Leica.Disto.Api.EventInterface)
W
ExceptionCore (Leica.Disto.Api.AsyncSubsystem)
L
SensorEventCalibration (Leica.Disto.Api.EventInterface)
ExceptionEmptyImageBuffer (Leica.Disto.Api.SystemInterface) SensorEventInclinationPlaneChanged (Leica.Disto.Api.EventInterface) WlanInterfaceException (Leica.Disto.Networking)
ExceptionError (Leica.Disto.Api.AsyncSubsystem) LiveImagePixelConverter (Leica.Disto.Api.GeoMath) SensorEventMeasurePolar (Leica.Disto.Api.EventInterface) PlatformWindowsNet.WlanInterfaceWithNetwork (Leica.Disto.Networking)
ExceptionEventInterface (Leica.Disto.Api.EventInterface)
P
SensorEventMotorStopped (Leica.Disto.Api.EventInterface) PlatformWindowsNet.WlanNetwork (Leica.Disto.Networking)
ExceptionInvalidParameter (Leica.Disto.Api.AsyncSubsystem) SensorEventRemoteControlKeyPressed (Leica.Disto.Api.EventInterface)
ExceptionInvalidState (Leica.Disto.Api.AsyncSubsystem) PlatformWindowsNet (Leica.Disto.Networking) SensorEventSystemMessage (Leica.Disto.Api.EventInterface)
ExceptionInvalidUsage (Leica.Disto.Api.AsyncSubsystem) Point (Leica.Disto.Api.GeoMath) SensorIncline (Leica.Disto.Api.GeoMath)
ExceptionSensorInterface (Leica.Disto.Api.SystemInterface)
R
SensorInterface (Leica.Disto.Api.SystemInterface)
RemoteControlKey (Leica.Disto.Api.HardwareInterface)
A | D | E | I | L | P | R | S | U | V | W
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
o C Leica.Disto.Api.GeoMath.Angle | functions that can be applied to angles in [rad]
o C ApplicationException |
| \ C Leica.Disto.Networking.WlanInterfaceException | Custom Exception to catch Wlan Problems with special Utilities (Lenovo etc.)
o C Leica.Disto.Networking.Windows.DistoOnWlanSearcher |
o C Leica.Disto.Networking.Windows.Wlan.Dot11Ssid | Contains the SSID of an interface.
o C Exception |
| \ C Leica.Disto.Api.AsyncSubsystem.ExceptionCore | generic core exception
| o C Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | generic cleanup exception (cleanup = reaction exception after error messages have been displayed)
| | o C Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize | system needs to initialize excetpion
| | \ C Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop | system has stopped exception
| o C Leica.Disto.Api.AsyncSubsystem.ExceptionError | generic error exception
| | o C Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter | generic timeout exception
| | o C Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage | generic timeout exception
| | o C Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout | generic timeout exception
| | o C Leica.Disto.Api.CommandInterface.ExceptionCommandInterface | exception that is thrown from the command interface, when something bad is encountered in the input
| | o C Leica.Disto.Api.EventInterface.ExceptionEventInterface | exception that is thrown from the command interface, when something bad is encountered in the input
| | o C Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer | Exception thrown when accessing a live image containing no data
| | o C Leica.Disto.Api.SystemInterface.ExceptionSensorInterface | exception that is thrown from the sensor interface
| | o C Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand | Exception thrown when the command is not supported by the connected device
| | \ C Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType | Exception thrown when the connected device is not supported by this API
| \ C Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState | invalid state exception
o C Leica.Disto.Api.HardwareInterface.IAxisData | Description: Provides the interface to an Axis's mirrored data values
| \ C Leica.Disto.Api.SystemInterface.AxisData | Represents the iternal data of eitherthe Hz or V axis
o C Leica.Disto.Api.GeoMath.IdentifiedObject | Base class for objects which need a unique id for persisting them
| o C Leica.Disto.Api.GeoMath.SensorDirection |
| o C Leica.Disto.Api.GeoMath.SensorPoint | Point defined with polar coordinates
| \ C Leica.Disto.Api.GeoMath.Vector | Class for 3d vectors
o C Leica.Disto.Api.HardwareInterface.ILiveImage | Represents the image that is returned from the sensor when live-image is turned on.
o C Leica.Disto.Api.Logging.ILog |
| \ C Leica.Disto.Api.Logging.DummyLogger |
o C Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask | wakeup mask for calls to WaitOnActionDone
o C Leica.Disto.Networking.IpDeviceDescriptor | Description of a connected Device
o C Leica.Disto.Api.HardwareInterface.ISensorData | Description: Provides the interface to the Sensor's mirrored data values Responsibilities: mirrors the Sensor's data values and provides an interface to it Collaborators: an implementation of ISensor
| \ C Leica.Disto.Api.SystemInterface.SensorData | collection of the Sensor's current, internal data
o C Leica.Disto.Api.HardwareInterface.ISensorEvent |
| \ C Leica.Disto.Api.EventInterface.SensorEvent | Base class for concrete sensor events
| o C Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged | concrete event representing the event when the battery's state has changed
| o C Leica.Disto.Api.EventInterface.SensorEventCalibration | concrete event representing the event when a calibration sequence finished
| o C Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged | concrete event representing the event when the state of the inclination plane has changed
| o C Leica.Disto.Api.EventInterface.SensorEventMeasurePolar | Concrete event representing the occurence of a Measure Polar with Image Event
| o C Leica.Disto.Api.EventInterface.SensorEventMotorStopped | concrete event representing the event when a motor(s) has been stopped
| o C Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed | concrete event representing the event when the remote control's key has been pressed
| \ C Leica.Disto.Api.EventInterface.SensorEventSystemMessage | Concrete event representing the occurence of a system error or warning
o C Leica.Disto.Api.HardwareInterface.ISensorEvents | Defines the sensor's event interface, i.e. which events the sensor generates.
| \ C Leica.Disto.Api.SystemInterface.SensorInterface | API for the Leica 3D Disto sensor
o C Leica.Disto.Api.HardwareInterface.ISnapImage | Represents a snapshot image that is returned from the sensor by a image-snap command.
| \ C Leica.Disto.Api.CommandInterface.SnapshotImage | Implements a snapshot image that is returned from the sensor.
o C Leica.Disto.Api.GeoMath.LiveImagePixelConverter | Converter class for transforming sensor directions to pixel coordinates and back
o C Leica.Disto.Networking.PlatformWindowsNet | Class for network configuration on Windows platforms (XP, Vista, Win7, Win8)
o C Leica.Disto.Api.GeoMath.Point | Struct representing a point, with double coordinates
o C Leica.Disto.Api.HardwareInterface.RemoteControlKey | the keys on the remote control
o C Leica.Disto.Api.HardwareInterface.Resolution5Mpix | 5M pix image resolution
o C Leica.Disto.Api.HardwareInterface.ResolutionDVGA | DVGA image resolution
o C Leica.Disto.Api.HardwareInterface.ResolutionQVGA | QVGA image resolution
o C Leica.Disto.Api.HardwareInterface.ResolutionSVGA | SVGA image resolution, supported on LD5+ devices
o C Leica.Disto.Api.HardwareInterface.ResolutionUXGA | UXGA image resolution, supported on LD5+ devices
o C Leica.Disto.Api.HardwareInterface.ResolutionVGA | VGA image resolution
o C Leica.Disto.Api.CommandInterface.Response | Represents the result that is returned by the Sensor, translated into binary data. The object contains a result object or an error code, but not boththey are mutually exclusive
o C Leica.Disto.Api.HardwareInterface.SensorBatteryState | the sensor battery's state, i.e. current voltage level and an indicator of the battery's charging level.
o C Leica.Disto.Api.HardwareInterface.SensorError | Error numbers (SkyCom 3.6)
o C Leica.Disto.Api.GeoMath.SensorIncline | Represents the inclination plane values from the sensor
o C Leica.Disto.Api.HardwareInterface.SensorTemperatures | consolidates the different temperatures measured on the sensor
o C Leica.Disto.Api.GeoMath.Size | Struct representing a size defined by width and heigt
o C Leica.Disto.Api.AsyncSubsystem.Subsystem | asynchronous subsystem base class
| \ C Leica.Disto.Api.SystemInterface.SensorInterface | API for the Leica 3D Disto sensor
o C Leica.Disto.Api.AsyncSubsystem.SyncObject | Object used for thread synchronization. It is mainly used as return value of asynchronous methods for communicating with the sensor.
| \ C Leica.Disto.Api.AsyncSubsystem.SyncObject< T > | Object used for thread synchronization. It is mainly used as return value in asynchronous method declaration.
o C Leica.Disto.Api.Configuration.SystemSettings | This class contains sensor settings like its (fixed) IP address over USB and WLAN.
o C Leica.Disto.Networking.Windows.UDPer |
o C Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork | Contains information about a WLAN network and the adapter where its available
\ C Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork | Contains information about a WLAN network.
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Leica.Disto.Networking.Windows.Wlan.Dot11Ssid Struct Reference

  • Networking
  • Windows
  • Wlan
  • Dot11Ssid
Public Attributes | List of all members
Leica.Disto.Networking.Windows.Wlan.Dot11Ssid Struct Reference

Contains the SSID of an interface. More...

Public Attributes

uint | SSIDLength
The length, in bytes, of the SSID array. More...
byte[] | SSID
The SSID. More...

Detailed Description

Contains the SSID of an interface.

Member Data Documentation

byte [] Leica.Disto.Networking.Windows.Wlan.Dot11Ssid.SSID

The SSID.

uint Leica.Disto.Networking.Windows.Wlan.Dot11Ssid.SSIDLength

The length, in bytes, of the SSID array.

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _EventType : Leica.Disto.Api.EventInterface.SensorEvent
  • _Evt : Leica.Disto.Api.AsyncSubsystem.SyncObject
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- a -

  • Action : Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed
  • Adapter : Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
  • Angle : Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • ApiVersion : Leica.Disto.Api.SystemInterface.SensorInterface
  • AreParallel() : Leica.Disto.Api.GeoMath.Vector
  • Axis : Leica.Disto.Api.EventInterface.SensorEventMotorStopped , Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • AxisData() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.AxisData , Leica.Disto.Api.SystemInterface.SensorData
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- b -

  • BatteryState : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • BatteryStateChanged : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • BitNumber : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChargingLevel : Leica.Disto.Api.HardwareInterface.SensorBatteryState
  • CheckRndisIp() : Leica.Disto.Networking.PlatformWindowsNet
  • Clear() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Clone() : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.Vector
  • Code : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • CompensatorState : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorIncline , Leica.Disto.Api.GeoMath.SensorPoint
  • Connect() : Leica.Disto.Api.SystemInterface.SensorInterface
  • ConnectToDistoWlanNetwork() : Leica.Disto.Networking.PlatformWindowsNet
  • Crosshair : Leica.Disto.Api.CommandInterface.SnapshotImage , Leica.Disto.Api.HardwareInterface.ISnapImage
  • CrossProduct() : Leica.Disto.Api.GeoMath.Vector
  • CurrentState : Leica.Disto.Api.EventInterface.SensorEvent
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- d -

  • Data : Leica.Disto.Api.CommandInterface.SnapshotImage , Leica.Disto.Api.HardwareInterface.ISnapImage
  • Debug() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • DeltaEast : Leica.Disto.Api.GeoMath.Vector
  • DeltaH : Leica.Disto.Api.GeoMath.Vector
  • DeltaNorth : Leica.Disto.Api.GeoMath.Vector
  • DeviceType : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Direction : Leica.Disto.Api.CommandInterface.SnapshotImage , Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.HardwareInterface.ISnapImage , Leica.Disto.Api.SystemInterface.AxisData
  • DisableLiveImage() : Leica.Disto.Api.SystemInterface.SensorInterface
  • DisableWlan() : Leica.Disto.Networking.PlatformWindowsNet
  • Disconnect() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Dist : Leica.Disto.Api.GeoMath.SensorPoint , Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • Down : Leica.Disto.Api.HardwareInterface.RemoteControlKey
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- e -

  • EdmSensor : Leica.Disto.Api.HardwareInterface.SensorTemperatures
  • EdmWorkingRange : Leica.Disto.Api.HardwareInterface.SensorError
  • Empty : Leica.Disto.Api.GeoMath.Point
  • EnableLiveImage() : Leica.Disto.Api.SystemInterface.SensorInterface
  • EnableWlan() : Leica.Disto.Networking.PlatformWindowsNet
  • EnterPin() : Leica.Disto.Api.SystemInterface.SensorInterface
  • EnterPuk() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Equals() : Leica.Disto.Api.GeoMath.IdentifiedObject
  • EquipmentNumber : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Error() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • ErrorCode : Leica.Disto.Api.CommandInterface.Response , Leica.Disto.Api.EventInterface.SensorEvent , Leica.Disto.Api.HardwareInterface.ISensorEvent
  • EventType : Leica.Disto.Api.EventInterface.SensorEvent , Leica.Disto.Api.HardwareInterface.ISensorEvent
  • ExceptionCleanup() : Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup
  • ExceptionCleanupInitialize() : Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize
  • ExceptionCleanupStop() : Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop
  • ExceptionCommandInterface() : Leica.Disto.Api.CommandInterface.ExceptionCommandInterface
  • ExceptionCore() : Leica.Disto.Api.AsyncSubsystem.ExceptionCore
  • ExceptionError() : Leica.Disto.Api.AsyncSubsystem.ExceptionError
  • ExceptionEventInterface() : Leica.Disto.Api.EventInterface.ExceptionEventInterface
  • ExceptionInvalidParameter() : Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter
  • ExceptionInvalidState() : Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState
  • ExceptionInvalidUsage() : Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage
  • ExceptionSensorInterface() : Leica.Disto.Api.SystemInterface.ExceptionSensorInterface
  • ExceptionTimeout() : Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout
  • ExitInstance() : Leica.Disto.Api.AsyncSubsystem.Subsystem , Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- f -

  • Face : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Finished() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher , Leica.Disto.Networking.Windows.UDPer
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- g -

  • Get() : Leica.Disto.Api.HardwareInterface.ILiveImage
  • GetAngle() : Leica.Disto.Api.GeoMath.Vector
  • GetBatteryState() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetCurrentState() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • GetDistoWlanNetworks() : Leica.Disto.Networking.PlatformWindowsNet
  • GetErrors() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • GetFace() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetHashCode() : Leica.Disto.Api.GeoMath.IdentifiedObject
  • GetHorDist() : Leica.Disto.Api.GeoMath.SensorPoint
  • GetInFaceOne() : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • GetIpDeviceDescriptorList() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher
  • GetLedSyserror() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetLedWarning() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetMotorStatus() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetOpticsConstant() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • GetSerialNumber() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetShortest() : Leica.Disto.Api.GeoMath.Angle
  • GetSoftwareVersion() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetSubsystemID() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • GetSystemError() : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
  • GetSystemWarning() : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
  • GetTemperatures() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetTiltSensitivity() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetVertDist() : Leica.Disto.Api.GeoMath.SensorPoint
  • GetWarnings() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • GetWlanChannel() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetWlanEssid() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetWlanFreq() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetWlanInterfaces() : Leica.Disto.Networking.PlatformWindowsNet
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- h -

  • HasException() : Leica.Disto.Api.AsyncSubsystem.SyncObject
  • HasResult() : Leica.Disto.Api.AsyncSubsystem.SyncObject
  • Height : Leica.Disto.Api.GeoMath.Size , Leica.Disto.Api.HardwareInterface.Resolution5Mpix , Leica.Disto.Api.HardwareInterface.ResolutionDVGA , Leica.Disto.Api.HardwareInterface.ResolutionQVGA , Leica.Disto.Api.HardwareInterface.ResolutionSVGA , Leica.Disto.Api.HardwareInterface.ResolutionUXGA , Leica.Disto.Api.HardwareInterface.ResolutionVGA
  • Hz : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • HzMotorBlocked : Leica.Disto.Api.HardwareInterface.SensorError
  • HzOutOfRange : Leica.Disto.Api.HardwareInterface.SensorError
  • HzSensor : Leica.Disto.Api.HardwareInterface.SensorTemperatures
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- i -

  • ICross : Leica.Disto.Api.GeoMath.SensorIncline
  • IdentifiedObject() : Leica.Disto.Api.GeoMath.IdentifiedObject
  • IHz : Leica.Disto.Api.GeoMath.SensorIncline
  • ILen : Leica.Disto.Api.GeoMath.SensorIncline
  • Image : Leica.Disto.Api.EventInterface.SensorEventMeasurePolar
  • ImageBrightness : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • ImageMode : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • ImageSize : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • ImageZoom : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • InclinationPlaneChanged : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • InclinationPlaneState : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Info() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • InitInstance() : Leica.Disto.Api.AsyncSubsystem.Subsystem , Leica.Disto.Api.SystemInterface.SensorInterface
  • Input : Leica.Disto.Api.CommandInterface.ExceptionCommandInterface , Leica.Disto.Api.EventInterface.ExceptionEventInterface
  • IpAddressRndis : Leica.Disto.Api.Configuration.SystemSettings
  • IpAddressWlan : Leica.Disto.Api.Configuration.SystemSettings
  • IpAdress : Leica.Disto.Networking.IpDeviceDescriptor
  • IpDeviceDescriptor() : Leica.Disto.Networking.IpDeviceDescriptor
  • IsDist() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsDown() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsError : Leica.Disto.Api.CommandInterface.Response , Leica.Disto.Api.EventInterface.SensorEvent , Leica.Disto.Api.HardwareInterface.ISensorEvent
  • IsLeft() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsRight() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsSet() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • IsUp() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- k -

  • Key : Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed , Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- l -

  • LaserMode : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Left : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • Length : Leica.Disto.Api.GeoMath.Vector
  • LevCalibrationCancelled : Leica.Disto.Api.HardwareInterface.SensorError
  • LevCalibrationChanged : Leica.Disto.Api.HardwareInterface.SensorError
  • Level : Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged
  • LevelMode : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • LevelSensitivity : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • LevelSensorInitializing : Leica.Disto.Api.HardwareInterface.SensorError
  • LevOutOfWorkingRange : Leica.Disto.Api.HardwareInterface.SensorError
  • LinkQuality : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
  • LiveImage : Leica.Disto.Api.SystemInterface.SensorInterface
  • LiveImageChanged : Leica.Disto.Api.HardwareInterface.ILiveImage
  • LiveImagePixelConverter() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • Location : Leica.Disto.Api.CommandInterface.ExceptionCommandInterface , Leica.Disto.Api.EventInterface.ExceptionEventInterface
  • Logger : Leica.Disto.Api.AsyncSubsystem.ExceptionCore
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- m -

  • MeasureAngle() : Leica.Disto.Api.SystemInterface.SensorInterface
  • MeasureIncline() : Leica.Disto.Api.SystemInterface.SensorInterface
  • MeasurePolar() : Leica.Disto.Api.SystemInterface.SensorInterface
  • MeasurePolarEvent : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • MessageSet : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
  • MessageType : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- n -

  • Network : Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
  • NiAngle : Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • NiHz : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • NiV : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • NormalAbsolute() : Leica.Disto.Api.GeoMath.Angle
  • NormalRelative() : Leica.Disto.Api.GeoMath.Angle
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- o -

  • OperatingHours : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • operator WaitHandle() : Leica.Disto.Api.AsyncSubsystem.SyncObject
  • operator*() : Leica.Disto.Api.GeoMath.Vector
  • operator+() : Leica.Disto.Api.GeoMath.Vector
  • operator-() : Leica.Disto.Api.GeoMath.Vector
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- p -

  • Ping() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PinState : Leica.Disto.Api.SystemInterface.SensorData
  • PlatformWindowsNet() : Leica.Disto.Networking.PlatformWindowsNet
  • Point() : Leica.Disto.Api.GeoMath.Point
  • PositionAbsolute() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionAbsoluteNi() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionAccelerate() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionRelative() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionRelativeNi() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PowerOff() : Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- r -

  • Raw : Leica.Disto.Api.GeoMath.SensorIncline
  • RemoteControlKey() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • RemoteControlKeyPressed : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • Reset() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Result : Leica.Disto.Api.AsyncSubsystem.SyncObject , Leica.Disto.Api.AsyncSubsystem.SyncObject< T > , Leica.Disto.Api.CommandInterface.Response
  • ResultObj : Leica.Disto.Api.AsyncSubsystem.SyncObject
  • Right : Leica.Disto.Api.HardwareInterface.RemoteControlKey
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- s -

  • ScalarProduct() : Leica.Disto.Api.GeoMath.Vector
  • ScanForDistoDevices() : Leica.Disto.Networking.PlatformWindowsNet
  • ScanWlanNetworks() : Leica.Disto.Networking.PlatformWindowsNet
  • Secured : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
  • SecurityEnabled : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Send() : Leica.Disto.Networking.Windows.UDPer
  • SensorBatteryState() : Leica.Disto.Api.HardwareInterface.SensorBatteryState
  • SensorData() : Leica.Disto.Api.SystemInterface.SensorData , Leica.Disto.Api.SystemInterface.SensorInterface
  • SensorDataChanged : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SensorDirection() : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SensorEvent() : Leica.Disto.Api.EventInterface.SensorEvent
  • SensorIncline() : Leica.Disto.Api.GeoMath.SensorIncline
  • SensorInterface() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SensorIp : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SensorPoint : Leica.Disto.Api.EventInterface.SensorEventMeasurePolar , Leica.Disto.Api.GeoMath.SensorPoint
  • SensorSerialNumber : Leica.Disto.Api.GeoMath.SensorPoint
  • SensorTemperatures() : Leica.Disto.Api.HardwareInterface.SensorTemperatures
  • SerialNumber : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData , Leica.Disto.Networking.IpDeviceDescriptor
  • Set() : Leica.Disto.Api.HardwareInterface.ILiveImage , Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SetErrors() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SetImageBrightness() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetImageZoom() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetLaserMode() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetLevelMode() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetPin() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetPositioningDirection() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetPositioningVelocity() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetTiltSensitivity() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetWarnings() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SetWlanChannel() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Shutdown() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • SignalCompletion() : Leica.Disto.Api.AsyncSubsystem.SyncObject< T >
  • Size() : Leica.Disto.Api.GeoMath.Size
  • Snapshot() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SoftwareName : Leica.Disto.Networking.IpDeviceDescriptor
  • SoftwareVersion : Leica.Disto.Networking.IpDeviceDescriptor
  • SoftwareVersionWlan : Leica.Disto.Networking.IpDeviceDescriptor
  • Ssid : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
  • SSID : Leica.Disto.Networking.Windows.Wlan.Dot11Ssid
  • SSIDLength : Leica.Disto.Networking.Windows.Wlan.Dot11Ssid
  • Start() : Leica.Disto.Networking.Windows.UDPer
  • StartPositioning() : Leica.Disto.Api.SystemInterface.SensorInterface
  • StartSearch() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher
  • Startup() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • State : Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged , Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.AxisData , Leica.Disto.Api.SystemInterface.SensorData
  • Stop() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher , Leica.Disto.Networking.Windows.UDPer
  • StopPositioning() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Subsystem() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • Synchronize() : Leica.Disto.Api.AsyncSubsystem.SyncObject , Leica.Disto.Api.AsyncSubsystem.SyncObject< T >
  • SyncObject() : Leica.Disto.Api.AsyncSubsystem.SyncObject< T >
  • SystemMessageReceived : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- t -

  • ToImagePoint() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • ToPolarCoordinates() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • ToString() : Leica.Disto.Api.AsyncSubsystem.SyncObject , Leica.Disto.Api.GeoMath.SensorIncline , Leica.Disto.Api.GeoMath.SensorPoint , Leica.Disto.Api.GeoMath.Vector , Leica.Disto.Api.HardwareInterface.RemoteControlKey
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- u -

  • Up : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • UpdateValues() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- v -

  • V : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • V1 : Leica.Disto.Api.GeoMath.Vector
  • V2 : Leica.Disto.Api.GeoMath.Vector
  • V3 : Leica.Disto.Api.GeoMath.Vector
  • Vector() : Leica.Disto.Api.GeoMath.Vector
  • Velocity : Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • VMotorBlocked : Leica.Disto.Api.HardwareInterface.SensorError
  • Voltage : Leica.Disto.Api.HardwareInterface.SensorBatteryState
  • VOutOfRange : Leica.Disto.Api.HardwareInterface.SensorError
  • VSensor : Leica.Disto.Api.HardwareInterface.SensorTemperatures
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- w -

  • WakeMaskActionsAll : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskActionsOne : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskCommandAboveNormal : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskCommandHigh : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskDefault : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • Warn() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • Width : Leica.Disto.Api.GeoMath.Size , Leica.Disto.Api.HardwareInterface.Resolution5Mpix , Leica.Disto.Api.HardwareInterface.ResolutionDVGA , Leica.Disto.Api.HardwareInterface.ResolutionQVGA , Leica.Disto.Api.HardwareInterface.ResolutionSVGA , Leica.Disto.Api.HardwareInterface.ResolutionUXGA , Leica.Disto.Api.HardwareInterface.ResolutionVGA
  • WlanInterfaceException() : Leica.Disto.Networking.WlanInterfaceException
  • WlanInterfaceWithNetwork() : Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
  • WlanNetwork() : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- x -

  • X : Leica.Disto.Api.GeoMath.Point
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all class members with links to the classes they belong to:

- y -

  • Y : Leica.Disto.Api.GeoMath.Point
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • AreParallel() : Leica.Disto.Api.GeoMath.Vector
  • AxisData() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.AxisData , Leica.Disto.Api.SystemInterface.SensorData
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CheckRndisIp() : Leica.Disto.Networking.PlatformWindowsNet
  • Clear() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Clone() : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.Vector
  • Connect() : Leica.Disto.Api.SystemInterface.SensorInterface
  • ConnectToDistoWlanNetwork() : Leica.Disto.Networking.PlatformWindowsNet
  • CrossProduct() : Leica.Disto.Api.GeoMath.Vector
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • Debug() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • DisableLiveImage() : Leica.Disto.Api.SystemInterface.SensorInterface
  • DisableWlan() : Leica.Disto.Networking.PlatformWindowsNet
  • Disconnect() : Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • EnableLiveImage() : Leica.Disto.Api.SystemInterface.SensorInterface
  • EnableWlan() : Leica.Disto.Networking.PlatformWindowsNet
  • EnterPin() : Leica.Disto.Api.SystemInterface.SensorInterface
  • EnterPuk() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Equals() : Leica.Disto.Api.GeoMath.IdentifiedObject
  • Error() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • ExceptionCleanup() : Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup
  • ExceptionCleanupInitialize() : Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize
  • ExceptionCleanupStop() : Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop
  • ExceptionCommandInterface() : Leica.Disto.Api.CommandInterface.ExceptionCommandInterface
  • ExceptionCore() : Leica.Disto.Api.AsyncSubsystem.ExceptionCore
  • ExceptionError() : Leica.Disto.Api.AsyncSubsystem.ExceptionError
  • ExceptionEventInterface() : Leica.Disto.Api.EventInterface.ExceptionEventInterface
  • ExceptionInvalidParameter() : Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter
  • ExceptionInvalidState() : Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState
  • ExceptionInvalidUsage() : Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage
  • ExceptionSensorInterface() : Leica.Disto.Api.SystemInterface.ExceptionSensorInterface
  • ExceptionTimeout() : Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout
  • ExitInstance() : Leica.Disto.Api.AsyncSubsystem.Subsystem , Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • Finished() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher , Leica.Disto.Networking.Windows.UDPer
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • Get() : Leica.Disto.Api.HardwareInterface.ILiveImage
  • GetAngle() : Leica.Disto.Api.GeoMath.Vector
  • GetBatteryState() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetCurrentState() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • GetDistoWlanNetworks() : Leica.Disto.Networking.PlatformWindowsNet
  • GetErrors() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • GetFace() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetHashCode() : Leica.Disto.Api.GeoMath.IdentifiedObject
  • GetHorDist() : Leica.Disto.Api.GeoMath.SensorPoint
  • GetInFaceOne() : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • GetIpDeviceDescriptorList() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher
  • GetLedSyserror() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetLedWarning() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetMotorStatus() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetOpticsConstant() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • GetSerialNumber() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetShortest() : Leica.Disto.Api.GeoMath.Angle
  • GetSoftwareVersion() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetSubsystemID() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • GetSystemError() : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
  • GetSystemWarning() : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
  • GetTemperatures() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetTiltSensitivity() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetVertDist() : Leica.Disto.Api.GeoMath.SensorPoint
  • GetWarnings() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • GetWlanChannel() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetWlanEssid() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetWlanFreq() : Leica.Disto.Api.SystemInterface.SensorInterface
  • GetWlanInterfaces() : Leica.Disto.Networking.PlatformWindowsNet
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HasException() : Leica.Disto.Api.AsyncSubsystem.SyncObject
  • HasResult() : Leica.Disto.Api.AsyncSubsystem.SyncObject
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • IdentifiedObject() : Leica.Disto.Api.GeoMath.IdentifiedObject
  • Info() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • InitInstance() : Leica.Disto.Api.AsyncSubsystem.Subsystem , Leica.Disto.Api.SystemInterface.SensorInterface
  • IpDeviceDescriptor() : Leica.Disto.Networking.IpDeviceDescriptor
  • IsDist() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsDown() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsError() : Leica.Disto.Api.EventInterface.SensorEvent , Leica.Disto.Api.HardwareInterface.ISensorEvent
  • IsLeft() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsRight() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • IsSet() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • IsUp() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • LiveImagePixelConverter() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MeasureAngle() : Leica.Disto.Api.SystemInterface.SensorInterface
  • MeasureIncline() : Leica.Disto.Api.SystemInterface.SensorInterface
  • MeasurePolar() : Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • NormalAbsolute() : Leica.Disto.Api.GeoMath.Angle
  • NormalRelative() : Leica.Disto.Api.GeoMath.Angle
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • operator WaitHandle() : Leica.Disto.Api.AsyncSubsystem.SyncObject
  • operator*() : Leica.Disto.Api.GeoMath.Vector
  • operator+() : Leica.Disto.Api.GeoMath.Vector
  • operator-() : Leica.Disto.Api.GeoMath.Vector
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • Ping() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PlatformWindowsNet() : Leica.Disto.Networking.PlatformWindowsNet
  • Point() : Leica.Disto.Api.GeoMath.Point
  • PositionAbsolute() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionAbsoluteNi() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionAccelerate() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionRelative() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PositionRelativeNi() : Leica.Disto.Api.SystemInterface.SensorInterface
  • PowerOff() : Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • RemoteControlKey() : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • Reset() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • ScalarProduct() : Leica.Disto.Api.GeoMath.Vector
  • ScanForDistoDevices() : Leica.Disto.Networking.PlatformWindowsNet
  • ScanWlanNetworks() : Leica.Disto.Networking.PlatformWindowsNet
  • Send() : Leica.Disto.Networking.Windows.UDPer
  • SensorBatteryState() : Leica.Disto.Api.HardwareInterface.SensorBatteryState
  • SensorData() : Leica.Disto.Api.SystemInterface.SensorData
  • SensorDirection() : Leica.Disto.Api.GeoMath.SensorDirection
  • SensorEvent() : Leica.Disto.Api.EventInterface.SensorEvent
  • SensorIncline() : Leica.Disto.Api.GeoMath.SensorIncline
  • SensorInterface() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SensorPoint() : Leica.Disto.Api.GeoMath.SensorPoint
  • SensorTemperatures() : Leica.Disto.Api.HardwareInterface.SensorTemperatures
  • Set() : Leica.Disto.Api.HardwareInterface.ILiveImage , Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SetErrors() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SetImageBrightness() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetImageZoom() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetLaserMode() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetLevelMode() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetPin() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetPositioningDirection() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetPositioningVelocity() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetTiltSensitivity() : Leica.Disto.Api.SystemInterface.SensorInterface
  • SetWarnings() : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SetWlanChannel() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Shutdown() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • SignalCompletion() : Leica.Disto.Api.AsyncSubsystem.SyncObject< T >
  • Size() : Leica.Disto.Api.GeoMath.Size
  • Snapshot() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Start() : Leica.Disto.Networking.Windows.UDPer
  • StartPositioning() : Leica.Disto.Api.SystemInterface.SensorInterface
  • StartSearch() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher
  • Startup() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • Stop() : Leica.Disto.Networking.Windows.DistoOnWlanSearcher , Leica.Disto.Networking.Windows.UDPer
  • StopPositioning() : Leica.Disto.Api.SystemInterface.SensorInterface
  • Subsystem() : Leica.Disto.Api.AsyncSubsystem.Subsystem
  • Synchronize() : Leica.Disto.Api.AsyncSubsystem.SyncObject , Leica.Disto.Api.AsyncSubsystem.SyncObject< T >
  • SyncObject() : Leica.Disto.Api.AsyncSubsystem.SyncObject< T >
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • ToImagePoint() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • ToPolarCoordinates() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • ToString() : Leica.Disto.Api.AsyncSubsystem.SyncObject , Leica.Disto.Api.GeoMath.SensorIncline , Leica.Disto.Api.GeoMath.SensorPoint , Leica.Disto.Api.GeoMath.Vector , Leica.Disto.Api.HardwareInterface.RemoteControlKey
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UpdateValues() : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • Vector() : Leica.Disto.Api.GeoMath.Vector
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • Warn() : Leica.Disto.Api.Logging.DummyLogger , Leica.Disto.Api.Logging.ILog
  • WlanInterfaceException() : Leica.Disto.Networking.WlanInterfaceException
  • WlanInterfaceWithNetwork() : Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
  • WlanNetwork() : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • e
  • h
  • l
  • r
  • s
  • v
  • w

- _ -

  • _EventType : Leica.Disto.Api.EventInterface.SensorEvent
  • _Evt : Leica.Disto.Api.AsyncSubsystem.SyncObject

- e -

  • EdmWorkingRange : Leica.Disto.Api.HardwareInterface.SensorError

- h -

  • Height : Leica.Disto.Api.HardwareInterface.Resolution5Mpix , Leica.Disto.Api.HardwareInterface.ResolutionDVGA , Leica.Disto.Api.HardwareInterface.ResolutionQVGA , Leica.Disto.Api.HardwareInterface.ResolutionSVGA , Leica.Disto.Api.HardwareInterface.ResolutionUXGA , Leica.Disto.Api.HardwareInterface.ResolutionVGA
  • HzMotorBlocked : Leica.Disto.Api.HardwareInterface.SensorError
  • HzOutOfRange : Leica.Disto.Api.HardwareInterface.SensorError

- l -

  • LevCalibrationCancelled : Leica.Disto.Api.HardwareInterface.SensorError
  • LevCalibrationChanged : Leica.Disto.Api.HardwareInterface.SensorError
  • LevelSensorInitializing : Leica.Disto.Api.HardwareInterface.SensorError
  • LevOutOfWorkingRange : Leica.Disto.Api.HardwareInterface.SensorError

- r -

  • ResultObj : Leica.Disto.Api.AsyncSubsystem.SyncObject

- s -

  • SSID : Leica.Disto.Networking.Windows.Wlan.Dot11Ssid
  • SSIDLength : Leica.Disto.Networking.Windows.Wlan.Dot11Ssid

- v -

  • VMotorBlocked : Leica.Disto.Api.HardwareInterface.SensorError
  • VOutOfRange : Leica.Disto.Api.HardwareInterface.SensorError

- w -

  • WakeMaskActionsAll : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskActionsOne : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskCommandAboveNormal : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskCommandHigh : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • WakeMaskDefault : Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
  • Width : Leica.Disto.Api.HardwareInterface.Resolution5Mpix , Leica.Disto.Api.HardwareInterface.ResolutionDVGA , Leica.Disto.Api.HardwareInterface.ResolutionQVGA , Leica.Disto.Api.HardwareInterface.ResolutionSVGA , Leica.Disto.Api.HardwareInterface.ResolutionUXGA , Leica.Disto.Api.HardwareInterface.ResolutionVGA
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • v
  • w
  • x
  • y

- a -

  • Action : Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed
  • Adapter : Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
  • Angle : Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • ApiVersion : Leica.Disto.Api.SystemInterface.SensorInterface
  • Axis : Leica.Disto.Api.EventInterface.SensorEventMotorStopped , Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData

- b -

  • BatteryState : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • BitNumber : Leica.Disto.Api.EventInterface.SensorEventSystemMessage

- c -

  • ChargingLevel : Leica.Disto.Api.HardwareInterface.SensorBatteryState
  • Code : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • CompensatorState : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorIncline , Leica.Disto.Api.GeoMath.SensorPoint
  • Crosshair : Leica.Disto.Api.CommandInterface.SnapshotImage , Leica.Disto.Api.HardwareInterface.ISnapImage
  • CurrentState : Leica.Disto.Api.EventInterface.SensorEvent

- d -

  • Data : Leica.Disto.Api.CommandInterface.SnapshotImage , Leica.Disto.Api.HardwareInterface.ISnapImage
  • DeltaEast : Leica.Disto.Api.GeoMath.Vector
  • DeltaH : Leica.Disto.Api.GeoMath.Vector
  • DeltaNorth : Leica.Disto.Api.GeoMath.Vector
  • DeviceType : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Direction : Leica.Disto.Api.CommandInterface.SnapshotImage , Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.HardwareInterface.ISnapImage , Leica.Disto.Api.SystemInterface.AxisData
  • Dist : Leica.Disto.Api.GeoMath.SensorPoint , Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • Down : Leica.Disto.Api.HardwareInterface.RemoteControlKey

- e -

  • EdmSensor : Leica.Disto.Api.HardwareInterface.SensorTemperatures
  • Empty : Leica.Disto.Api.GeoMath.Point
  • EquipmentNumber : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • ErrorCode : Leica.Disto.Api.CommandInterface.Response , Leica.Disto.Api.EventInterface.SensorEvent , Leica.Disto.Api.HardwareInterface.ISensorEvent
  • EventType : Leica.Disto.Api.EventInterface.SensorEvent , Leica.Disto.Api.HardwareInterface.ISensorEvent

- f -

  • Face : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData

- h -

  • Height : Leica.Disto.Api.GeoMath.Size
  • Hz : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • HzSensor : Leica.Disto.Api.HardwareInterface.SensorTemperatures

- i -

  • ICross : Leica.Disto.Api.GeoMath.SensorIncline
  • IHz : Leica.Disto.Api.GeoMath.SensorIncline
  • ILen : Leica.Disto.Api.GeoMath.SensorIncline
  • Image : Leica.Disto.Api.EventInterface.SensorEventMeasurePolar
  • ImageBrightness : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • ImageMode : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • ImageSize : Leica.Disto.Api.GeoMath.LiveImagePixelConverter
  • ImageZoom : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • InclinationPlaneState : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Input : Leica.Disto.Api.CommandInterface.ExceptionCommandInterface , Leica.Disto.Api.EventInterface.ExceptionEventInterface
  • IpAddressRndis : Leica.Disto.Api.Configuration.SystemSettings
  • IpAddressWlan : Leica.Disto.Api.Configuration.SystemSettings
  • IpAdress : Leica.Disto.Networking.IpDeviceDescriptor
  • IsError : Leica.Disto.Api.CommandInterface.Response

- k -

  • Key : Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed , Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork

- l -

  • LaserMode : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • Left : Leica.Disto.Api.HardwareInterface.RemoteControlKey
  • Length : Leica.Disto.Api.GeoMath.Vector
  • Level : Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged
  • LevelMode : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • LevelSensitivity : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • LinkQuality : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
  • LiveImage : Leica.Disto.Api.SystemInterface.SensorInterface
  • Location : Leica.Disto.Api.CommandInterface.ExceptionCommandInterface , Leica.Disto.Api.EventInterface.ExceptionEventInterface
  • Logger : Leica.Disto.Api.AsyncSubsystem.ExceptionCore

- m -

  • MessageSet : Leica.Disto.Api.EventInterface.SensorEventSystemMessage
  • MessageType : Leica.Disto.Api.EventInterface.SensorEventSystemMessage

- n -

  • Network : Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
  • NiAngle : Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • NiHz : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • NiV : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint

- o -

  • OperatingHours : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData

- p -

  • PinState : Leica.Disto.Api.SystemInterface.SensorData

- r -

  • Raw : Leica.Disto.Api.GeoMath.SensorIncline
  • Result : Leica.Disto.Api.AsyncSubsystem.SyncObject , Leica.Disto.Api.AsyncSubsystem.SyncObject< T > , Leica.Disto.Api.CommandInterface.Response
  • Right : Leica.Disto.Api.HardwareInterface.RemoteControlKey

- s -

  • Secured : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
  • SecurityEnabled : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SensorData : Leica.Disto.Api.SystemInterface.SensorInterface
  • SensorDirection : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SensorIp : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SensorPoint : Leica.Disto.Api.EventInterface.SensorEventMeasurePolar
  • SensorSerialNumber : Leica.Disto.Api.GeoMath.SensorPoint
  • SerialNumber : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData , Leica.Disto.Networking.IpDeviceDescriptor
  • SoftwareName : Leica.Disto.Networking.IpDeviceDescriptor
  • SoftwareVersion : Leica.Disto.Networking.IpDeviceDescriptor
  • SoftwareVersionWlan : Leica.Disto.Networking.IpDeviceDescriptor
  • Ssid : Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
  • State : Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged , Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.AxisData , Leica.Disto.Api.SystemInterface.SensorData

- u -

  • Up : Leica.Disto.Api.HardwareInterface.RemoteControlKey

- v -

  • V : Leica.Disto.Api.GeoMath.SensorDirection , Leica.Disto.Api.GeoMath.SensorPoint
  • V1 : Leica.Disto.Api.GeoMath.Vector
  • V2 : Leica.Disto.Api.GeoMath.Vector
  • V3 : Leica.Disto.Api.GeoMath.Vector
  • Velocity : Leica.Disto.Api.HardwareInterface.IAxisData , Leica.Disto.Api.SystemInterface.AxisData
  • Voltage : Leica.Disto.Api.HardwareInterface.SensorBatteryState
  • VSensor : Leica.Disto.Api.HardwareInterface.SensorTemperatures

- w -

  • Width : Leica.Disto.Api.GeoMath.Size

- x -

  • X : Leica.Disto.Api.GeoMath.Point

- y -

  • Y : Leica.Disto.Api.GeoMath.Point
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Class Members - Events

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • BatteryStateChanged : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • InclinationPlaneChanged : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • LiveImageChanged : Leica.Disto.Api.HardwareInterface.ILiveImage
  • MeasurePolarEvent : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • RemoteControlKeyPressed : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
  • SensorDataChanged : Leica.Disto.Api.HardwareInterface.ISensorData , Leica.Disto.Api.SystemInterface.SensorData
  • SystemMessageReceived : Leica.Disto.Api.HardwareInterface.ISensorEvents , Leica.Disto.Api.SystemInterface.SensorInterface
Generated on Tue Feb 24 2015 14:07:41 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionCleanup
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup, including all inherited members.

ExceptionCleanup() | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanup(Exception nestedException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanup(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionCleanupInitialize
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize, including all inherited members.

ExceptionCleanup() | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanup(Exception nestedException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanup(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanupInitialize() | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize |
ExceptionCleanupInitialize(Exception nestedException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize |
ExceptionCleanupInitialize(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupInitialize | protected
ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionCleanupStop
Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop, including all inherited members.

ExceptionCleanup() | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanup(Exception nestedException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanup(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanup | protected
ExceptionCleanupStop() | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop |
ExceptionCleanupStop(Exception nestedException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop |
ExceptionCleanupStop(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCleanupStop | protected
ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionCore
Leica.Disto.Api.AsyncSubsystem.ExceptionCore Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionCore, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionError
Leica.Disto.Api.AsyncSubsystem.ExceptionError Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionError, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionInvalidParameter
Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionInvalidParameter() | Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter |
ExceptionInvalidParameter(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidParameter | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionInvalidState
Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionInvalidState() | Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState |
ExceptionInvalidState(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidState | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionInvalidUsage
Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionInvalidUsage() | Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage |
ExceptionInvalidUsage(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionInvalidUsage | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • ExceptionTimeout
Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionTimeout() | Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout |
ExceptionTimeout(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionTimeout | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • InterruptReasonMask
Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask, including all inherited members.

WakeMaskActionsAll | Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
WakeMaskActionsOne | Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
WakeMaskCommandAboveNormal | Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
WakeMaskCommandHigh | Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
WakeMaskDefault | Leica.Disto.Api.AsyncSubsystem.InterruptReasonMask
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • Subsystem
Leica.Disto.Api.AsyncSubsystem.Subsystem Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.Subsystem, including all inherited members.

ExitInstance() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
GetCurrentState() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
GetSubsystemID() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
InitInstance() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
Shutdown() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
Startup() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
Subsystem(string subsystemID, string instanceInfo) | Leica.Disto.Api.AsyncSubsystem.Subsystem | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • SyncObject
Leica.Disto.Api.AsyncSubsystem.SyncObject Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.SyncObject, including all inherited members.

_Evt | Leica.Disto.Api.AsyncSubsystem.SyncObject | protected
HasException() | Leica.Disto.Api.AsyncSubsystem.SyncObject | virtual
HasResult() | Leica.Disto.Api.AsyncSubsystem.SyncObject | virtual
operator WaitHandle(SyncObject p_Right) | Leica.Disto.Api.AsyncSubsystem.SyncObject | static
Result | Leica.Disto.Api.AsyncSubsystem.SyncObject |
ResultObj | Leica.Disto.Api.AsyncSubsystem.SyncObject | protected
Synchronize() | Leica.Disto.Api.AsyncSubsystem.SyncObject | virtual
Synchronize(int p_TimeoutMs) | Leica.Disto.Api.AsyncSubsystem.SyncObject | virtual
ToString() | Leica.Disto.Api.AsyncSubsystem.SyncObject |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • AsyncSubsystem
  • SyncObject< T >
Leica.Disto.Api.AsyncSubsystem.SyncObject< T > Member List

This is the complete list of members for Leica.Disto.Api.AsyncSubsystem.SyncObject< T >, including all inherited members.

_Evt | Leica.Disto.Api.AsyncSubsystem.SyncObject | protected
HasException() | Leica.Disto.Api.AsyncSubsystem.SyncObject | virtual
HasResult() | Leica.Disto.Api.AsyncSubsystem.SyncObject | virtual
operator WaitHandle(SyncObject p_Right) | Leica.Disto.Api.AsyncSubsystem.SyncObject | static
Result | Leica.Disto.Api.AsyncSubsystem.SyncObject< T > |
ResultObj | Leica.Disto.Api.AsyncSubsystem.SyncObject | protected
SignalCompletion(T p_Result) | Leica.Disto.Api.AsyncSubsystem.SyncObject< T > | virtual
Synchronize() | Leica.Disto.Api.AsyncSubsystem.SyncObject< T > | virtual
Synchronize(int p_TimeoutMs) | Leica.Disto.Api.AsyncSubsystem.SyncObject< T > | virtual
SyncObject() | Leica.Disto.Api.AsyncSubsystem.SyncObject< T > |
SyncObject(bool p_Signalled) | Leica.Disto.Api.AsyncSubsystem.SyncObject< T > |
ToString() | Leica.Disto.Api.AsyncSubsystem.SyncObject |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • CommandInterface
  • ExceptionCommandInterface
Leica.Disto.Api.CommandInterface.ExceptionCommandInterface Member List

This is the complete list of members for Leica.Disto.Api.CommandInterface.ExceptionCommandInterface, including all inherited members.

ExceptionCommandInterface(string input, int location) | Leica.Disto.Api.CommandInterface.ExceptionCommandInterface |
ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
Input | Leica.Disto.Api.CommandInterface.ExceptionCommandInterface |
Location | Leica.Disto.Api.CommandInterface.ExceptionCommandInterface |
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • CommandInterface
  • Response
Leica.Disto.Api.CommandInterface.Response Member List

This is the complete list of members for Leica.Disto.Api.CommandInterface.Response, including all inherited members.

ErrorCode | Leica.Disto.Api.CommandInterface.Response
IsError | Leica.Disto.Api.CommandInterface.Response
Result | Leica.Disto.Api.CommandInterface.Response
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • CommandInterface
  • SnapshotImage
Leica.Disto.Api.CommandInterface.SnapshotImage Member List

This is the complete list of members for Leica.Disto.Api.CommandInterface.SnapshotImage, including all inherited members.

Crosshair | Leica.Disto.Api.CommandInterface.SnapshotImage
Data | Leica.Disto.Api.CommandInterface.SnapshotImage
Direction | Leica.Disto.Api.CommandInterface.SnapshotImage
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Configuration
  • SystemSettings
Leica.Disto.Api.Configuration.SystemSettings Member List

This is the complete list of members for Leica.Disto.Api.Configuration.SystemSettings, including all inherited members.

IpAddressRndis | Leica.Disto.Api.Configuration.SystemSettings | static
IpAddressWlan | Leica.Disto.Api.Configuration.SystemSettings | static
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • ExceptionEventInterface
Leica.Disto.Api.EventInterface.ExceptionEventInterface Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.ExceptionEventInterface, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionEventInterface(string input, int location) | Leica.Disto.Api.EventInterface.ExceptionEventInterface |
Input | Leica.Disto.Api.EventInterface.ExceptionEventInterface |
Location | Leica.Disto.Api.EventInterface.ExceptionEventInterface |
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEvent
Leica.Disto.Api.EventInterface.SensorEvent Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEvent, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventBatteryStateChanged
Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
Level | Leica.Disto.Api.EventInterface.SensorEventBatteryStateChanged |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventCalibration
Leica.Disto.Api.EventInterface.SensorEventCalibration Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventCalibration, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventInclinationPlaneChanged
Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
State | Leica.Disto.Api.EventInterface.SensorEventInclinationPlaneChanged |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventMeasurePolar
Leica.Disto.Api.EventInterface.SensorEventMeasurePolar Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventMeasurePolar, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
Image | Leica.Disto.Api.EventInterface.SensorEventMeasurePolar |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
SensorPoint | Leica.Disto.Api.EventInterface.SensorEventMeasurePolar |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventMotorStopped
Leica.Disto.Api.EventInterface.SensorEventMotorStopped Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventMotorStopped, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
Axis | Leica.Disto.Api.EventInterface.SensorEventMotorStopped |
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventRemoteControlKeyPressed
Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
Action | Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed |
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
Key | Leica.Disto.Api.EventInterface.SensorEventRemoteControlKeyPressed |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • EventInterface
  • SensorEventSystemMessage
Leica.Disto.Api.EventInterface.SensorEventSystemMessage Member List

This is the complete list of members for Leica.Disto.Api.EventInterface.SensorEventSystemMessage, including all inherited members.

_EventType | Leica.Disto.Api.EventInterface.SensorEvent | protected
BitNumber | Leica.Disto.Api.EventInterface.SensorEventSystemMessage |
CurrentState | Leica.Disto.Api.EventInterface.SensorEvent |
ErrorCode | Leica.Disto.Api.EventInterface.SensorEvent |
EventType | Leica.Disto.Api.EventInterface.SensorEvent |
GetSystemError() | Leica.Disto.Api.EventInterface.SensorEventSystemMessage |
GetSystemWarning() | Leica.Disto.Api.EventInterface.SensorEventSystemMessage |
IsError() | Leica.Disto.Api.EventInterface.SensorEvent |
MessageSet | Leica.Disto.Api.EventInterface.SensorEventSystemMessage |
MessageType | Leica.Disto.Api.EventInterface.SensorEventSystemMessage |
SensorEvent(EEvent p_EventType, int p_ErrorCode, SensorState p_CurrentState) | Leica.Disto.Api.EventInterface.SensorEvent | protected
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • Angle
Leica.Disto.Api.GeoMath.Angle Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.Angle, including all inherited members.

GetShortest(double p_From, double p_To) | Leica.Disto.Api.GeoMath.Angle | static
NormalAbsolute(double p_Angle) | Leica.Disto.Api.GeoMath.Angle | static
NormalRelative(double p_Angle) | Leica.Disto.Api.GeoMath.Angle | static
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • IdentifiedObject
Leica.Disto.Api.GeoMath.IdentifiedObject Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.IdentifiedObject, including all inherited members.

Equals(object p_Obj) | Leica.Disto.Api.GeoMath.IdentifiedObject |
Equals(IdentifiedObject p_IdentifiedObject) | Leica.Disto.Api.GeoMath.IdentifiedObject | virtual
GetHashCode() | Leica.Disto.Api.GeoMath.IdentifiedObject |
IdentifiedObject() | Leica.Disto.Api.GeoMath.IdentifiedObject |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • LiveImagePixelConverter
Leica.Disto.Api.GeoMath.LiveImagePixelConverter Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.LiveImagePixelConverter, including all inherited members.

GetOpticsConstant(EDeviceType deviceType) | Leica.Disto.Api.GeoMath.LiveImagePixelConverter | static
ImageSize | Leica.Disto.Api.GeoMath.LiveImagePixelConverter |
LiveImagePixelConverter(EDeviceType deviceType, Size imageSize) | Leica.Disto.Api.GeoMath.LiveImagePixelConverter |
ToImagePoint(SensorPoint sensorPoint) | Leica.Disto.Api.GeoMath.LiveImagePixelConverter |
ToPolarCoordinates(Point imagePoint) | Leica.Disto.Api.GeoMath.LiveImagePixelConverter |
UpdateValues(SensorDirection sensorDirection, VerticalAxisFace imageOrientation, ImageZoom zoomFactor, Point crosshair) | Leica.Disto.Api.GeoMath.LiveImagePixelConverter |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • SensorDirection
Leica.Disto.Api.GeoMath.SensorDirection Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.SensorDirection, including all inherited members.

Clone() | Leica.Disto.Api.GeoMath.SensorDirection | virtual
CompensatorState | Leica.Disto.Api.GeoMath.SensorDirection |
Equals(object p_Obj) | Leica.Disto.Api.GeoMath.IdentifiedObject |
Equals(IdentifiedObject p_IdentifiedObject) | Leica.Disto.Api.GeoMath.IdentifiedObject | virtual
GetHashCode() | Leica.Disto.Api.GeoMath.IdentifiedObject |
GetInFaceOne() | Leica.Disto.Api.GeoMath.SensorDirection | virtual
Hz | Leica.Disto.Api.GeoMath.SensorDirection |
IdentifiedObject() | Leica.Disto.Api.GeoMath.IdentifiedObject |
NiHz | Leica.Disto.Api.GeoMath.SensorDirection |
NiV | Leica.Disto.Api.GeoMath.SensorDirection |
SensorDirection() | Leica.Disto.Api.GeoMath.SensorDirection |
SensorDirection(double p_Hz, double p_V, double p_NiHz, double p_NiV, int p_CompensatorState) | Leica.Disto.Api.GeoMath.SensorDirection |
V | Leica.Disto.Api.GeoMath.SensorDirection |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • SensorIncline
Leica.Disto.Api.GeoMath.SensorIncline Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.SensorIncline, including all inherited members.

CompensatorState | Leica.Disto.Api.GeoMath.SensorIncline
ICross | Leica.Disto.Api.GeoMath.SensorIncline
IHz | Leica.Disto.Api.GeoMath.SensorIncline
ILen | Leica.Disto.Api.GeoMath.SensorIncline
Raw | Leica.Disto.Api.GeoMath.SensorIncline
SensorIncline(bool p_RawValues) | Leica.Disto.Api.GeoMath.SensorIncline
SensorIncline(double p_IHz, double p_ILen, double p_ICross, int p_CompensatorState, bool p_RawValues) | Leica.Disto.Api.GeoMath.SensorIncline
ToString() | Leica.Disto.Api.GeoMath.SensorIncline
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • SensorPoint
Leica.Disto.Api.GeoMath.SensorPoint Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.SensorPoint, including all inherited members.

CompensatorState | Leica.Disto.Api.GeoMath.SensorPoint |
Dist | Leica.Disto.Api.GeoMath.SensorPoint |
Equals(object p_Obj) | Leica.Disto.Api.GeoMath.IdentifiedObject |
Equals(IdentifiedObject p_IdentifiedObject) | Leica.Disto.Api.GeoMath.IdentifiedObject | virtual
GetHashCode() | Leica.Disto.Api.GeoMath.IdentifiedObject |
GetHorDist() | Leica.Disto.Api.GeoMath.SensorPoint | virtual
GetHorDist(SensorPoint p_SecondPoint) | Leica.Disto.Api.GeoMath.SensorPoint | virtual
GetInFaceOne() | Leica.Disto.Api.GeoMath.SensorPoint | virtual
GetVertDist() | Leica.Disto.Api.GeoMath.SensorPoint | virtual
Hz | Leica.Disto.Api.GeoMath.SensorPoint |
IdentifiedObject() | Leica.Disto.Api.GeoMath.IdentifiedObject |
NiHz | Leica.Disto.Api.GeoMath.SensorPoint |
NiV | Leica.Disto.Api.GeoMath.SensorPoint |
SensorPoint() | Leica.Disto.Api.GeoMath.SensorPoint |
SensorPoint(double p_Hz, double p_V, double p_Dist, double p_NiHz, double p_NiV, InclinationPlaneState p_CompensatorState, int p_SensorSerialNumber) | Leica.Disto.Api.GeoMath.SensorPoint |
SensorSerialNumber | Leica.Disto.Api.GeoMath.SensorPoint |
ToString() | Leica.Disto.Api.GeoMath.SensorPoint |
V | Leica.Disto.Api.GeoMath.SensorPoint |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • Vector
Leica.Disto.Api.GeoMath.Vector Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.Vector, including all inherited members.

AreParallel(Vector p_Vector1, Vector p_Vector2, double p_MaxAngle, bool p_SameDirection) | Leica.Disto.Api.GeoMath.Vector | static
Clone() | Leica.Disto.Api.GeoMath.Vector | virtual
CrossProduct(Vector p_Vector1, Vector p_Vector2) | Leica.Disto.Api.GeoMath.Vector | static
DeltaEast | Leica.Disto.Api.GeoMath.Vector |
DeltaH | Leica.Disto.Api.GeoMath.Vector |
DeltaNorth | Leica.Disto.Api.GeoMath.Vector |
Equals(object p_Obj) | Leica.Disto.Api.GeoMath.IdentifiedObject |
Equals(IdentifiedObject p_IdentifiedObject) | Leica.Disto.Api.GeoMath.IdentifiedObject | virtual
GetAngle(Vector p_SecondVector) | Leica.Disto.Api.GeoMath.Vector | virtual
GetHashCode() | Leica.Disto.Api.GeoMath.IdentifiedObject |
IdentifiedObject() | Leica.Disto.Api.GeoMath.IdentifiedObject |
Length | Leica.Disto.Api.GeoMath.Vector |
operator*(double p_Number, Vector p_Vector) | Leica.Disto.Api.GeoMath.Vector | static
operator*(Vector p_Vector, double p_Number) | Leica.Disto.Api.GeoMath.Vector | static
operator+(Vector p_FirstVector, Vector p_SecondVector) | Leica.Disto.Api.GeoMath.Vector | static
operator-(Vector p_FirstVector, Vector p_SecondVector) | Leica.Disto.Api.GeoMath.Vector | static
ScalarProduct(Vector p_Vector1, Vector p_Vector2) | Leica.Disto.Api.GeoMath.Vector | static
ToString() | Leica.Disto.Api.GeoMath.Vector |
V1 | Leica.Disto.Api.GeoMath.Vector |
V2 | Leica.Disto.Api.GeoMath.Vector |
V3 | Leica.Disto.Api.GeoMath.Vector |
Vector(double p_DeltaEast, double p_DeltaNorth, double p_DeltaH) | Leica.Disto.Api.GeoMath.Vector |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • RemoteControlKey
Leica.Disto.Api.HardwareInterface.RemoteControlKey Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.RemoteControlKey, including all inherited members.

Code | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
Dist | Leica.Disto.Api.HardwareInterface.RemoteControlKey | static
Down | Leica.Disto.Api.HardwareInterface.RemoteControlKey | static
IsDist() | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
IsDown() | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
IsLeft() | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
IsRight() | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
IsUp() | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
Left | Leica.Disto.Api.HardwareInterface.RemoteControlKey | static
RemoteControlKey(int p_Code) | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
Right | Leica.Disto.Api.HardwareInterface.RemoteControlKey | static
ToString() | Leica.Disto.Api.HardwareInterface.RemoteControlKey |
Up | Leica.Disto.Api.HardwareInterface.RemoteControlKey | static
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • Resolution5Mpix
Leica.Disto.Api.HardwareInterface.Resolution5Mpix Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.Resolution5Mpix, including all inherited members.

Height | Leica.Disto.Api.HardwareInterface.Resolution5Mpix
Width | Leica.Disto.Api.HardwareInterface.Resolution5Mpix
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ResolutionDVGA
Leica.Disto.Api.HardwareInterface.ResolutionDVGA Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ResolutionDVGA, including all inherited members.

Height | Leica.Disto.Api.HardwareInterface.ResolutionDVGA
Width | Leica.Disto.Api.HardwareInterface.ResolutionDVGA
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ResolutionQVGA
Leica.Disto.Api.HardwareInterface.ResolutionQVGA Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ResolutionQVGA, including all inherited members.

Height | Leica.Disto.Api.HardwareInterface.ResolutionQVGA
Width | Leica.Disto.Api.HardwareInterface.ResolutionQVGA
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ResolutionSVGA
Leica.Disto.Api.HardwareInterface.ResolutionSVGA Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ResolutionSVGA, including all inherited members.

Height | Leica.Disto.Api.HardwareInterface.ResolutionSVGA
Width | Leica.Disto.Api.HardwareInterface.ResolutionSVGA
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ResolutionUXGA
Leica.Disto.Api.HardwareInterface.ResolutionUXGA Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ResolutionUXGA, including all inherited members.

Height | Leica.Disto.Api.HardwareInterface.ResolutionUXGA
Width | Leica.Disto.Api.HardwareInterface.ResolutionUXGA
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ResolutionVGA
Leica.Disto.Api.HardwareInterface.ResolutionVGA Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ResolutionVGA, including all inherited members.

Height | Leica.Disto.Api.HardwareInterface.ResolutionVGA
Width | Leica.Disto.Api.HardwareInterface.ResolutionVGA
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • SensorBatteryState
Leica.Disto.Api.HardwareInterface.SensorBatteryState Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.SensorBatteryState, including all inherited members.

ChargingLevel | Leica.Disto.Api.HardwareInterface.SensorBatteryState
SensorBatteryState() | Leica.Disto.Api.HardwareInterface.SensorBatteryState
SensorBatteryState(double p_Voltage, int p_ChargingLevel) | Leica.Disto.Api.HardwareInterface.SensorBatteryState
Voltage | Leica.Disto.Api.HardwareInterface.SensorBatteryState
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • SensorError
Leica.Disto.Api.HardwareInterface.SensorError Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.SensorError, including all inherited members.

EdmWorkingRange | Leica.Disto.Api.HardwareInterface.SensorError
HzMotorBlocked | Leica.Disto.Api.HardwareInterface.SensorError
HzOutOfRange | Leica.Disto.Api.HardwareInterface.SensorError
LevCalibrationCancelled | Leica.Disto.Api.HardwareInterface.SensorError
LevCalibrationChanged | Leica.Disto.Api.HardwareInterface.SensorError
LevelSensorInitializing | Leica.Disto.Api.HardwareInterface.SensorError
LevOutOfWorkingRange | Leica.Disto.Api.HardwareInterface.SensorError
VMotorBlocked | Leica.Disto.Api.HardwareInterface.SensorError
VOutOfRange | Leica.Disto.Api.HardwareInterface.SensorError
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • SensorTemperatures
Leica.Disto.Api.HardwareInterface.SensorTemperatures Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.SensorTemperatures, including all inherited members.

EdmSensor | Leica.Disto.Api.HardwareInterface.SensorTemperatures
HzSensor | Leica.Disto.Api.HardwareInterface.SensorTemperatures
SensorTemperatures() | Leica.Disto.Api.HardwareInterface.SensorTemperatures
VSensor | Leica.Disto.Api.HardwareInterface.SensorTemperatures
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Logging
  • DummyLogger
Leica.Disto.Api.Logging.DummyLogger Member List

This is the complete list of members for Leica.Disto.Api.Logging.DummyLogger, including all inherited members.

Debug(object message) | Leica.Disto.Api.Logging.DummyLogger
Error(object message) | Leica.Disto.Api.Logging.DummyLogger
Error(object message, Exception exception) | Leica.Disto.Api.Logging.DummyLogger
Info(object message) | Leica.Disto.Api.Logging.DummyLogger
Info(object message, Exception exception) | Leica.Disto.Api.Logging.DummyLogger
Warn(object message) | Leica.Disto.Api.Logging.DummyLogger
Warn(object message, Exception exception) | Leica.Disto.Api.Logging.DummyLogger
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • AxisData
Leica.Disto.Api.SystemInterface.AxisData Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.AxisData, including all inherited members.

Angle | Leica.Disto.Api.SystemInterface.AxisData
Axis | Leica.Disto.Api.SystemInterface.AxisData
AxisData(SensorData p_Owner, PositioningAxis p_Axis, double p_Angle, PositioningDirection p_Direction, int p_Velocity) | Leica.Disto.Api.SystemInterface.AxisData
Direction | Leica.Disto.Api.SystemInterface.AxisData
NiAngle | Leica.Disto.Api.SystemInterface.AxisData
State | Leica.Disto.Api.SystemInterface.AxisData
Velocity | Leica.Disto.Api.SystemInterface.AxisData
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • ExceptionEmptyImageBuffer
Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.ExceptionEmptyImageBuffer, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • ExceptionSensorInterface
Leica.Disto.Api.SystemInterface.ExceptionSensorInterface Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.ExceptionSensorInterface, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionSensorInterface() | Leica.Disto.Api.SystemInterface.ExceptionSensorInterface |
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • ExceptionUnsupportedCommand
Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.ExceptionUnsupportedCommand, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • ExceptionUnsupportedDeviceType
Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.ExceptionUnsupportedDeviceType, including all inherited members.

ExceptionCore() | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionCore(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
ExceptionError() | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(Exception innerException) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
ExceptionError(SerializationInfo info, StreamingContext context) | Leica.Disto.Api.AsyncSubsystem.ExceptionError | protected
Logger | Leica.Disto.Api.AsyncSubsystem.ExceptionCore | protected
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • SensorData
Leica.Disto.Api.SystemInterface.SensorData Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.SensorData, including all inherited members.

AxisData(PositioningAxis p_Axis) | Leica.Disto.Api.SystemInterface.SensorData
BatteryState | Leica.Disto.Api.SystemInterface.SensorData
Clear(ESystemError p_Error) | Leica.Disto.Api.SystemInterface.SensorData
Clear(ESystemWarning p_Warning) | Leica.Disto.Api.SystemInterface.SensorData
DeviceType | Leica.Disto.Api.SystemInterface.SensorData
EquipmentNumber | Leica.Disto.Api.SystemInterface.SensorData
Face | Leica.Disto.Api.SystemInterface.SensorData
GetErrors() | Leica.Disto.Api.SystemInterface.SensorData
GetWarnings() | Leica.Disto.Api.SystemInterface.SensorData
ImageBrightness | Leica.Disto.Api.SystemInterface.SensorData
ImageMode | Leica.Disto.Api.SystemInterface.SensorData
ImageZoom | Leica.Disto.Api.SystemInterface.SensorData
InclinationPlaneState | Leica.Disto.Api.SystemInterface.SensorData
IsSet(ESystemError p_Error) | Leica.Disto.Api.SystemInterface.SensorData
IsSet(ESystemWarning p_Warning) | Leica.Disto.Api.SystemInterface.SensorData
LaserMode | Leica.Disto.Api.SystemInterface.SensorData
LevelMode | Leica.Disto.Api.SystemInterface.SensorData
LevelSensitivity | Leica.Disto.Api.SystemInterface.SensorData
OperatingHours | Leica.Disto.Api.SystemInterface.SensorData
PinState | Leica.Disto.Api.SystemInterface.SensorData
Reset() | Leica.Disto.Api.SystemInterface.SensorData
SecurityEnabled | Leica.Disto.Api.SystemInterface.SensorData
SensorData() | Leica.Disto.Api.SystemInterface.SensorData
SensorDataChanged | Leica.Disto.Api.SystemInterface.SensorData
SensorDirection | Leica.Disto.Api.SystemInterface.SensorData
SensorIp | Leica.Disto.Api.SystemInterface.SensorData
SerialNumber | Leica.Disto.Api.SystemInterface.SensorData
Set(ESystemError p_Error) | Leica.Disto.Api.SystemInterface.SensorData
Set(ESystemWarning p_Warning) | Leica.Disto.Api.SystemInterface.SensorData
SetErrors(UInt16 p_ErrorBits) | Leica.Disto.Api.SystemInterface.SensorData
SetWarnings(UInt16 p_WarningBits) | Leica.Disto.Api.SystemInterface.SensorData
State | Leica.Disto.Api.SystemInterface.SensorData
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • SystemInterface
  • SensorInterface
Leica.Disto.Api.SystemInterface.SensorInterface Member List

This is the complete list of members for Leica.Disto.Api.SystemInterface.SensorInterface, including all inherited members.

ApiVersion | Leica.Disto.Api.SystemInterface.SensorInterface |
BatteryStateChanged | Leica.Disto.Api.SystemInterface.SensorInterface |
Connect(string sensorIp) | Leica.Disto.Api.SystemInterface.SensorInterface |
DisableLiveImage() | Leica.Disto.Api.SystemInterface.SensorInterface |
Disconnect() | Leica.Disto.Api.SystemInterface.SensorInterface |
EnableLiveImage() | Leica.Disto.Api.SystemInterface.SensorInterface |
EnterPin(int pin) | Leica.Disto.Api.SystemInterface.SensorInterface |
EnterPuk(int puk) | Leica.Disto.Api.SystemInterface.SensorInterface |
ExitInstance() | Leica.Disto.Api.SystemInterface.SensorInterface | virtual
GetBatteryState() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetCurrentState() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
GetFace() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetLedSyserror() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetLedWarning() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetMotorStatus(PositioningAxis axis) | Leica.Disto.Api.SystemInterface.SensorInterface |
GetSerialNumber() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetSoftwareVersion() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetSubsystemID() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
GetTemperatures() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetTiltSensitivity() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetWlanChannel() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetWlanEssid() | Leica.Disto.Api.SystemInterface.SensorInterface |
GetWlanFreq() | Leica.Disto.Api.SystemInterface.SensorInterface |
InclinationPlaneChanged | Leica.Disto.Api.SystemInterface.SensorInterface |
InitInstance() | Leica.Disto.Api.SystemInterface.SensorInterface | virtual
LiveImage | Leica.Disto.Api.SystemInterface.SensorInterface |
MeasureAngle() | Leica.Disto.Api.SystemInterface.SensorInterface |
MeasureIncline() | Leica.Disto.Api.SystemInterface.SensorInterface |
MeasurePolar() | Leica.Disto.Api.SystemInterface.SensorInterface |
MeasurePolarEvent | Leica.Disto.Api.SystemInterface.SensorInterface |
Ping() | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionAbsolute(PositioningAxis axis, double angle) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionAbsolute(double horizontal, double vertical) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionAbsoluteNi(PositioningAxis axis, double angleNi) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionAbsoluteNi(double horizontalNi, double verticalNi) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionAccelerate(PositioningAxis axis, int velocity, PositioningDirection direction) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionRelative(PositioningAxis axis, double angle) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionRelative(double horizontal, double vertical) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionRelativeNi(PositioningAxis axis, double angleNi) | Leica.Disto.Api.SystemInterface.SensorInterface |
PositionRelativeNi(double horizontalNi, double verticalNi) | Leica.Disto.Api.SystemInterface.SensorInterface |
PowerOff() | Leica.Disto.Api.SystemInterface.SensorInterface |
RemoteControlKeyPressed | Leica.Disto.Api.SystemInterface.SensorInterface |
SensorData | Leica.Disto.Api.SystemInterface.SensorInterface |
SensorInterface() | Leica.Disto.Api.SystemInterface.SensorInterface |
SetImageBrightness(ImageBrightness p_ImageBrightness) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetImageZoom(ImageZoom zoomFactor) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetLaserMode(LaserMode laserMode) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetLevelMode(LevelMode levelMode) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetPin(int pin) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetPositioningDirection(PositioningAxis axis, PositioningDirection direction) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetPositioningVelocity(PositioningAxis axis, int velocity) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetTiltSensitivity(TiltSensorMode mode) | Leica.Disto.Api.SystemInterface.SensorInterface |
SetWlanChannel(int channel, bool appendChannelToEssid) | Leica.Disto.Api.SystemInterface.SensorInterface |
Shutdown() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
Snapshot(ImageResolution resolution) | Leica.Disto.Api.SystemInterface.SensorInterface |
StartPositioning(PositioningAxis axis) | Leica.Disto.Api.SystemInterface.SensorInterface |
Startup() | Leica.Disto.Api.AsyncSubsystem.Subsystem | virtual
StopPositioning(PositioningAxis axis) | Leica.Disto.Api.SystemInterface.SensorInterface |
Subsystem(string subsystemID, string instanceInfo) | Leica.Disto.Api.AsyncSubsystem.Subsystem | protected
SystemMessageReceived | Leica.Disto.Api.SystemInterface.SensorInterface |
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • IpDeviceDescriptor
Leica.Disto.Networking.IpDeviceDescriptor Member List

This is the complete list of members for Leica.Disto.Networking.IpDeviceDescriptor, including all inherited members.

IpAdress | Leica.Disto.Networking.IpDeviceDescriptor
IpDeviceDescriptor(string p_IPAdress, string p_SerialNumber, string p_SoftwareName, string p_SoftwareVersion, string p_SoftwareVersionWlan) | Leica.Disto.Networking.IpDeviceDescriptor
SerialNumber | Leica.Disto.Networking.IpDeviceDescriptor
SoftwareName | Leica.Disto.Networking.IpDeviceDescriptor
SoftwareVersion | Leica.Disto.Networking.IpDeviceDescriptor
SoftwareVersionWlan | Leica.Disto.Networking.IpDeviceDescriptor
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • PlatformWindowsNet
Leica.Disto.Networking.PlatformWindowsNet Member List

This is the complete list of members for Leica.Disto.Networking.PlatformWindowsNet, including all inherited members.

CheckRndisIp(string sensorRndisIp) | Leica.Disto.Networking.PlatformWindowsNet |
ConnectToDistoWlanNetwork(WlanInterfaceWithNetwork p_Net, bool p_UseExistingProfile) | Leica.Disto.Networking.PlatformWindowsNet |
DisableWlan() | Leica.Disto.Networking.PlatformWindowsNet |
EnableWlan(string adapterName, string essid, string sensorWlanIp) | Leica.Disto.Networking.PlatformWindowsNet | virtual
EnableWlan(string adapterName, string essid, string sensorWlanIp, bool useExistingProfile) | Leica.Disto.Networking.PlatformWindowsNet | virtual
EnableWlan(string adapterName, string essid, string sensorWlanIp, string key) | Leica.Disto.Networking.PlatformWindowsNet | virtual
EnableWlan(string adapterName, string essid, string sensorWlanIp, string key, bool useExistingProfile) | Leica.Disto.Networking.PlatformWindowsNet | virtual
GetDistoWlanNetworks() | Leica.Disto.Networking.PlatformWindowsNet |
GetWlanInterfaces() | Leica.Disto.Networking.PlatformWindowsNet |
PlatformWindowsNet() | Leica.Disto.Networking.PlatformWindowsNet |
ScanForDistoDevices() | Leica.Disto.Networking.PlatformWindowsNet |
ScanWlanNetworks(string wlanInterfaceName) | Leica.Disto.Networking.PlatformWindowsNet |
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • PlatformWindowsNet
  • WlanInterfaceWithNetwork
Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork Member List

This is the complete list of members for Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork, including all inherited members.

Adapter | Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
Network | Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
WlanInterfaceWithNetwork(string ssid, uint linkQuality, string adapter) | Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
WlanInterfaceWithNetwork(WlanNetwork network, string p_Adapter) | Leica.Disto.Networking.PlatformWindowsNet.WlanInterfaceWithNetwork
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • PlatformWindowsNet
  • WlanNetwork
Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork Member List

This is the complete list of members for Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork, including all inherited members.

Key | Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
LinkQuality | Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
Secured | Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
Ssid | Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
WlanNetwork(string p_Ssid, uint p_LinkQuality) | Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
WlanNetwork(string p_Ssid, uint p_LinkQuality, bool p_Secured, string p_Key) | Leica.Disto.Networking.PlatformWindowsNet.WlanNetwork
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • Windows
  • DistoOnWlanSearcher
Leica.Disto.Networking.Windows.DistoOnWlanSearcher Member List

This is the complete list of members for Leica.Disto.Networking.Windows.DistoOnWlanSearcher, including all inherited members.

Finished() | Leica.Disto.Networking.Windows.DistoOnWlanSearcher
GetIpDeviceDescriptorList() | Leica.Disto.Networking.Windows.DistoOnWlanSearcher
StartSearch() | Leica.Disto.Networking.Windows.DistoOnWlanSearcher
Stop() | Leica.Disto.Networking.Windows.DistoOnWlanSearcher
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • Windows
  • UDPer
Leica.Disto.Networking.Windows.UDPer Member List

This is the complete list of members for Leica.Disto.Networking.Windows.UDPer, including all inherited members.

Finished() | Leica.Disto.Networking.Windows.UDPer
Send(string message) | Leica.Disto.Networking.Windows.UDPer
Start() | Leica.Disto.Networking.Windows.UDPer
Stop() | Leica.Disto.Networking.Windows.UDPer
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • WlanInterfaceException
Leica.Disto.Networking.WlanInterfaceException Member List

This is the complete list of members for Leica.Disto.Networking.WlanInterfaceException, including all inherited members.

WlanInterfaceException() | Leica.Disto.Networking.WlanInterfaceException
WlanInterfaceException(string p_Message, Exception p_InnerException) | Leica.Disto.Networking.WlanInterfaceException
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Properties Directory Reference

  • Develop
  • Api
  • Api
  • Properties
Properties Directory Reference

Files

file Api/Properties/AssemblyInfo.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Api Directory Reference

  • Develop
  • Api
Api Directory Reference

Directories

directory | Api
directory | Networking
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Windows Directory Reference

  • Develop
  • Api
  • Networking
  • Windows
Windows Directory Reference

Files

file | DistoOnWlanSearcher.cs
file | IpDeviceDescriptor.cs
file | TcpConfig.cs
file | UDPer.cs
file | WinInterop.cs
file | WinWlanApi.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Properties Directory Reference

  • Develop
  • Api
  • Networking
  • Properties
Properties Directory Reference

Files

file Networking/Properties/AssemblyInfo.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Develop Directory Reference

  • Develop
Develop Directory Reference

Directories

directory Api
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Communication Directory Reference

  • Develop
  • Api
  • Api
  • Communication
Communication Directory Reference

Files

file | ConnectionManager.cs
file | ConnectionMonitor.cs
file | Connector.cs
file | Communication/Constants.cs
file | Communication/Exceptions.cs
file | IForwarder.cs
file | IListener.cs
file | IReceiver.cs
file | Message.cs
file | TcpForwarder.cs
file | TcpListener.cs
file | TcpReceiver.cs
file | UdpListener.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Logging Directory Reference

  • Develop
  • Api
  • Api
  • Logging
Logging Directory Reference

Files

file | DummyLogger.cs
file | ILog.cs
file | Log4NetLogger.cs
file | LogManager.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Networking Directory Reference

  • Develop
  • Api
  • Networking
Networking Directory Reference

Directories

directory | Properties
directory | Windows

Files

file | PlatformWindows.cs
file | WlanInterfaceException.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: GeoMath Directory Reference

  • Develop
  • Api
  • Api
  • GeoMath
GeoMath Directory Reference

Files

file | Angle.cs
file | GeoMath/Constants.cs
file | GeoMath/Enumerations.cs
file | IdentifiedObject.cs
file | LiveImagePixelConverter.cs
file | Point.cs
file | SensorDirection.cs
file | SensorIncline.cs
file | SensorPoint.cs
file | Size.cs
file | Vector.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: AsyncSubsystem Directory Reference

  • Develop
  • Api
  • Api
  • AsyncSubsystem
AsyncSubsystem Directory Reference

Files

file | Action.cs
file | CommandQueue.cs
file | Commands.cs
file | AsyncSubsystem/Enumerations.cs
file | AsyncSubsystem/Exceptions.cs
file | IWorkItemQueue.cs
file | State.cs
file | StateMachineContext.cs
file | StateMachineEngine.cs
file | Subsystem.cs
file | SubsystemImplementation.cs
file | SubsystemState.cs
file | SyncObject.cs
file | Threads.cs
file | ThreadWorkImplementation.cs
file | WorkItemQueue.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: CommandInterface Directory Reference

  • Develop
  • Api
  • Api
  • CommandInterface
CommandInterface Directory Reference

Files

file | Cmds.cs
file | CommandFactory.cs
file | CommandInterpreter.cs
file | CommandInterface/Exceptions.cs
file | Lexer.cs
file | Parser.cs
file | Response.cs
file | ResultBuilders.cs
file | SnapshotImage.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Configuration Directory Reference

  • Develop
  • Api
  • Api
  • Configuration
Configuration Directory Reference

Files

file SystemSettings.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: EventInterface Directory Reference

  • Develop
  • Api
  • Api
  • EventInterface
EventInterface Directory Reference

Files

file | EventInterpreter.cs
file | EventInterface/Exceptions.cs
file | SensorEvents.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: HardwareInterface Directory Reference

  • Develop
  • Api
  • Api
  • HardwareInterface
HardwareInterface Directory Reference

Files

file | Definitions.cs
file | EDataIdentifier.cs
file | EDeviceType.cs
file | HardwareInterface/Enumerations.cs
file | ESystemError.cs
file | ILiveImage.cs
file | InterfaceTypes.cs
file | ISensorData.cs
file | ISensorEvent.cs
file | ISensorEvents.cs
file | ISnapImage.cs
file | RemoteControlKey.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Api Directory Reference

  • Develop
  • Api
  • Api
Api Directory Reference

Directories

directory | AsyncSubsystem
directory | CommandInterface
directory | Communication
directory | Configuration
directory | EventInterface
directory | GeoMath
directory | HardwareInterface
directory | Logging
directory | Properties
directory | SystemInterface
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: SystemInterface Directory Reference

  • Develop
  • Api
  • Api
  • SystemInterface
SystemInterface Directory Reference

Files

file | SystemInterface/Enumerations.cs
file | SystemInterface/Exceptions.cs
file | LiveImage.cs
file | RingBuf.cs
file | SensorActions.cs
file | SensorCommands.cs
file | SensorData.cs
file | SensorDataMonitor.cs
file | SensorImplementation.cs
file | SensorInterface.cs
file | SensorStateMachineEngine.cs
file | StateCalibratingLevelSensor.cs
file | StateConfiguring.cs
file | StateConfiguringSecurity.cs
file | StateConnecting.cs
file | StateCreated.cs
file | StateDisconnected.cs
file | StateDisconnecting.cs
file | StateGettingBatteryState.cs
file | StateGettingDeviceType.cs
file | StateGettingFace.cs
file | StateGettingImageSnap.cs
file | StateGettingLevelStatus.cs
file | StateGettingMotorStatus.cs
file | StateGettingTemperatures.cs
file | StateGettingValue.cs
file | StateInitGettingBatteryState.cs
file | StateInitGettingEquipmentNumber.cs
file | StateInitGettingOperationHours.cs
file | StateInitGettingSerialNumber.cs
file | StateInitGettingValues.cs
file | StateInitGettingWlanChannelNumber.cs
file | StateInitialized.cs
file | StateInitializing.cs
file | StateInitMeasuringAngle.cs
file | StateInitSettingImageBrightness.cs
file | StateInitSettingImageMode.cs
file | StateInitSettingImageZoom.cs
file | StateInitSettingLaserMode.cs
file | StateInitSettingMotorPolling.cs
file | StateInitUnlockingCompensator.cs
file | StateMeasuring.cs
file | StateMeasuringAngle.cs
file | StateMeasuringIncline.cs
file | StateMeasuringPolar.cs
file | StateMoving.cs
file | StateOffLevel.cs
file | StatePinging.cs
file | StatePingingEventChannel.cs
file | StatePosition.cs
file | StatePositionAbsolute.cs
file | StatePositionContinuous.cs
file | StatePositioning.cs
file | StatePositionRelative.cs
file | StatePoweringOff.cs
file | StateProcessing.cs
file | StateReady.cs
file | StateSensor.cs
file | StateSettingImageBrightness.cs
file | StateSettingImageMode.cs
file | StateSettingImageZoom.cs
file | StateSettingLaserMode.cs
file | StateSettingLevelMode.cs
file | StateSettingValue.cs
file | StateTerminated.cs
file | StateTerminatingProcessing.cs
file | UdpSender.cs
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Main Page

Leica Disto API Documentation

This is an API for the Leica Disto.

Starting point for the API is the class SensorInterface .

Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • IAxisData
Leica.Disto.Api.HardwareInterface.IAxisData Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.IAxisData, including all inherited members.

Angle | Leica.Disto.Api.HardwareInterface.IAxisData
Axis | Leica.Disto.Api.HardwareInterface.IAxisData
Direction | Leica.Disto.Api.HardwareInterface.IAxisData
NiAngle | Leica.Disto.Api.HardwareInterface.IAxisData
State | Leica.Disto.Api.HardwareInterface.IAxisData
Velocity | Leica.Disto.Api.HardwareInterface.IAxisData
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ILiveImage
Leica.Disto.Api.HardwareInterface.ILiveImage Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ILiveImage, including all inherited members.

Get(out SensorDirection direction, out Point crosshair, out VerticalAxisFace orientation, out byte[] buffer, out int bufferSize) | Leica.Disto.Api.HardwareInterface.ILiveImage
LiveImageChanged | Leica.Disto.Api.HardwareInterface.ILiveImage
Set(byte[] p_RawData, int p_Size) | Leica.Disto.Api.HardwareInterface.ILiveImage
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ISensorData
Leica.Disto.Api.HardwareInterface.ISensorData Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ISensorData, including all inherited members.

AxisData(PositioningAxis p_Axis) | Leica.Disto.Api.HardwareInterface.ISensorData
BatteryState | Leica.Disto.Api.HardwareInterface.ISensorData
Clear(ESystemError p_Error) | Leica.Disto.Api.HardwareInterface.ISensorData
Clear(ESystemWarning p_Warning) | Leica.Disto.Api.HardwareInterface.ISensorData
DeviceType | Leica.Disto.Api.HardwareInterface.ISensorData
EquipmentNumber | Leica.Disto.Api.HardwareInterface.ISensorData
Face | Leica.Disto.Api.HardwareInterface.ISensorData
GetErrors() | Leica.Disto.Api.HardwareInterface.ISensorData
GetWarnings() | Leica.Disto.Api.HardwareInterface.ISensorData
ImageBrightness | Leica.Disto.Api.HardwareInterface.ISensorData
ImageMode | Leica.Disto.Api.HardwareInterface.ISensorData
ImageZoom | Leica.Disto.Api.HardwareInterface.ISensorData
InclinationPlaneState | Leica.Disto.Api.HardwareInterface.ISensorData
IsSet(ESystemError p_Error) | Leica.Disto.Api.HardwareInterface.ISensorData
IsSet(ESystemWarning p_Warning) | Leica.Disto.Api.HardwareInterface.ISensorData
LaserMode | Leica.Disto.Api.HardwareInterface.ISensorData
LevelMode | Leica.Disto.Api.HardwareInterface.ISensorData
LevelSensitivity | Leica.Disto.Api.HardwareInterface.ISensorData
OperatingHours | Leica.Disto.Api.HardwareInterface.ISensorData
Reset() | Leica.Disto.Api.HardwareInterface.ISensorData
SecurityEnabled | Leica.Disto.Api.HardwareInterface.ISensorData
SensorDataChanged | Leica.Disto.Api.HardwareInterface.ISensorData
SensorDirection | Leica.Disto.Api.HardwareInterface.ISensorData
SensorIp | Leica.Disto.Api.HardwareInterface.ISensorData
SerialNumber | Leica.Disto.Api.HardwareInterface.ISensorData
Set(ESystemError p_Error) | Leica.Disto.Api.HardwareInterface.ISensorData
Set(ESystemWarning p_Warning) | Leica.Disto.Api.HardwareInterface.ISensorData
SetErrors(UInt16 p_ErrorBits) | Leica.Disto.Api.HardwareInterface.ISensorData
SetWarnings(UInt16 p_WarningBits) | Leica.Disto.Api.HardwareInterface.ISensorData
State | Leica.Disto.Api.HardwareInterface.ISensorData
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ISensorEvent
Leica.Disto.Api.HardwareInterface.ISensorEvent Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ISensorEvent, including all inherited members.

ErrorCode | Leica.Disto.Api.HardwareInterface.ISensorEvent
EventType | Leica.Disto.Api.HardwareInterface.ISensorEvent
IsError() | Leica.Disto.Api.HardwareInterface.ISensorEvent
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ISensorEvents
Leica.Disto.Api.HardwareInterface.ISensorEvents Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ISensorEvents, including all inherited members.

BatteryStateChanged | Leica.Disto.Api.HardwareInterface.ISensorEvents
InclinationPlaneChanged | Leica.Disto.Api.HardwareInterface.ISensorEvents
MeasurePolarEvent | Leica.Disto.Api.HardwareInterface.ISensorEvents
RemoteControlKeyPressed | Leica.Disto.Api.HardwareInterface.ISensorEvents
SystemMessageReceived | Leica.Disto.Api.HardwareInterface.ISensorEvents
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • HardwareInterface
  • ISnapImage
Leica.Disto.Api.HardwareInterface.ISnapImage Member List

This is the complete list of members for Leica.Disto.Api.HardwareInterface.ISnapImage, including all inherited members.

Crosshair | Leica.Disto.Api.HardwareInterface.ISnapImage
Data | Leica.Disto.Api.HardwareInterface.ISnapImage
Direction | Leica.Disto.Api.HardwareInterface.ISnapImage
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Logging
  • ILog
Leica.Disto.Api.Logging.ILog Member List

This is the complete list of members for Leica.Disto.Api.Logging.ILog, including all inherited members.

Debug(object message) | Leica.Disto.Api.Logging.ILog
Error(object message) | Leica.Disto.Api.Logging.ILog
Error(object message, Exception exception) | Leica.Disto.Api.Logging.ILog
Info(object message) | Leica.Disto.Api.Logging.ILog
Info(object message, Exception exception) | Leica.Disto.Api.Logging.ILog
Warn(object message) | Leica.Disto.Api.Logging.ILog
Warn(object message, Exception exception) | Leica.Disto.Api.Logging.ILog
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • Point
Leica.Disto.Api.GeoMath.Point Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.Point, including all inherited members.

Empty | Leica.Disto.Api.GeoMath.Point | static
Point(double p_X, double p_Y) | Leica.Disto.Api.GeoMath.Point |
X | Leica.Disto.Api.GeoMath.Point |
Y | Leica.Disto.Api.GeoMath.Point |
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • GeoMath
  • Size
Leica.Disto.Api.GeoMath.Size Member List

This is the complete list of members for Leica.Disto.Api.GeoMath.Size, including all inherited members.

Height | Leica.Disto.Api.GeoMath.Size
Size(int p_Width, int p_Height) | Leica.Disto.Api.GeoMath.Size
Width | Leica.Disto.Api.GeoMath.Size
Generated on Tue Feb 24 2015 14:07:39 for Leica Disto API by doxygen 1.8.6


Leica Disto API: Member List

  • Networking
  • Windows
  • Wlan
  • Dot11Ssid
Leica.Disto.Networking.Windows.Wlan.Dot11Ssid Member List

This is the complete list of members for Leica.Disto.Networking.Windows.Wlan.Dot11Ssid, including all inherited members.

SSID | Leica.Disto.Networking.Windows.Wlan.Dot11Ssid
SSIDLength | Leica.Disto.Networking.Windows.Wlan.Dot11Ssid
Generated on Tue Feb 24 2015 14:07:40 for Leica Disto API by doxygen 1.8.6